Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Firefox 24+ for ME and 98


 Share

Recommended Posts

Some tests on XP:
I mean that CID49/52 runs as good as FF49/52 on XP. CID needs the api-ms-win files just like Firefox. I can add them to system32 or the program folder. These were simply removed. Basically it is a Firefox with some additional security features/extensions. At this point, I cannot say whether these extensions are working properly here.
What doesn't work is the installer!


And I started Firefox on XP to compare about:support > failure log regarding "Unrecognized feature WEBRENDER".
I had set FF52 to Compositing Basic (Hardware Acceleration disabled) and this error info appeared here, too. Then on ME, I started CID50 without profile (first run), but with a prefs.js and Hardware Acceleration enabled/D3D9. With the result that the message did not appear at least for the time being.
It could be a new message/info of any failure regarding to a failing WebGL Renderer or feature. More research is needed to make this message clear.
Probably it will never possible to use webgl without driver support on ME/98.

Link to comment
Share on other sites

  • 2 weeks later...

Finally, I've found the problem. I'm running Firefox 52.9 esr. FF49+ doesn't run with the runtime files in the dependentlibs.list on ME. This means the runtime entries must be removed.

MyPal 28 and 29 start and run, too, but I've the issue of FF 28 - 44 "Input in address bar doesn't work after a while or second start anymore / Search Engine List is empty".

Link to comment
Share on other sites

Posted (edited)

Obviously the Firefox default APISet dll loading of dependentlibs.list doesn't get along with forwarding dll's in the registry by knownDlls here.

In details: The file "dependentlibs.list" is in the Firefox program folder.

MSVCP140.dll
api-ms-win-crt-runtime-l1-1-0.dll
api-ms-win-crt-string-l1-1-0.dll
api-ms-win-crt-heap-l1-1-0.dll
api-ms-win-crt-stdio-l1-1-0.dll
api-ms-win-crt-convert-l1-1-0.dll
VCRUNTIME140.dll
api-ms-win-crt-math-l1-1-0.dll
api-ms-win-crt-filesystem-l1-1-0.dll
api-ms-win-crt-environment-l1-1-0.dll
mozglue.dll
api-ms-win-crt-utility-l1-1-0.dll
api-ms-win-crt-time-l1-1-0.dll
api-ms-win-crt-multibyte-l1-1-0.dll
nss3.dll
lgpllibs.dll
api-ms-win-crt-locale-l1-1-0.dll
xul.dll

=> New: dependentlibs.list for Firefox 49 - 52.9 and Cyberfox 49/49.0.1

mozglue.dll
nss3.dll
lgpllibs.dll
xul.dll

----------------

I also had Thunderbird 52.9 running. Still to be noted - the account wizard doesn't open (it freezes on start).

MyPal: The "address bar workaround" to set search.json to read only may not work. I want to investigate further. The AzureContentBackend skia probably works fine on it.

dependentlibs.list for MyPal (28 / 29) and Centaury ( up to 0.16):

mozglue.dll
nss3.dll
gkmedias.dll
lgpllibs.dll
mozsqlite3.dll
xul.dll

Screenshot MyPal 29.2 on ME

Centaury crashed with skia AzureContentBackend. So leave cairo and use CTR.

dependentlibs.list for SeaMonkey (2.46 - 2.49.5) and Thunderbird (52 - 52.9.1):

LDAP60.dll
mozglue.dll
nss3.dll
PRLDAP60.dll
lgpllibs.dll
xul.dll

Msvcp140.dll and vcruntime140.dll aren't knowndll's and may remain in the file.

 

Edited by schwups
Link to comment
Share on other sites

9 hours ago, schwups said:

MyPal: The "address bar workaround" to set search.json to read only may not work. I want to investigate further.

After several attempts it worked.

Link to comment
Share on other sites

Hallo Jumper. So far, I have not examined or considered e10s in detail. Because of your request I have just tinkered with some settings on 52.9.

browser.tabs.remote.autostart
browser.tabs.remote.force-enable=true   =>  FF doesn't start
extensions.e10sMultiBlockedByAddons           52.9 haven't this boolean
dom.ipc.processCount
extensions.e10sBlockedByAddons        

extensions.e10sBlocksEnabling  (default true) => Troubleshootinginfo: "disabled by addons")  when set false => Info "WindowsXP"

I will test different settings more closely in the next days.

Quite a bit about Electrolysis: https://www.ghacks.net/2016/07/22/multi-process-firefox/

It remains exciting.

Link to comment
Share on other sites

The appropriate topic on MSFN: (https://msfn.org/board/topic/178466-force-multiprocess-mode-in-ff-52/)  So far I only have read the first page.

MyPal: e10s may not exist or is removed.

Centaury: e10s is disabled by default. I enabled it for the check. I had all extensions enabled and later I also had them disabled (PlainOldFavorites, CTR, CAA, GitHub Web Components Polyfill), but this haven't made a difference.  The first try was the worst. The Kext prompt appeared, because USER32.dll: RegisterTouchWindow (win7 API) was called and the user ressources (TaskManager) went down. I had to reboot. Then I disabled this API in the stubs.ini and I also tried different stubs, with the result that Electrolysis apparently basically works here (Multiprocess Windows: 2/2 enabled by user), but got an endless connecting (Tabs) with blank pages. Now I will finish reading Force "multiprocess mode" in FF 52 first.

Link to comment
Share on other sites

Posted (edited)

e10s:

FF52.9esr    on XP => probably OK         Multiprocess Windows:     2/2 (Enabled by user)
FF52.9esr    on ME => doesn't start without message

IceDragon 52 on XP => probably OK      Multiprocess Windows:     2/2 (Enabled by user)

IceDragon 52 on ME => doesn't start     "IceDragon has caused an error in IceDragon.exe"

Centaury on ME => Multiprocess Windows: 2/2 enabled by user, but got an endless connecting (Tabs) with blank pages.

Edited by schwups
Link to comment
Share on other sites

Posted (edited)

Today I tried to run FF 52, Centaury ...  on my other three active Win ME machines to verify that it works, to better isolate possible problems and to find out the exact requirements. So far I wasn't able to run these browser versions on my oldest system, Via PT880Ultra (P4V800D-X), P4 C Nothwood which meets SSE2, NV5900XT (AGP). The highest FF version I can run is 48.0.2, here.
There were no problems on the other two computers (iG31,P5KPL/1600, Core2Duo 8500, NV7900GS and i915, MS-7058, P640 Prescott, NV7800GT).

Requirements:

First get Firefox 48 running.

- Kexstubs.ini 

reg file APISets/Knowndlls

- The UCRTBASE.DLL version 10.0.14393.33 of Firefox 52.9 or 10.0.14393.795 must be in the system folder! Don't use version 10.0.16299.397 of MyPal or Centaury. The DependencyWalker also misses the concrt140.dll. So it can be added, too.

- dependentlibs.list

 

 

Issues:
Sporadic letters that were slightly out of place and reduced in size.
OE inbox doesn't always open (via winSSLwrap) when FF/MyPal/Centaury is running
Sometimes error in Kexstubs on start - second start always OK


MyPal:
Updater doesn't work
Sometimes I can't close Tabs after a while.
"Input in address bar doesn't work on second browser start anymore / Search Engine List is empty". See issues Firefox 28 - 44


Centaury/MyPal: Mostly seldom - Error in Xul (browser restart required)


Centaury:

https://github.com/Feodor2/Centaury/issues/32 Boolean must be added: svg.in-content.enabled;true (not only issue on ME)

The Search (Navigation Toolbar) doesn't work, if you set it back to "Old Search" with the ClassicThemeRestorer (Search Bar > Page 1).

 

And see FF issues on first page.

 

I checked e10s on FF48 of my oldest machine (single core), too.  But it was also completely unstable and unusable.

Edited by schwups
Link to comment
Share on other sites

How well does RoyTam1's New Moon 26.5.0 work on Windows 98 SE or ME with KernelEx (insert your recommended version)? Are there any files that need to be added to New Moon's directory in order to get it working?

Link to comment
Share on other sites

I'm sorry to say that I haven't a workaround to run RT's browsers NewMoon, Serpent, ArcticFox and IceApe so far. All versions crash on start. The reasons are different between NM26.5/27/ArcticFox and NM28/Serpent.

Link to comment
Share on other sites

No, Palemoon has caused an error in <unknown>.

PALEMOON caused an invalid page fault in
module <unknown> at c239:00020001.
Registers:
EAX=8000ffff CS=0177 EIP=00020001 EFLGS=00010286
EBX=00000000 SS=017f ESP=0064fa30 EBP=024a4dd4
ECX=00000000 DS=017f ESI=024a4de3 FS=5de7
EDX=00000004 ES=017f EDI=0064fa01 GS=0000
Bytes at CS:EIP:
23 00 cd 31 5a 66 58 66 5b 66 59 0f 82 c6 01 8e
Stack dump:
01f2809b 00000034 0000000b 02342052 011f75c8 0115d104 024a4dd4 00000000 024a4dd4 0115d104 00000000 011aba3c 04232f20 023422a0 0115d104 024a4dd4

Link to comment
Share on other sites

On 5/26/2021 at 1:01 AM, roytam1 said:

because almost all of my builds have "--dsiable-skia" switch specified when building.

KM76.4.4 (changelog): - Bug 1154322 - Allow using skia for content rendering. r=jrmuizel (26413363e)
Thanks RoyTam for allowing testing, if the change is for me. K-Meleon fails to start with skia ContentBackend on ME and XP.
Is skia, in context to your builds, discussed somewhere?
 
Date 06/24/2021 Time 13:47
K-MELEON caused an exception 03H in module MOZALLOC.DLL at 0177:016210bd.
Registers:
EAX=00000000 CS=0177 EIP=016210bd EFLGS=00000202
EBX=0347a34c SS=017f ESP=00feea70 EBP=00000001
ECX=00500ed3 DS=017f ESI=00000000 FS=5eff
EDX=81ddcfbc ES=017f EDI=004f2425 GS=0000
Bytes at CS:EIP:
6a 03 c7 05 00 00 00 00 25 00 00 00 ff 15 04 20
Stack dump:
01f79d69 00feea88 016211f0 0664b180 00000000 0832d100 37392d5b 31393430 2323205d 21212123 4f424120 203a5452 6c756f43 6f6e2064 6e692074 61697469

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...