Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


ruthan

XP List of HW no compatible with PAE 4 GB+ Patch.

Recommended Posts

Im experimenting with PAE patched XP, for quite long time, some drivers are not compabitle with it (but there are fine in 32bit mode), except of boot BSoD where im not sure what causes it, i have found that these cards are not compabitle, pleas report others:
- VIA USB3 controlles with 8xx chipsets - there is some exclamation mark in device manager, that driver cant start
- Aureal Vortex 1 - device manager is fine, but all sounds are broken
- MB with Gigabyte MBs with Z370 chipset, its working only with no ACPI boot - Multiprocessor MPS mode because of broken Bios ACPI table and i pae patch is for ACPI, i dunn know if there is no ACPI MPS patch available.

Share this post


Link to post
Share on other sites

Posted (edited)

No ACPI no PAE in most cases .

PAE may work in certain cases but weird issues will appear without ACPI.

Problem is not pae patch of mine problem is your mobo which is not ACPI compatible with my hal.

I recommend always a clean installation while dealing with nt5.x on post ivy bridge hardware.

Intel 6th gen and up needs patched bios in motherboard to make XP work properly.

Sad to say but todays motherboards aren't Designed for XP so don't except heavenly results without modified bios

One solution is Linux and KVM

Poorly written written bios are real culprit why Microsoft rejected pae in XP sp2 .

People complains drivers but nothing wrong with drivers as long they use kernel routines compliant with pae .

HAL has ability to deny certain drivers from using PAE altogether.

 

 

 

Edited by Dibya

Share this post


Link to post
Share on other sites
1 hour ago, Dibya said:

Poorly written written bios are real culprit why Microsoft rejected pae in XP sp2 .

Absolutely NOT.

It was poorly written drivers.

jaclaz

Share this post


Link to post
Share on other sites
Posted (edited)

VIA USB3 was tested on M

B with fully working ACPI.
Aureal Vortex 1, was tested on patched Z170 ACPI BIOS, but we found some issues, it could be one of them, but probably not, because in 32bit mode it working fine and problem is only in 64 bit mode and there are not conflicts in device manager.

Quote

One solution is Linux and KVM

  1. Are you really using it? Or you only thing that is good? You know, lots of people try it for moment, or see some pro Linux video, which is ignoring some flaws etc..
  2. I suppose that GPU passthrough is working, because i case mainly about games?
  3.  Its monitor picture output handling solved, or you need on passthrough GPU connected to its own monitor / monitor input and switching them?
  4. Can i passthrough to WinXP virtual primary GPU and use it for system after guest is shutdown?
  5. Need i 2 gpus to make it working?
  6. What about performance impact for gaming are somewhere some comparisions of KVM and physical machine?
  7. What about USB mouse and keyboard - has they should be dedicated from boot for specific guest, so i need 2 keyboards, 2 mice etc? I they could be passthrough to virtual and back - like in Vmware workstation?
  8. How big is list of KVM Win XP issues in comparision with physical machines, is there somewhing broken? Some additional bugs or not?
     
Edited by ruthan
KVM

Share this post


Link to post
Share on other sites
On 3/15/2019 at 12:02 AM, jaclaz said:

Absolutely NOT.

It was poorly written drivers.

jaclaz

Well same asmedia card worked on my skylake and never worked on my Sandy bridge with same nlite cd slipstreamed with my patch

 

Shall I continue list of such hardware?

Share this post


Link to post
Share on other sites
On 3/15/2019 at 1:26 AM, ruthan said:

VIA USB3 was tested on M

B with fully working ACPI.
Aureal Vortex 1, was tested on patched Z170 ACPI BIOS, but we found some issues, it could be one of them, but probably not, because in 32bit mode it working fine and problem is only in 64 bit mode and there are not conflicts in device manager.

  1. Are you really using it? Or you only thing that is good? You know, lots of people try it for moment, or see some pro Linux video, which is ignoring some flaws etc..
  2. I suppose that GPU passthrough is working, because i case mainly about games?
  3.  Its monitor picture output handling solved, or you need on passthrough GPU connected to its own monitor / monitor input and switching them?
  4. Can i passthrough to WinXP virtual primary GPU and use it for system after guest is shutdown?
  5. Need i 2 gpus to make it working?
  6. What about performance impact for gaming are somewhere some comparisions of KVM and physical machine?
  7. What about USB mouse and keyboard - has they should be dedicated from boot for specific guest, so i need 2 keyboards, 2 mice etc? I they could be passthrough to virtual and back - like in Vmware workstation?
  8. How big is list of KVM Win XP issues in comparision with physical machines, is there somewhing broken? Some additional bugs or not?
     

Surely performance will be less than physical hardware but if nothing works then something is better.

KVM reduces GPU performance too in my experience though they say it is GPU passthrough.

I never felt any bug but once my steam stucked and caused bsod.

Share this post


Link to post
Share on other sites
Posted (edited)
11 hours ago, Dibya said:

Well same asmedia card worked on my skylake and never worked on my Sandy bridge with same nlite cd slipstreamed with my patch

 

Shall I continue list of such hardware?

I am failing to see any connection :w00t:, but feel free to continue senselessly listing similar anecdotes.

As I see it there are two possibilities:

1) your same asmedia card worked on your Sandy bridge with any other OS with appropriate drivers for it

or:

2) your same asmedia card NEVER worked on your Sandy bridge with any other OS with appropriate drivers for it

IF #1 the issue lies in the XP OS, or in its drivers for the card or in your half-@§§ed/half-ripped patch.

IF #2 the issue lies in the BIOS that makes your Sandy Bridge motherboard not compatible with your same asmedia card.

jaclaz

Edited by jaclaz

Share this post


Link to post
Share on other sites

Ok, my GB 170 MB ACPI bios seems to be fixed, at least all other issues seems to be ok, but Aureal Vortex 1 sound with PAE patch is still broken, in 32 bit with ACPI mode its still ok,

 KVM what could input, output isssue? I experimented with Unraid for while, its KVM, QEMU based and this was nightmare..

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...