Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
drillgr

[Windows ME] Greek language isn`t recognized correctly by the system

Recommended Posts

u6dlvqt.png

Hello,

I have installed Windows ME English on an old system of mine for retro reasons along with the Cumulative Update, KernelEX etc. But my main problem is that the system won`t recognize Greek language correctly. I have set the appropriate option in local settings but as you can see in the picture it isn`t working. As a result I cannot access folders with Greek names, they aren`t recognized by the system (their names are only dashes and can`t be accessed).

Is there any solution? I could have installed the Greek version of Windows ME but the recent updates, patches etc aren`t working correctly and the system becomes unstable.

 

Edited by drillgr

Share this post


Link to post
Share on other sites

Control Panel -> Regional Settings doesn't affect fonts.
Try Control Panel -> Add/Remove Programs -> Windows Setup -> Multilanguage Support -> Details -> Greek

Welcome to MSFN.org!

Share this post


Link to post
Share on other sites
13 hours ago, jumper said:

Control Panel -> Regional Settings doesn't affect fonts.
Try Control Panel -> Add/Remove Programs -> Windows Setup -> Multilanguage Support -> Details -> Greek

Welcome to MSFN.org!
 

Thanks! 

I forgot to mention in the first post but I have already install Greek from multilanguage support, it was the first I did after OS install. Back in the days I didn't had such a problem, I worked english windows of Me for some years with no problem. Maybe it was a patch from windows update that fixed the problem.

Share this post


Link to post
Share on other sites

> I cannot access folders with Greek names, they aren`t recognized by the system (their names are only dashes and can`t be accessed).
Are these remote folders located on a non-FAT filesystem?
With what apps are you trying to access them?
Scandisk will probably be able to tell you what (WinME thinks) is wrong with them.

Share this post


Link to post
Share on other sites
5 hours ago, jumper said:

> I cannot access folders with Greek names, they aren`t recognized by the system (their names are only dashes and can`t be accessed).
Are these remote folders located on a non-FAT filesystem?
With what apps are you trying to access them?
Scandisk will probably be able to tell you what (WinME thinks) is wrong with them.
 

These folders are on a usb disk which is in FAT32 filesystem. Also my main HDD has tow partitions, before I install the English version of windows ME, I had the Greek one, so I had created some folders there with Greek names. Its very weird, in the past I didn`t have any of these problems.

Share this post


Link to post
Share on other sites

Because the folders can't be accessed, I don't think it's (only) a font issue. Path length maybe? What does Scandisk have to say about each of the drives? How about the Explorer Property sheet?
If you can access the usb disk on another system, try renaming one of the Greek folders to English.

Share this post


Link to post
Share on other sites
Posted (edited)
On 1/2/2019 at 6:18 PM, jumper said:

Because the folders can't be accessed, I don't think it's (only) a font issue. Path length maybe? What does Scandisk have to say about each of the drives? How about the Explorer Property sheet?
If you can access the usb disk on another system, try renaming one of the Greek folders to English.
 

Hello again, I have tried some things with no luck. At first, I renamed the folder with Greek name in English ( in Windows 10 pc) and checked in Windows ME. The folder was accessible but whatever Greek named appear in there was still with weird characters. I scandisk the usb drive and opened properties tab. You can see in the picture bellow (with circle an example of file which appears in gibberish. Also scandisk messed with the USB files, I lost some pdf and some Greek notepad files weren`t accessible even in windows 10.

Xn2W520.png

I tried also to install Office 2000 pro in Greek, hoping this may somehow fix the problem. After a lot of guessing (Gibberish in many windows) it installed successfully and inside office I have Greek appearing ok and also writing. But in general, the problem persists. I cannot even write in Greek in windows like name a folder or a file in Greek. I checked all possible keyboard settings as you can see in next picture with no luck.

LHG5kud.png

I don`t know what else to try, I think it`s a font/script issue, the system doesn`t set the font script in Greek and keeping it in western. All Greek fonts are present and working, checked and write successfully in notepad by selecting a font with Greek script.

I am open to suggestion!

Edited by drillgr

Share this post


Link to post
Share on other sites

Compatriot, I would suggest a reinstalling... If you have the same problem again then there must be a problem with the installation media or the procedure of installation

On Τρίτη, 1 Ιανουαρίου 2019 at 11:58 AM, drillgr said:

I forgot to mention in the first post but I have already install Greek from multilanguage support, it was the first I did after OS install.

That is the correct way, after that check if everything works OK and then install everything else step by step checking every time the same thing. In this way you'll find if something causes the problem.

Share this post


Link to post
Share on other sites

Καλησπέρα Harry!

I used a downloaded media of Windows ME [Microsoft Windows ME (4.90.3000) (Retail Full)], burned it with Nero in the lowest speed in a CD-RW and verified. So I think the media is ok.

Installation was quite straightforward, the only reference of language or something was to choose my region and time zone. Did I missed something or is something hidden/specific to do while installing; 

One last thing I tried is to change fonts from desktop options -> appearance and select Greek Ms Sans Serif. This corrected the problem in some windows but only till next restart, so it wasn't permanent.

Generally I am out of thoughts on what to do else. If I am not missing something during windows install or there is no way to change default windows fonts even from registry, I will try to use Windows 98 SE.

Share this post


Link to post
Share on other sites

I decided to give it up with Windows ME and try Windows 98SE, it seems this issue cannot be resolved.. So for my surprise, during Windows 98 setup process, it asked me to select the desired code page. I did it and changed it to Greek 869 and finally OS could recognize Greek correctly with no more gibberish! This option wasn`t available in Windows ME setup, I checked even with advance setup.

I installed some more stuff regarding win98 OS but with the 98SE2ME patch the problem revived, at least not as severe as before. I will continue to experiment and hopefully I will find the best combination.

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×