Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Laaca

Win7 don't boot after from AHCI to IDE switch in BIOS

Recommended Posts

Hi! I have HP Pavilion dv6 notebook. It uses the AHCI mode of drives handling and my Win7 work OK with it. Now I found a way how to modify the BIOS to allow to change the AHCI mode into IDE mode. I have some reasons why to do it - sometimes I experiment with various hobbyists OSes and also FreeDOS which I sometimes boot feels better with IDE setting.

So please dont't respond me to simply keep the AHCI setting.

However after switching into IDE the win7 booting unsuccesfully ends in the first loading screen and the computer restarts. I expected this behaviour, though. My question is: The reinstalation certainly helps. But is necesarry the whole reinstalation with rewritting of all system? Or there is some possibility of limited instalation like "fix the booting problems"? Or the installation CD is not necessary at all and it can be solved in some other way?

And last question: Can I expect big performance slowdown or the effect will be rather negligible?

Share this post


Link to post
Share on other sites

17 minutes ago, Laaca said:

And last question: Can I expect big performance slowdown or the effect will be rather negligible?

I don't know the answer to your other questions, but I do know the answer to the quoted one: the performance slowdown is negligible.

Share this post


Link to post
Share on other sites
2 hours ago, Laaca said:

change the AHCI mode into IDE mode.

Go back to AHCI mode temporarily.

Boot Windows 7,
open the registry HKLM\system\CurrentControlSet\services\pciide
set start=0

Enable IDE mode again.

  • Upvote 1

Share this post


Link to post
Share on other sites

Wow! Thank you guys. The suggested registry modification works like a charm. Nice to know that there are such experts on this forum.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...