Jump to content

Replaced CMOS Battery - CD/DVD Burner not Recognized


Recommended Posts

XP Pro_SP3

BIOS type and version is: Award Modular BIOS v6.00PG

I had one of those "OH MY GOD" moments when I realized my oldest desktop had the original
factory installed CMOS battery (CR2032) on the mobo.  Before replacing the battery, I was able to
print out the CMOS settings so they could be quickly restored.

During bootup, I see my Pioneer CD/DVD Burner clearly listed on the monitor.  If I had not restored
the CMOS settings correctly, the Pioneer Burner would be absent from the bootup listings.  I've
checked the CMOS settings several times, but XP no longer recognizes this hardware in Explorer,
My Computer, or Device Manager.

I have a huge cache of documents, files, and applets all about fixing problems with Windows.  Two
Microsoft KB articles suggest a few Registry edits.  Didn't work.  I also have an applet authored by
Doug Knox called "XP_CD-DVD-Fix.exe."  The idea is to restore your CD/DVD drive(s) to Explorer.
Didn't work.

Obviously, XP provides native driver support for this type of hardware.  I almost wish there were
third party drivers to reinstall!  If the operating system is not at fault, there must be something
in the CMOS settings I failed to restore.  What can I do in XP or the CMOS settings that might
resolve this problem?

Edited by HoppaLong
Link to comment
Share on other sites

Check cables and connections of the CD/DVD drive.

Check Device Manager.

What do you see?

Check Disk Manager.

What do you see?

It would be very, very hard normally to "hide" a CD/DVD drive from Windows, confirm that the CD/DVD drive is seen correctly from BIOS, hwever (i.e. try booting from a bootable CD/DVD).


Link to comment
Share on other sites

jaclaz, the CD/DVD drive is not shown in Device Manager or Disk Manager.

Following your suggestion, I immediately rebooted and pressed the F12 key for the Boot Menu.
Fortunately, I have many BartPE boot disks.  They always worked perfectly before I replaced the
CMOS battery.  Now, the BartPE disk failed to boot!  There has got to be something wrong in the
CMOS settings. What else could it be?

In the CMOS under "Advanced BIOS Features" the boot order is selected.

"Hard Disk Boot Priority" lists the disk where your operating system is installed.  There is usually
no reason the change these default settings.

First, second, and third boot devices are seperate items in the CMOS:

First Boot Device
Second Boot Device
Third Boot Device

My CD/DVD drive is listed as "Pioneer DVD-RW."  If I was a little crazy, I could select "Pioneer DVD-RW"
for first, second, and third boot devices.  I've tried changing the boot order for "Pioneer DVD-RW" at
least a dozen times.  "Disabled" is also an option for each boot device.  Nothing works!

During bootup when the Pioneer burner is listed on the monitor I also clearly see the LED go on and off
for POST.  The tray opens and closes when I press the switch.  It's working normally, but XP is failing
to "see" this device.

There is something a little scary I could try.  Most external USB hardware is "hot swappable."  I don't know
what would happen if I shutdown the computer, pulled the power connector to the internal CD/DVD drive
and reconnected the power cable while the computer is running.  XP might respond and reinstall the device.
I've never connected internal hardware while a computer is powered up.  I'm afraid it might damage the
CD/DVD drive.  Should I try this procedure?

I still think the answer is in the CMOS.  Besides selecting the boot order for the Pioneer burner, what other
CMOS settings might be causing this problem?

Edited by HoppaLong
Link to comment
Share on other sites

This continues to sound like a cable problem. do try removing the cable from both ends (one at the time) and re-seat the connectors.

Of course if the drive activity leds blink and the tray opens/closes at the push of the button it means that the power cable is OK, but it tells us not enough about the data cable, the fact that it doesn't boot from it may well be an issue with it (the data cable), but it can also be that you mis-recorded (or failed to reset properly) the BIOS settings.

Now, the Award BIOS should have a choice for "Load failsafe settings".

If you choose that one, the CD/DVD drive will work (unless the issue is the drive itself or the data cable).

Is the CD/DVD drive IDE/ATAPI or SATA?

What motherboard (exact make/model) is that PC?




Link to comment
Share on other sites

When you buy external or internal hardware the manufacturer usually provides a junk cable.  I never use them!
The best SATA cables have a sturdy latch which keeps the plug firmly in its port.  With a massive harness of
wires in most desktop towers, all cables should have latch.  If they don't I use small zip-ties so the plug
never loosens.

Except for the floppy drive, all hardware in this desktop I built several years ago is SATA.  I wanted a speed
boost, so I used two identical hard drives and setup a RAID 0 configuration in the CMOS.  These days, you
can buy screaming fast computers for less than $2000.00.  I would never build another RAID 0!

I've used laptops until they fall apart, but this desktop is in my home office.  It was never used a lot, so it's
almost like new.

The mobo has spare SATA ports.  I switched ports.  Sure enough, the port number displayed next to my Pioneer
burner reflected the number on the mobo.  Obviously, there is nothing wrong with the SATA cable.

jaclaz, I printed out the CMOS settings before changing the battery, but it was a waste of ink!  Except for the
RAID settings which I restored in five minutes, all other settings are default.

As you suggested, I tried "Load Fail-Safe Defaults."  For a few seconds it appeared to be working.  The monitor
displayed "Loading CD/DVD Drive" and the BartPE boot disk started to spin up.  After that it just stopped!  The
monitor displayed nothing.  I've never seen anything like this before!

A couple of days before replacing the battery, I used my CD/DVD drive with a BartPE disk to create a new image
backup.  You probably know that imaging backup apps (like Acronis) don't work with RAID.  The solution is a
BartPE disk (or similar) with your backup software as a plugin.  It works flawlessly.

Except for my RAID CMOS settings, everything else is "Load Optimized Defaults."  Since 99.9% of the CMOS
settings are default, I don't understand why I'm having all this trouble.  If this problem really is in the CMOS,
replacing the Pioneer burner with a new model won't fix anything.  It would be nice if I could flash the BIOS
with some new firmware.  Gigabyte doesn't have an update for this mobo.

Link to comment
Share on other sites

Try again, with "Failsafe settings" and another cable you can use alright (for the sale of the test) one of those crappy ones you have as spare, then all that remains is a (coincidental) partial failure of the actual CD/DVD drive, which you should be able to test separately by connecting it to another machine.

BUT the fact that it started loading and then suddenly stopped may mean something else.

I wouldn't (as I never do) totally exclude a PSU issue (I have seen too many of them).

Try (again for the sake of testing) disconnecting the power from your hard disks and test again the CD/DVD drive (ideally you should have a spare PSU).


Link to comment
Share on other sites

Believe it or not, I may be very close to a solution!

1. Removed CMOS battery again.  The contacts looked bright and shiny, but I cleaned them anyway with an
electronics oxidation remover.  Installed a different battery.

2. "Pioneer DVD-RW" is now listed correctly on the Boot Menu.  BartPE booted perfectly.  Problem solved.

3. When XP Pro completed startup, I disconnected and reconnected the power plug for the Pioneer burner.
Almost instantly, my Pioneer CD/DVD drive is restored to Device Manager, My Computer, etc.  YIPPIE!!
For a few minutes I thought this nightmare was over.  Unfortunately, when you reboot the problem returns.
Gone from Device Manager and all the other locations it should be listed.

4. The Pioneer optical drive is model DVR-2920Q.  I already have the lastest firmware installed.  I ran the
installer just to see what would happen.  No go.  Can't flash again with the same firmware.

 I've learned a lot about this problem, but I don't know what to do next.  Disconnecting and reconnecting
the power plug fixes the problem while XP Pro is running.  What is the final step?  I must find a way to keep
the CD/DVD drive installed after a reboot (or a shutdown and startup).

( A computer SMPS is a marvel of engineering, but I always replace them before they get old or run too hot.
The SMPS in this desktop was replaced about two months ago.  The old one tested good, so I'll keep it as
a spare.

Edited by HoppaLong
Link to comment
Share on other sites

Well, then try with the old PSU.

The firmware of the actual CD/DVD should be anyway irrelevant, the "basic" info for OS detection would be the same.

The connection and re-connection of the power plug making it working again points towards an issue with power supply.

What happens if you scan for new hardware on device manager?

IF it is a power issue, then maybe it is connected to boot-time "timing" of the startup of the devices and once the system has booted the device is seen again.

It is not like you have*something* in your system for hot-plugging eSATA (please read as SATA) devices?

Something *like*:

If you do not have it (or *something* similar) you could try that, it may be able to offer a temporary workaround.


Link to comment
Share on other sites

I ran the "Add Hardware" applet in the Control Panel several times.  There are dozens of Registry Keys
showing the Pioneer burner installed, but the applet never finds anything.  You can't "manually" select
the device because it never appears on the list.

The new PSU was installed several weeks before I replaced the CMOS battery.  XP was completely stable
(and normal) with the new PSU.  After replacing the CMOS battery and restoring the RAID settings I booted
into XP Pro.  That's when the CD/DVD drive vanished from the system.

I've built numerous load boxes since I was a kid.  I have three in my workshop for small, medium, and
large capacity power supplies.  They're equipped with temperature sensors that shutdown the supply
if it runs too hot during a test.  Both old and new PSUs tested good.  I also completely agree that testing
is not definitive.  Any device can fail.

I think replacing that 25 cent battery screwed up the mobo firmware.  These BIOS chips are EEPROMs
(Electrically Erasable Programmable Read-Only Memory).  There are bootable apps that will delete or
"erase" everything.  Don't worry, I'm not going to do it!

This desktop has two eSATA hard drives.  (USB 3.0 came along and quickly dethroned eSATA.)  Most of
the time they're not powered up.  I use them mainly for backups and long term storage. 

At this point, I'm a little confused about the link you provided for "HotSwap!"  I don't think I completely
understand the benefits of this app.  Are you saying "HotSwap!" might resolve the problems I'm having
with my CD/DVD drive?  

If HotSwap! works that would be great.  If not, I might buy a new CD/DVD drive or retire this desktop.
It's hard to believe replacing a coin cell battery would cause so much grief.  Ironically, it was an email
from a friend that prompted me to replace the battery.  He listed several awful problems with a laptop.
Like most people, he didn't make backups so he was really upset!  I recommended replacing the CMOS
battery.  All his laptop problems were cured.  Too bad I didn't have the same luck with my desktop.

Edited by HoppaLong
Link to comment
Share on other sites

As I see it, whatever you think, there is no real evidence that anything (particularly not anything "permanent") happened connected to the CMOS battery replacement.

And I have had systems (BOTH desktops and laptops) running with a depleted or without a CMOS battery at all and they worked just fine (just so you know).

For *whatever* reasons *something* happened to the capability of your Windows XP install to detect/install the (SATA) CD/DVD drive.

While this may be connected to a malfunctioning of the PSU (it doesn't matter AT ALL if you changed it 2 months ago, it could be malfunctioning even if you changed it half an hour ago), it is possible that you are experiencing the issue only because of some OS driver/device management issue.

The *normal* troubleshooting path I would follow would be:

1) try the thingy with another PSU

2) try the thingy with an alternate OS

3) try  in the current OS to uninstall and re-install hardware drivers, possibly cleaning the Registry, etc.

4) try some third party tool (such as the mentioned hotswap thingy) and see if *somehow* they see the device (since hotswap runs well after the booting phase this would workaround possible issues of timing with a defective PSU that provides not enough power).

If you believe that changing the CMOS battery with one touched by a holy man or after having made a voodoo rite and danced around the PC dropping on it clover leaves will solve the problem, it is ok, of course, but it is unlikely to be the appropriate cure for this non-diagnosed issue.



Link to comment
Share on other sites

Sorry, my memory fails me, but I've had this problem before. Are we talking about the slot-in drives (car-stereo load type so to say)? Pioneer had a lot of firmware problems on their drives, but they were darn good when they worked.

I believe I fixed the problem by replacing the driver DLL for the drive, or changed the registry, or disabled or enabled 32bit drive support in the BIOS. I might have been disabling SMART, change master/slave in cable select, as well.  Microsoft´s fix didn't work for most drives, I think it did work for HP drives in laptops. Check the net if you can find a manual solution editing the registry.

I hope you get some ideas from this.


Link to comment
Share on other sites

  • 3 weeks later...

When you finish building a desktop, there are usually unused SATA ports on the motherboard.  I tried the
optical drive cable in each unused port.  The BIOS always listed the port number correctly during bootup,
but it didn't fix the problem with XP.

I started opening some boxes in my workshop with old expansion cards that should have been tossed in
the trash or recycled.  Suddenly, I had the solution!  Provide the optical drive with its own inexpensive
SATA Controller Card.  Revision 1.0 has a maximum data transfer rate of 150 MBYTES/SEC which is more
than adequate for an optical drive.

I purchased a card on eBay for $14.49.  Several dozen Silicon Image drivers on a CD were included with
the package.

IT WORKED!!!        YIPPEE!!!

To anyone who may find this thread while performing a Google seach, please be careful when you buy a
cheap SATA Controller Card.  Revision 1.0 (150 MBYTES/SEC) is fine for a CD/DVD burner.  If you need
extra SATA ports for a hard drive or SSD (Solid-State Drive) optimized for the latest Revisions (3.0, 3.1,
and 3.2) make sure the controller card matches your requirements.

Optical Drive Speeds.jpg

SATA Revisions.jpg

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...