Jump to content

various problems with system restore, sfc, dism


Recommended Posts

Hi, this morning I discovered that System Restore stopped working correctly, because, after choosing a point, I got the error 0x80070005
(see the image).
I'm on Windows 7 Pro x64 (not planning to update to 8\10).

No active antivirus at the moment.
I've tried various solutions online, but noone worked.
Selecting a 20 days old point didn't work either.
How can I fix this?
I've also encountered other problems not related to the first error, but discovered due to that:

- SFC /scannow couldn't repair some files like: themeservice.dll, themeui.dll, uxtheme.dll

- DISM doesn't have the usual /restorehealth parameter (only /scanhealth).. why??
- the "System Protection" tab is missing in "Safe mode" (bug or feature?).
Do you have any suggestion?
Should I try a repair at this point? (NO refresh)


Edited by phaolo
Link to comment
Share on other sites

Oh well, I solved at least the first problem.
I used System Restore from the Repair mode and it worked :)

No idea about that SR error or the other issues though..

Any comment?

Link to comment
Share on other sites

Sigh.. this forum has become quite empty since some months :(


- after various tries, SFC managed at least to repair themeservice.dll and uxtheme.dll.

- DISM /restorehealth seems to exist only on Win 8+ versions.

- no SR tab in "Safe mode" is probably a security feature.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...