Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Sign in to follow this  
Isawa Mitaka

Floppy drive problem

Recommended Posts

I've got a problem that I hope [b:08e4fd0609]SOMEONE[/b:08e4fd0609] can help me with. My floppy drive under WinME was locking my system whenever I tried to access it. And I mean a total system lock, no mouse or anything. I was hoping that a fesh install of WinXP when I got it would fix the problem. Unfortunately, no go.

The reason I'm having trouble tracking down the problem is that when I try and access a disk:

  1. In a normal start, the system locks
  2. Using msconfig.exe and disabling everything in the selective start, the system locks
  3. In Safe Mode, it reads the drive fine
  4. Booting from a floppy, it accesses the disk just fine
    [/list=1]
    Does anyone have any ideas of what the problem could be? :confused
    Thanks in advance.

Share this post


Link to post
Share on other sites

If you tried both fresh installs of WinME and WinXP, and you still get a complete system lock-up when accessing the floppy drive, then it sounds like a hardware problem. Bad IDE cable probably?

Share this post


Link to post
Share on other sites

When you are getting frustrated out of your mind, then it is easy to forget stuff that is right in front of your face. LOL

Rick

Share this post


Link to post
Share on other sites
Guest LouCypher

Bad IDE cable on a floppy drive? Not unless he's got a SuperDisk or something.. It sounds like he may have a bad cable or the drive connected to the wrong connector. It has to be connected AFTER the twisted section for drive A:, unless you've got floppy swap enabled in the BIOS. The system would boot fine but Windows will look for A: in the wrong location. I suspect it would also give an error under Device Manager as well if it ever booted into Normal Mode. Get a new floppy cable and connect it AFTER the twist and see if it helps.

Share this post


Link to post
Share on other sites

I figured he probably meant floppy cable.Oddly enough, Windows reports the floppy drive as working just fine. It's only when you try to access a disk that the lock happens.I've tried a different floppy drive to no avail, but the cable had completely slipped my mind. Fortunately, I live in a house with 3 systems, so it's no problem... acquiring another cable. :)

Share this post


Link to post
Share on other sites

Well hold on one min guys....When you go to acsess the drive do you get any light or activity on the drive while its locked up. If you do then this has nothin to do with the cable. As far as I have ever seen if you have tried two fresh OS installes and your getting activity on the drive when try to acsess it, then its the drive. They cost 15 bucks go get a new one. [b:48cad05970]Now-[/b:48cad05970] If your not getting any activaty and its locking up then I would have to refer to posted replys above.

-Chris

Share this post


Link to post
Share on other sites

I get the light, but it's not the drive. That was my first thought, but I've swapped the drive with another one in the house. If it were the drive, then the problem should have transferred over to the other system. But the drive that I know is working still locks up my system. The one that I was getting the lock ups on works fine in the other system.

Share this post


Link to post
Share on other sites

Think u all are forgeting something.

The drive boots in dos + it works in safe mode!

So drive & cable are ok.

It's a windows problem. Wrong drivers or some conflict.

Share this post


Link to post
Share on other sites

My solution is yanking out the fdd cable and tell the BIOS to disable the drive totally. Most modern BIOS's boot to USB flash drive. The 256m or even 128m are dirt cheap. If you need a disc, make a bootable CD. FDD's are OLD and unreliable (both drives and disks), why fight it?

My 2 cents worth.

Sakui

Share this post


Link to post
Share on other sites
Think u all are forgeting something.

The drive boots in dos + it works in safe mode!

So drive & cable are ok.

It's a windows problem. Wrong drivers or some conflict.

Agreed... check for Conflicts (IRQ, DMA, etc). New hardware added recently maybe? Check that BIOS and REAL hardware settings. Windows only uses what it's told to, ya know... One-by-one, you'll find the culprit. :thumbup

Share this post


Link to post
Share on other sites
My solution is yanking out the fdd cable and tell the BIOS to disable the drive totally. Most modern BIOS's boot to USB flash drive. The 256m or even 128m are dirt cheap. If you need a disc, make a bootable CD. FDD's are OLD and unreliable (both drives and disks), why fight it?

My 2 cents worth.

Sakui

Ehm, this thread is over 6 years (!) old... :whistle::wacko:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×