Jump to content

Is my MOCA adapter to blame for unstable Remote Desktop?


PlayWithFire
 Share

Recommended Posts

When I bring my work laptop home, I simply use remote desktop to get into it in order to take advantage of the keyboard, mouse and tripple monitors.

However, remote desktop is sort of laggy, sometimes freezes for 30 seconds at a time and takes a long time to refresh things like images.

I am starting to wonder if it's my network setup.

 

My personal PC and work laptop are connected to the same hub, which is connected to a MOCA adapter. The actual FiOS router is a different room to maximize the WiFi coverage, so I have no way of directly plugging the two computers in there. Is my remote desktop slow because I am going over MOCA? Can I expect better speeds if I connect both computers directly to the router? Can this be solved by replacing the hub with something different (switch or another router)

 

Thank you!

Link to comment
Share on other sites


> My personal PC and work laptop are connected to the same hub

Wired or wireless? If wired, a cross-over cable directly between the two should be fastest. If wireless, disconnect the hub from the rest of the network (yes, a switch or router might be needed) and all other devices from the hub. In short, create the fastest local area network you can that just includes these two machines.

MoCA is tuned for multimedia, so stay off that network when you're looking for performance from non-multimedia applications.

Link to comment
Share on other sites

They are connected to a hub via cables.

 

I don't want to go with a crossover cable, since I only have a single NIC on each machine. Besides, I am having horrible flashbacks to the days when I had to bridge connections. Not something I want to do again.

 

Would replacing the hub with a router work? I want to avoid having the data travel via MOCA at all.

Link to comment
Share on other sites

I believe so. One of the machines may need to act as a server (plugged into the WAN port), however.

>the same hub, which is connected to a MOCA adapter

If you mean the MoCA adapter is plugged into the hub, try unplugging the MoCA adapter from the hub. This might be enough to fix the performance of your existing configuration.

Link to comment
Share on other sites

  • 3 weeks later...

Been using MoCA myself for years and never have had this issue.

 

What kind of bandwidth are you seeing on the computer plugged into the MoCA adapter?

 

See: https://www.raymond.cc/blog/network-benchmark-test-your-network-speed/

 

Just check to be sure you got decent bandwidth. Need to know if you are dropping packets as well.

Link to comment
Share on other sites

  • 1 month later...

Well, i ended up moving some things arond the house, and now both my laptop and the desktop are plugged dirrectly into the router.

And I am having the exact same problem.

But, I realized that my wife is working right next to me, and she using remoted desktop over VPN on her office machine.

So, now I am wondering if my network is just oversaturated. I need to look into a better router.

 

I need to decide whether to add a 2nd router to the network, or figure out how to replace verizon's router entirely.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...