Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


NoelC

Reminder: Deconfigure Local Account Password Expiry

Recommended Posts

I'm not sure whether this even applies to a Microsoft account, but if you're using a local account to run Windows 10, something you may want to consider...

 

Passwords are set to expire by default.

 

If you haven't remembered to do so on your brand new setup, you might want to double check whether your password is set to expire, and whether you want to deconfigure that.

  • Run the Local Security Policy snapin (secpol.msc)
  • Navigate to Security Settings > Account Policies > Password Policy
  • Change the Maximum password age to 0 to avoid expiry.

 

-Noel

Share this post


Link to post
Share on other sites

Windows 10 Home doesnt have "secpol.msc", it tells me "File not found"

Share this post


Link to post
Share on other sites

You may be able to do the same thing by doing the following:

 

  • Start an elevated CMD window.
     
  • Type the following command to check the current status:
     
    NET ACCOUNTS
     
  • Type the following command to avert password expiration:
     
    NET ACCOUNTS /MAXPWAGE:UNLIMITED

 

-Noel

Share this post


Link to post
Share on other sites

Does this still work?

 

wmic useraccount where "name='Username'" set PasswordExpires=false
*also use in elevated CMD.

Share this post


Link to post
Share on other sites

I'm not sure whether this even applies to a Microsoft account, but if you're using a local account to run Windows 10, something you may want to consider...

 

Passwords are set to expire by default.

 

If you haven't remembered to do so on your brand new setup, you might want to double check whether your password is set to expire, and whether you want to deconfigure that.

  • Run the Local Security Policy snapin (secpol.msc)
  • Navigate to Security Settings > Account Policies > Password Policy
  • Change the Maximum password age to 0 to avoid expiry.

 

-Noel

 

Done, thanks!

 

--JorgeA

Share this post


Link to post
Share on other sites

Does this Windows 8 command no longer work ("where Name='JOHNDOE' " is your actual Windows user name)? I ask because I use this command on my Windows 8 clean install disk and was going to use in on my Windows 10 .iso as well.

C:\Windows\System32\wbem\WMIC.exe path Win32_UserAccount where Name='JOHNDOE' set PasswordExpires=false
Edited by lurk&jerk

Share this post


Link to post
Share on other sites

Hey lurk, you posted (nearly) the same command that I did! :P

Share this post


Link to post
Share on other sites

@Tripredacus. Sorry. That's what I get for speed reading posts early in the morning.  :blushing: 

Edited by lurk&jerk

Share this post


Link to post
Share on other sites

Now is the time for people to try things and report back.  I honestly don't know about the WMIC command.  I suspect it will work.

 

-Noel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...