Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Sign in to follow this  

2000 and ATI drivers USED to work

Recommended Posts

I have decided to reinstall my windows 2000 computer. my greatest problem is with the ATI X700 drivers. I have solved the issue with BWC's 10.2 drivers, but i am curious why my originals failed because they worked on other reinstallations - is it possible some sort of lock out occurred?

I had some troubles last time, it worked flawless all the times before that, this time neither the installer or the drivers will work at all. because of the success i had last time i renamed the file with (Xseries) - i know this DID work last time (i dont know if i ran this setup and if it failed, but after some struggle finding the right one, i ran it and it worked, not sure if something happened during the struggle to help it). the filename is 10-02_legacy_xp32-64_dd_ccc.exe. in all except the last of the scenarios below, i got the error "Setup has determined that the operating system in use is not a 64bit OS and as this Setup is intended for 64bit systems only Setup will now exit". the installer does have 32 and 64bit folders. the xp32(only) driver installer doesnt seem to include drivers for the X series (X700), so thats ruled out. I managed to force install the drivers by replacing [ATI.Mfg.NTx86] (not in the 64bit folder as you can see) with [ATI.Mfg] in the INF file, after reboot (and including the last scenario below) i get in the device property page: "the device is not working properly because Windows cannot load the drivers required for the device. (code 31)". I was quite sure i didnt have to edit the INF file in the past also (and i never knew about the RU2 and xp based updates)... so it does seem to me there is some sort of lockout.

These things are what i have tried/installed

*without SP4 (SP3) - the force installed driver caused BSOD on reboot (kernel32).

*with RU1

*with RU2

*with RU1 and 2 uninstalled (sp4 only)

*Java 5update5 (at the moment)

*dotnet 2

*directX 9c

*fresh install and changing the timestamps and system time to Mar 2009 (after the install program's release, according to a program named "MediaInfo" on sourceforge.net), though program was briefly launched in a dir and with files dated with 2012 (it was still checking the file's integrity when i ended that task).

*i tried ConvertCatalysXP-2K by Bernhard Schelling, which installed for the above 10-02 installer, but not for 10-5.

By the way this took like 1.5 days... learnt to back up :)

UURollup is out of the question due to BSOD, but i never used that in my past fresh installations.

its related to the problems expressed here too:



the suggestion to use Omega drivers does work but i prefer the originals, doesnt work when originals are installed over the top.

as for black wing cats, ATI1204w2k.cab doesnt support my card, and his ati2k1002l.zip is 10.2, and does work - So it makes me wonder what he did to fix it?

with my prior installation im quite sure i got 12.2 to install. the reason for the reinstall is i did a failed update, and found i didnt back up my whole installation (and reformatted, then i found my backup) - you need a fresh install once in a while... the icons had been messing up, though i found an indirect solution to that.

SO what on earth happened? im curious.


Share this post

Link to post
Share on other sites

I don't know which version of the official drivers was the last one to support Win2k but the drivers ver. 10.x support only XP+. There are unfixed dependencies in them and they won't work in Win2k unless you:

  • Install the unofficial kernel
  • Use BlackWingCat's drivers where the dependencies are fixed using files from KDW.

You didn't explain any details about the BSOD related to UURollup but my wild guess is that IE5 might be a problem (you haven't mentioned anything about installing IE6). You might want to install either IE6 or USP5.1 (IE6 is included in it) and then try to install UURollup again.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...