Jump to content

Unofficial SP 5.2 for Microsoft Windows 2000 (WIP)


Recommended Posts


I don't really know what the problem with the SQL Server is.

Yeah, neither do I at this point. I'm also not a programmer so making full sense of the dump is beyond me.

First, a few points about UURollup v11

1) Two versions of process explorer included. Nice. :thumbup

2) Caused nvidia display driver service to temporarily hang at startup.

3) May have been premature on saying v11 fixed ssl cert issue. It just may be throwing an exception before it even gets to that point.

Anyway, so today I decided to mess around a bit. First I uninstalled Office 2003 so I can get MS Update working again.

[Note to self - either install Office as the last thing I ever do or just fore-go it for Ashampoo/SoftMaker Office 2010 or 2012.

2010 works fine on a stock win2k]

MS Update offered me two patches for .NET and re-offered Rollup 1. :no:

Back to SQL. I uninstalled v11 which caused win2k to reboot before logon prompt appears. Went into safemode and installed Rollup 2.

After restart I installed v10d and went back to sql. So now we're back to the beginning of not being able to create ssl certificate.

Just for the fun of it I decided to add bits and pieces of v11 to v10d to see what happens. With each addition I'd try and reinstall sql server.

The copying of bits was done via a Linux rescue system. The following dlls were added to the system (system32 & dllcache)...

user32 - no go (meaning the same ssl cert issue)

crypt32, cryptui, wintrust - no go

rsaenh - no go

userenv - no go

Following added just for the fun of it...

cryptsXP, credui, wintruXP, xpsp#res files - no go

Given that those files from v11 didn't change anything I then reinstalled all of v11. SQL Server throws an exception.

Hmm, maybe it's the included uxtheme.dll I thought. Nope.

This could be kernel related or anything for that matter.

BTW, an almost identical exception error was found at MS when I was searching last week with a supposed fix being cumulative update 15

for sql server 2005 sp3. Thing is I can't test that because sp3 itself won't finish installing and thus CU15 can't find any instance to update.

I'm finished for this week. I'll resume testing next week on my next days off.


You should try a different version of SQL server to see if it works or not.

Link to comment
Share on other sites

You should try a different version of SQL server to see if it works or not.

Yeah. I can either try SQL Server 2000 (is it free?) or just go with SQL CE (doesn't run as service nor has all the

features but then again I probably don't need much anyway).

After my first round of failures I had installed SQL CE anyway.

I doubt Server 2008 would run even with the unofficial updates (requires .NET 3.5, not sure what else).


Link to comment
Share on other sites

Latest SQL Server 2005 Test

To AnX: I don't think there's another version of MSSQL that I can try. Version 2000 isn't/wasn't available in an Express edition

as far as I know.


Starting from scratch this time.

1) Installed Win2K, SP4, Rollup 1

2) Installed IE6 and essentials (Windows Update Agent, MSI, BITS, and roots update v010)

At this point MSUpdate worked great and I let it do all the patching and updating. Only non-MS addition was to fix

timezone/DST stuff. Everything went smoothly.

Full backup image done.

3) Installed Visual Studio C++ 2005 Express with SQL Server. No problems or errors in Event Viewer.

Though I have an archive of services packs and updates I let MS do it all so I know there's no user error.

4) Service packs, patches, updates to .NET 2, VC++, SQL (SP3 offered).

SP3 failed a few times 'til I found out my MDAC needed updating. After that the SQL update went fine.

In between all this I kept checking and SQL ran without issue. Self-signed certificate was generated and used.

I held out on updating the roots via MSUpdate until I was sure all was working. Updated roots and all was still good.

Another image made.

As a test I took the roots bits from Rollup2 and manually 'updroot'ed them as per inf files. Still all was good.

5) Installed Update Rollup 2. SQL still working with no issues, errors, or warnings.

6) Jumped straight to UURollup v11. SQL throws exception. MSUpdate stopped working. Something about

wuaueng.dll version or database mismatch. Strange since far as I can tell that dll isn't part of the updates.

7) Uninstalled v11. Went smoothly. SQL is working again.

8) Installed UURollup v10d. SQL won't start due to certificate issue...

"...server could not load the certificate it needs to initiate an SSL connection... [error 0x90090008]"

9) Fixed MSUpdate by reinstalling BITS. Was offered up the roots update again.

So, after all this I have learned what? Nada. Nichts. Still where I started.

As mentioned before as a Joe User I really have no need for an SQL server but the fight to make it work has wasted

a lot of days and nights.

Wouldn't have it any other way. :D


Edited by marcdw
Link to comment
Share on other sites

Two More SQL Tests

Test 1

I thought I was done with this SQL thing but I thought there was some hope.

After giving up on SQL and restoring the main image I installed UR2 and UURollup v11 w20130323.

With v11 running I get the nvidia service temporary hang but in event viewer I noticed a number of errors

regarding WMI and ASP.NET and .NET. I remembered that I had .NET 2.0 SP2 on hand so I installed

that. It fixes the WMI errors.

MSUpdate, after installing the initial .NET2, only offers updates to SP1. Anyway MSUpdate then offered

patches to SP2 along with Rollup 1 (7.7MB).

Also installed KB971111 (.NET GDIPLUS patch) which isn't offered.

There's no SQL installed so I figured I start with the RTM (no service pack). Much to my surprise it did

install with no certificate errors or exceptions. However, sqlserver runs at 99% CPU hogging everything.

This also happened some months ago on another older machine I was testing before.

Tried to use MSUpdate to go to SP3 but the cpu issue was dragging things along. I would periodically

stop the service to give the install a boost but it still was taking forever. Decided to cancel the install which

also took forever.

Installed SP3 from archive instead but once again the server throws an exception.

End test.

Test 2 - and a new daily?

With the RTM version of SQL not crashing I thought there was hope.

This time I restored the image with the working SQL.

Installed .NET2 SP2

MSUpdate offers roots update

Install Update Rollup 2 (SQL running great).

Install SQL SP4 (no probs)

MSUpdate offers roots again (seems to do that a lot)

Install UURollup v10d (SQL certificate problem)

Discovered that there was a new daily available, from April 27.

Installed UURollup v11-d20130427

On reboot I'd get to the logon screen and then error. Services.exe terminated unexpectedly. It reboots. Errors again.

Safe Mode: Uninstall new 11 daily, reboot

Install v11-d20130323 (sql exception, nvidia, MSUpdate broken).

Fix MSUpdate (offered small Rollup 1 and roots)

Safe Mode: Uninstall v11

Safe Mode: Uninstall v10d

Back to normal, SQL is running fine

Safe Mode: Reinstall new v11 daily (in case something got missed)

Boot is successful. Clear logs and reboot just to be sure.

But same as before. SQL throws exception and temporary nvidia service hang.

So there you have it. SQL is definitely, officially out.

Regarding the new UURollup daily, I haven't seen any announcements or what the changes are.

Comparing file dates the only diffs I see is with update.inf and update.ver. Everything else seems the same.


Edited by marcdw
Link to comment
Share on other sites

  • 3 weeks later...

msxml6.dll and msxml3.dll from Windows 7 cannot be registred as well, because it requires correct "API-MS-WIN-CORE-LOCALREGISTRY-L1-1-0.DLL" to add registry information. So, when you slipstream msxml3 or msxml6 from Win7 to Win2000/XP/2003 distribution - you will get not working msxml! You should remove msxmls's from Win7, and use from XP/2003/Vista ones, then.

Edited by Svyatpro
Link to comment
Share on other sites

  • 2 weeks later...

Hey everyone :hello:

I'm sorry for being absent for some time. I've been very busy and things have been a little bit difficult for me recently so at the moment I've got very little time for Windows 2000 and MSFN. I hope to be able to fully come back in the near future.

@Tommy There're some issues with UURollup uninstallation. I worked on it already two months ago and I'm going to improve the situation later on. The problem occurs when you've installed several versions of UURollup without uninstalling the previous one, and then try to uninstall it. Simply speaking, the uninstaller unregisters several system files and doesn't register them again.

@marcdw I can't really help you the SQL problem at the moment. I'd need to install and test it myself. I'll remember about the issue and try to do something in the future.

@Svyatpro They can be registered as long as you've installed UURollup-v11.

Link to comment
Share on other sites

blackwingcat has released an updated version of his kernel so you can expect a new release of UURollup-v11 soon. I'm also working on a new merged .NET Framework installer. This time I want to make sure that it works correctly both in 2000, XP and 2003, and also that Windows Update doesn't ask for the updates which have been already integrated there.

Link to comment
Share on other sites

I've been updating the Download Archive at my website. I've added several XP and 2003 updates, and I'm going to remove the obsolete updates from the Windows 2000 folder and add the new ones released in the last few months.

Please let me know if you find any errors.

Link to comment
Share on other sites

Great to see you're back at updating the rollup again, and keeping the site up to date with updates.

I was sad to not find a Win2k update in the latest security ISO release from Microsoft, as IE6 has been getting updates on the XP side the past couple months. It may be that Microsoft realized they were providing updates for an EOL platform, or perhaps the current run of hotfixes do not apply in any way to IE6 SP1.

Link to comment
Share on other sites

Thanks :)

I've read a blackwingcat's post saying that there were no longer Windows 2000 updates included in the latest ISO. There was still another one released which is newer than the one listed on my website (Update List for HFSLIP). I'm going to update the whole list in the near future.

I'm also going to gradually add to the Download Archive all updates for Windows XP (basing on the Mimo's list) and for Windows 2003 Server (basing on the FDV's list).

Link to comment
Share on other sites

  • 2 weeks later...

tomasz86, since when have you started using XP? I've started using Vista because of the issues that Win2k previously gave me.

Anyway I'm not too sure if I should venture out into UUR anymore, because reliability and stability come along with my want of Windows 2000.

And if Win2k isn't reliable or stable, there's no point.

Well, I can say that for me the rollups have been stable and reliable, my Win2k machine NEVER crashed, in fact it seems to run more STABLE with the Rollups! :)

BUT sometimes app compatibility can be an issue. It's rare, and too little to complain about.

The issue I was having back then was because of my integrated HD 2500 Graphics. I'm now on nVidia, so theoretically, Windows 2000 should run awesome.

Edited by AnX
Link to comment
Share on other sites

My main PC got broken two months ago and I had to use a different machine with XP installed. Recently I've managed to fix my main computer but after using XP for a while I realised that it was the right time to make a switch. I had already used XP on my laptop for a few years before so it wasn't anything new for me.

There are two main reasons why I decided to switch:

  1. The first is IE. I have to use several websites which rely on ActiveX and they no longer work in IE6 so using them in Windows 2000 was very difficult.
  2. The second is proper ClearType support. The 3rd party alternatives lack proper multilanguage support. There are some fonts to which ClearType shouldn't be applied at all (and Windows doesn't do it) but those 3rd party programs apply ClearType to all fonts unless you exclude the problematic fonts one by one which is just too much work and still very far from ideal solution.

I actually find Windows 2000 more stable than XP :} but these two reasons (especially the first one) are crucial for me so I'm using Windows XP at the moment and probably continue to use for a long time.

However, it doesn't mean that the Windows 2000 related projects are over. Everything will be the same as I'm going to continue working on USP5.1. Windows 2000/XP/2003 are exactly the same when it comes to the basic structure of the OS so everything I've been doing in reality applies to all of them.

Link to comment
Share on other sites

For me, Windows XP was a literal nightmare. Whether it would boot to the desktop would be the question! Windows Vista SP2, however is well behaved.

But my ventures with Windows 2000 aren't over...yet. Also, you could run Windows XP in a VM for the sake of IE 8, and for me ClearType has never been an issue.

I find Windows 2000 more stable than any other OS, because even with UUR it does not crash.

BUG FOUND: In the latest daily version of UUR 11: June 2013, I'm greeted by this terrifying sight:


It seems that the kernel32.dll file is problematic.

In the April 2013 version, everything runs great. Super stable.

Edited by AnX
Link to comment
Share on other sites

But my ventures with Windows 2000 aren't over...yet. Also, you could run Windows XP in a VM for the sake of IE 8

Trust me, I tried everything. I tried running both Windows XP and 7 in a VM in order to use IE but as soon as I tried to use some of those ActiveX plug-ins, the whole system would crash. They caused BSODs in the host system, not just inside the VM. They only seem to work on a real hardware.

BUG FOUND: In the latest daily version of UUR 11: June 2013, I'm greeted by this terrifying sight:


It seems that the kernel32.dll file is problematic.

In the April 2013 version, everything runs great. Super stable.

Thanks for testing. Something seems to be wrong in the latest kernel32.dll I've added recently. In what situation exactly did the BSOD occur?

Link to comment
Share on other sites

  • Tommy pinned this topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...