Jump to content

automatically enable/disable internet connection


colore
 Share

Recommended Posts

hello

for some reason, my internet adsl connection gets stuffed after some time of inactivity and it becomes unusable

for this reason, I need to automatically disable it when I am leaving my pc (just like the pc detects inactivity and enables screensaver) and re-enable the internet connection when I move my mouse, click my keyboard, etc (just like pc resumes from screensaver)

any idea?

thanks

Link to comment
Share on other sites


I'm confused. If it's a line problem (external to your PC) doesn't the PC automatically reacquire the signal when it becomes available again? If so, what's the problem? And if not, then why will disabling the connection during inactivity help the situation?

Cheers and Regards

Link to comment
Share on other sites

I'm confused. If it's a line problem (external to your PC) doesn't the PC automatically reacquire the signal when it becomes available again? If so, what's the problem? And if not, then why will disabling the connection during inactivity help the situation?

Cheers and Regards

disabling the connection during inactivity helps, because as I was advised from the customer service, my line gets stuffed because of too many errors in packets transmitted, so disabling the line (often restarting my router or even my pc) fixes the problem

this in most cases works, but it is hard to manually do all these each day, an automatic method would be a saviour

Link to comment
Share on other sites

If it takes restarting the PC or router then I don't know if disabling the software end of the connection will really help. Are you currently disabling it manually before you leave the PC so you know for a fact that this will indeed help? And speaking of screensavers, have you tried changing your power settings so that after some amount of inactivity that the PC goes to sleep? (Disable any wake on LAN) If your particular PC can wake up gracefully that might solve the problem.

Cheers and Regards

Link to comment
Share on other sites

If it takes restarting the PC or router then I don't know if disabling the software end of the connection will really help. Are you currently disabling it manually before you leave the PC so you know for a fact that this will indeed help? And speaking of screensavers, have you tried changing your power settings so that after some amount of inactivity that the PC goes to sleep? (Disable any wake on LAN) If your particular PC can wake up gracefully that might solve the problem.

Cheers and Regards

yes indeed it helps

I dont want my pc to go to standby, I just want the connection to be disabled

(I dont even know if getting the pc into standby, disables the connection)

Link to comment
Share on other sites

What exactly are you doing to disable and restart it manually now? If nothing else you might be able to script that with a shortcut on the desktop to make it easier/quicker to do. Also, once you have a script that functions correctly, then it's just a matter of figuring out how to trigger it after xx minutes of inactivity.

Or an extremely simple manual fix, since you don't want to PC to go into standby, unplug the LAN connection when you are not using it. THAT disables the connection. LOL

Cheers and Regards

Edited by bphlpt
Link to comment
Share on other sites

That will only disable the NIC, not the internet connection.

Your problem is the modem / router and the phone line, and seeing you have been talking to "customer service", I recommend that you talk to them again about how to resolve the problem.

Link to comment
Share on other sites

That will only disable the NIC, not the internet connection.

Your problem is the modem / router and the phone line, and seeing you have been talking to "customer service", I recommend that you talk to them again about how to resolve the problem.

there is nothing to resolve

the previous internet provider locked my speed at a lower value to overcome this problem, this company now won't do that and I dont want to do it either

it is due to the distance from the dslam and little can be done

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...