Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


laffinboy

nLite needs which ver of .net?

Recommended Posts

Hi,

I recently built an nLite disk using my original factory install of XP SP3 which included the full ver of .net 3.0. I used that disk to successfully install a fresh copy of XP SP3 on this machine and it's working very well so far. Tonight I did an "online" install of .net 3.5 SP1 Client Profile which is a "light weight" ver of .Net. ("Lightweight" is this case means that it ONLY installed 239MB of crap on my 950mb C: drive!!)

The install program claimed that it was a success. I can see in the reg that it shows .net ver 3.5.30729 which is 3.5 SP1    But when I attempt to run nLite now it throws up an error message saying: "This app requires .Net 3.5 SP1 or greater" ! Which seriously confuses me since (1)  I have that and (2)  the nlite website claims that it only needs .net 2.0 and (3)  nLite ran fine on the previous XP install whch only went up to v3.0. 

Can anyone clue me in here?

laffin_boy

 

Share this post


Link to post
Share on other sites

Guest

You probably need the full installer. Not the client profile. nLite requires .NET 2.0 which is included in 3.5.

Share this post


Link to post
Share on other sites

I'm not sure what really happened here, but I use nLite with .NET 2.0 SP2 (which I only installed for nLite :yes:)

Please attach your Last Session.ini and a screenshot of the warning itself. Which version of nLite are you using?

Cheers

Share this post


Link to post
Share on other sites

Thanks for both your replys.

I'm not sure what really happened here, but I use nLite with .NET 2.0 SP2 (which I only installed for nLite :yes:)

Please attach your Last Session.ini and a screenshot of the warning itself. Which version of nLite are you using?

I'm using nLite 1.4.9.1.

The "Client Profile" ver installs v2 through SP2, v3 through SP2 & v3.5 SP1. I can see this recorded in the reg and also in the layered folders under C:\Windoze\M$.Net\Framework. But nLite throws up an error message for a ver of .Net that it doesn't even use ! and when I run .NetVerCk it shows only v2 & v3 runtimes installed. (ok, after reading their website it appears that the program hasn't been updated since 3.0 was the "top" so it probably isn't capable of seeing 3.5 SP1)

I have a couple of apps i'd like to run that do require .net 3.5 and if the "client Profile" ver is too "lightweight" to work for them @ 239mb I shudder to think what the 'full install" ver of .Net 3.5 SP1 will be.

laffin_boy

LAST SESSION.INI

post-279381-0-43595100-1299433362_thumb.

Edited by laffinboy

Share this post


Link to post
Share on other sites

If you're looking for a proper .NET detector, here's one http://www.asoft.be/prod_netver.html (there are a few around the forums, use search if you like)

As for the screenshot, it looks really, really strange. If .NET framework 2.0 is not installed, nLite tosses a window with a numeric error like this

post-236786-0-21066100-1299457258_thumb.

Share this post


Link to post
Share on other sites

 Thanks again for your reply.

As for the screenshot, it looks really, really strange. If .NET framework 2.0 is not installed, nLite tosses a window with a numeric error like this

post-236786-0-21066100-1299457258_thumb.

 

Looks like I should do a backup image on this install, roll back to my last, pre-.net image and try again w/ the full .net 3.5 SP1 install to see how the apps react to that.  I'll update the thread if I find anything interesting.

laffin_boy

Share this post


Link to post
Share on other sites

An update for people who might read this in the future w/ similar issues:

In the process of troubleshooting I found 4 apps on my computer that need some ver of .Net to run. All 4 of them threw up the exact same error message that I posted a screenshot of even though 3 of them only require .Net 2.0!

So I rolled back to a pre-.Net install image and then downloaded  (239mb) & installed the full version of .Net 3.5 SP1. Now all 4 apps work fine so while I have to concede that it's possible that my my install of the "Client Profile" ver was in some way faulty  I don't think so - I think all of these apps need .Net components not installed w/ the "Client Profile" ver. 

But a word of warning: If you only need .Net for nLite it's far better, bloat-wise, to install just v 2.0 (plus SP's). After weeding 50+mb of msi installers (which, in reality, we're not going to use) this gift from M$ added 450mb to my 710mb C: drive (not counting pagefile)!! Ouch!

laffin_boy

 

 

Share this post


Link to post
Share on other sites
Guest
But a word of warning: If you only need .Net for nLite it's far better, bloat-wise, to install just v 2.0 (plus SP's). After weeding 50+mb of msi installers (which, in reality, we're not going to use) this gift from M$ added 450mb to my 710mb C: drive (not counting pagefile)!! Ouch!

I couldn't agree more. Even ATI's Catalyst Control Center still needs only dotNET 2.0. When installing all of the dotNETs, they take up more space than the XP install itself.

Share this post


Link to post
Share on other sites

Yes, nLite needs only DotNet 2.0 (which is less "bloatware").

But I noticed that it requires a higher version so it can read properly from the Last session files.

With 2.0 it doesn't "see" all the settings.

With 3.5 SP1 it "see" them all. Maybe works also with a version < 3.5 SP1 (but > 2), I don't know, it needs testing...

So, if someone doesn't use Last session, 2.0 is good. If he needs Last session to be read properly it should use a newer version.

Just my opinion...

Oh, and on my computer I solved the problem with 3.5 SP1: I didn't installed it in Windows XP. Instead I created a lite install with ThinApp for nLite which includes also .Net 3.5 SP1.

This way DotNet is used only by nLite in a "Sandbox" (virtual computer) and is not slowing down my OS.

I tested it with a Last session and the result was identical.

It's just an idea...

Share this post


Link to post
Share on other sites

Yes, nLite needs only DotNet 2.0 (which is less "bloatware").

But I noticed that it requires a higher version so it can read properly from the Last session files.

With 2.0 it doesn't "see" all the settings.

With 3.5 SP1 it "see" them all.

? Could you please elaborate on this. What does it not see that it sees with 3.5 ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...