Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Sign in to follow this  

Missing Files - RyanVM Integrator, nLite, DriverPacks

Recommended Posts

These are just a few topics that state similar problems but so far none of their "solutions" seem to work for me.

Tools I use:

Windows XP Mode (Windows XP Pro SP3) on a Windows 7 Pro x86 Dell Optiplex 780

Dell OEM XP Pro SP3 source disk


RyanVM Integrator 1.6

DriverPacks BASE 10.06




Steps I take:

Create the following folders on the XP Mode VM -

  • C:\Custom
  • C:\Custom\XPLite1
  • C:\Custom\XPLite2
  • C:\Custom\XPLite3
  • C:\Custom\XPLite4

C:\Custom is where I store general files relating to customized installations

  1. Using nLite, I copy the Dell OEM XP Pro SP3 CD to the XPLite1 folder (This is my "original copy" folder basically).
  2. I manually copy (ctrl-c, ctrl-v) all files in XPLite1 to XPLite2.
  3. I run RyanVM Integrator, point it to XPLite2, choose the OnePiece Update Pack and attach the Remove Windows Search Addon Pack, check the "Optimize System Files" box and integrate. (See attached RVM_Integrator_1.6.txt file for details)
  4. I then manually copy all files from XPLite2 to XPLite3.
  5. I run nLite to remove some components, add some tweaks... details in the Last Session.txt file
  6. I manually copy all files from XPLite3 to XPLite4 (repetitive I know but it gives me several stopping points to test things from and I have plenty of disk space)
  7. I run DriverPacks and integrate Chipset, CPU, LAN, and Mass Storage drivers... settings details found in the XP_CD.txt file and log found in DPs_BASE.txt
  8. I run nLite again, this time on the XPLite4 directory and choose to only create the bootable ISO (without loading previous sessions or including any other options in nLite)
  9. I copy the ISO file from the XP Mode VM onto the physical computer and burn it to a CD using ImgBurn. (See attached ImgBurn.txt file for the log)

I now take my nice new customized XP installation disk and place it in my old as junk Dell Optiplex 170L and boot to it. After loading all the mass storage drivers and whatnot, I delete all partitions, create a new partition using the full size of the drive (40GB), and format the partition using NTFS Full. Eventually, setup gets to the point where it begins copying files to the HD and soon I begin running into this error message:

Setup cannot copy the file: cdaudio.sys

To retry, press ENTER.

If you are installing from a CD, make sure the Windows XP CD is in the CD-ROM drive.

To skip this file, press ESC.

CAUTION: If you skip this file, Setup may not complete and Windows XP may not work properly.

To quit Setup, press F3

Here is the full list of files that Setup failed to locate:


  1. After skipping each of these files and allowing Setup to continue there was a reboot followed by the DriverPacks Finisher tool running.
  2. The next phase of the Windows installation is the one with the 5 radio like buttons on the left and the timer saying that Setup will complete in approximately 39 minutes.
  3. Now on Installing Devices (37, 36, 35, 34, then 33 minutes remaining)
  4. Installing Network (32, 31, then 30 minutes remaining)
  5. Copying Files (29, 28, 27 minutes remaining)
  6. I missed a few items that went by quickly
  7. Installing Start Menu Items (22, 19 minutes remaining)
  8. Registering Components (18, 17, 16, 15 minutes remaining)

Error message pops up:

Internet Connection Wizard

Windows cannot load the Internet Configuration library (ICFGNT.DLL). The following error occurred: The specified module could not be found.

[ OK ]

Hit the OK button and it seems as though the computer has frozen completely (not surprising considering how many files were missed)

So that's the problem. Now for the various solutions that I've tried:

  • Possible driver.cab corruption - - > Using WinRAR, tested driver.cab throughout all stages including directly on the source CD, in XPLite1, 2, 3, and 4, and on the finished customized CD. All tested OK.
  • Possible missing files in driver.cab, specifically the ones listed above - - > Again, verified each file listed above existed in all locations and then compared file size. All files exist and are the same (except driver.cab itself: source and 1 were 59.8MB, 2, 3, and 4 were all 74.4MB meaning that RyanVM Integrator is what changed the size of the driver.cab file). So apparently, I'm not actually "missing" any files, it's just that the text-setup can't find/read them.
  • driver.pack compression issues - - > Tried using nLite option High Compression and without using it... same results.
  • Symbols in temp folder names - - > Original folder names did have symbols in them, what I've listed above is a later attempt after I had already corrected this... as you can see it didn't fix the problem.
  • Disk Space - - > 118GB currently available... not the answer.
  • nLite confusion with multiple sessions - - > I tried replacing nLite in the ISO creation step with RyanVM Integrator in order to only use nLite once. Didn't change anything.
  • Hardware - - > Believe it or not, I actually did have a problem with my CD drive at one point which caused even more problems but again, replacing it merely got things this far.

Some fixes I have not tried yet:

  • Editing the txtsetup.sif and layout.inf files as suggested in one of the posts listed above. First off, I'm not very familiar with what I'm doing so even though fdv graciously provided simple steps to follow I'm holding off on trying this for the simple reason that no one else has mentioned having to do this kind of thing to get the disk to work. I may try this eventually but not yet. If needed, I can upload those files for you to see. Can't do it in this post though because they're both over 400KB.
  • Using a batch file to extract these files instead of going with the original cab file expanding. Again, this is the only place I've seen this mentioned so I'll be holding off on this until needed.
  • Testing the actual CD after each step instead of doing all steps before testing. This is on my list to do and I'll keep you posted as to how it turns out. One of the four steps is causing this CD to stop working right and I still need to determine which one it is.


I have done this before successfully. I recently had to wipe my hard drive and start over again and ended up losing all the data I had on my virtual machine (all the XP customization stuff). Since then, I've rebuilt the computer almost exactly as it was before but there have been a few updates, OnePiece's Update pack and a few of the DriverPacks as well as upgrading ImgBurn from to I also included an extra DriverPack (Mass Storage) on this new CD that I hadn't been including before. I do still have my last working Custom XP CD and will be comparing files on the two disks once I get some more time to play with things. I would eventually like to move away from having to use nLite so that I can duplicate my efforts at work but until I can find some other tool that gives me the power of customization that nLite does I'm going to have to keep it. As for the RVM Integrator and DriverPacks, they're both here to stay. Any suggestions or help on this problem would be appreciated and if I can offer any more information that would aid someone in fixing this then please let me know.

RyanVM Integrator 1.6


OnePiece XP Post-SP3 AIO Update Pack v4.3.1-101217




DriverPacks 10.06







Last Session.txt




Edited by Fiernaq

Share this post

Link to post
Share on other sites

Coupla things:

Update your ryanvm integrator

The dell source may be the origion of your issues as dell LOVES to add s*** to these disks that rvmi and nLite do not handle well

Share this post

Link to post
Share on other sites

Strange all 4 threads you link are more than 3 years old. Is your Dell cd an original ? Try updating your tools indeed. Then if nothing, try without point 7 to see if you still get the errors. I never used DriverPacks with nLite but there must be a good order. I'm sure you checked ?

Share this post

Link to post
Share on other sites

Happy New Year to everybody :)

RVM hasn't been upgraded since 2009 but that is a good point you bring up... I'll redownload all the software I use to make sure nothing's been corrupted. As for the Dell OEM source I'm using... yes, it could be the source of the problems as well but considering the fact that I have done this exact thing successfully about a month ago, I'm inclined to believe the problem is due to something else; something I actually changed between then and now.

It was interesting how old most of the threads involving this problem are. That's why I was intrigued enough to keep working on it. I'll make sure all my tools are updated and then I'm going to try burning a CD after each step of the process to see where the problem is. Just wanted to let you know that I hadn't abandoned this, just had a fun filled weekend and wasn't working on this problem.



Share this post

Link to post
Share on other sites

Try restart Your PC after each step and test it in virtual machine. This helped me alot in bug findings :)

Share this post

Link to post
Share on other sites

I redownloaded everything and installed it all on a fresh XP Mode VM.

  1. Used RyanVM Integrator to copy files from the CD to the C:\XPLite2 folder, integrate the OnePiece Update Pack and the Remove Windows Search Addon Pack as well as Optimizing the System Files before making an ISO and burning it to a disk using ImgBurn (RVM_Log.txt)
  2. Used RichCopy to duplicate C:\XPLite2 to C:\XPLite4
  3. Used nLite to trim down the install on C:\XPLite4 and then made an ISO and burned it to a disk using ImgBurn (nLite_Log.txt)
  4. Used RichCopy to duplicate C:\XPLite4 to C:\XPLite5
  5. Used DriverPacks Base to integrate CPU, Chipset, LAN and Mass Storage drivers on C:\XPLite5 (DPB_Log.txt)
  6. Used RyanVM Integrator to make an ISO of C:\XPLite5 before burning it to a disk using ImgBurn

All three disks have the same problem of missing files in the dark blue background text install portion immediately following format. This would imply that the problem is in either RVMI or the OnePiece update pack. I'll keep looking for info on this but we can now safely assume that neither nLite or DriverPacks is what's directly causing the issue.




Share this post

Link to post
Share on other sites

Thanks for pointing me to that. I'll give it a try and see what happens. I notice that there's already a comment concerning driver.cab problems on the Chinese Source so maybe I'm running into something related to that.

Share this post

Link to post
Share on other sites

Downloaded and used RVMI 1.6.1 beta 2.1 and ended up with the same story. I did however come across an interesting tidbit on the RyanVM Discussion Board: OnePiece says that I should be integrating first with just the Update Pack and then after I integrate that then I can go ahead and integrate again using any of the "remove" Addons. When I try doing that (using only the source dir, destination dir, update pack, and optimizing system files) it gives me this error message:

Error: No entries*.ini Found, Exiting


I'll try to post this error msg on the RVM Forum after I get my account approved over there but I figured that in the meantime I might as well ask here in case someone knew what to do about this or if it's normal and to be expected or what I should do to fix it.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...