Jump to content

XP-Home install BUG: IERTUTIL.DLL at T-13


Recommended Posts

Hi Folks,

Thanks for the great work and contribs from the whole team.

Before this problem, I already successfully slipstreamed and used several times XP CD,


This time, XP Home edition installation yields to a bug at T-13.

=> Msgbox: Rundll32.exe: not found iertutil.dll file


=> Msgbox: RUNDLL: Error loading IEKCS32.DLL

It seems to be related to IE (version 8 in this case?)

Please find enclosed

- HFSLIPFC messages from runnng CMD console

- HFSLIP log

For short, I use:

- source CD: Win XP Home genuine disk French, purchased license key perfectly granted

- IE8, WMP11, RDC7

- Burn ISO image to DVD-RW

- ALL HF available, except 2 (not mandatory)

FYI, after the first incident while installing,

a second one occurs:

=> MsgBox: Unable to find C:\WINDOWS\system32\Wbem\mofcomp.exe

Then, at end of install, PC reboots as usual, WXP boots,

but after initial WXP splash screen,

screen blanks,

then PC reboots,

and so on, so on.

I went through forum topics,

but I didn't find a matching issue.

Would you be so kind to advice me some reading or procedure to check any further that I prepared the Cd the right way?

I have been trying to rebuild the CD several times, change DVD media, suppressing some folders into SOURCE directory, such as \SUPPORT or \VALUEADD,

but I come to the same pb.

Thanks in advance,




Link to comment
Share on other sites

What's with the "0" for the install path? Why not leave it as default? Are you installing this with a boot cd?

Hello Tommy,

Hold on, "0" install path.

That's in HFANSWER.INI? Oh yes.

Let me check a sec and retry.

Well it's a single CD, bootable, no multiboot.

I doubt this is the key but I try anyway. Thanks

-- Piko

Link to comment
Share on other sites

See, I have just tried the XP-PRO that has been generated with the same inputs as the XP Home CD: it works !

As far as I remember now, my XP-PRO cd were operational,

but my attempts with XP Home were a failure.

I am burning the XP-Home without boot path, just in case,

but again, I doubt this is the key.

Link to comment
Share on other sites

That's what I thought.

Your programs works perfectly when I create a Windows XP PRO CD.

But fails for a XP Home edition. :}

What a pain in the back, this Home edition...

Where should I look first?

May it be IE8 related?


-- Piko

Link to comment
Share on other sites

Sounds like it's ie8 related and/or maybe you're trying to slip something not meant for xphome. You'll need to read the kb articles to verify. I don't have xphome to troubleshoot. I'm afraid you're on your own unless someone else chimes in.

Link to comment
Share on other sites

Sounds like it's ie8 related and/or maybe you're trying to slip something not meant for xphome. You'll need to read the kb articles to verify. I don't have xphome to troubleshoot. I'm afraid you're on your own unless someone else chimes in.

Argh.. :} but ... Why HFSLIPFC does not cope with this issue?

Link to comment
Share on other sites

Maybe try doing the critical stuff first before doing the optional stuff. Try to isolate it the prob. Testing in a vm would help ya out greatly. I routinely "isosize". To isosize is to run the script with a given batch of hotfixes and/or run differnet scripts and see if all works. Isosizing is a great way to kill the day. lol.

I find it weird that the txtmode does not give probs, but later on during setup it says it can't find files. A hfslip'd install generally copies all files it needs except for the ones at svcpack.

From my limited experience, the constant rebooting is due to mui files not getting copied. The mui stuff is from ie8.

Link to comment
Share on other sites

Hello Piko! I was looking at your log files & well... I don't know.... Have you tried the following?

From your hfslipfc log,

1. List not found hotfixes: no

2. DirectX 9 already extracted in HFCABS: no <--From your hfslip-log, directx_feb2010_redist.exe is in the HF folder.

3. Media Player 11 already extracted in HF\WMP11: no

For 1, would you like to try changing the option to yes to make sure something isn't missing?

For 2 & 3, how about extracting the files? (using something like winrar or izarc)

Once they are extracted with winrar or izarc or some other zipping utility to the proper folders, I remove the exe files themselves from the HF folder (or Mim0's checker will do it for you, if you configure it to do so.) Check Mimo's Updates List Page again for more information--like how the folders should be named!

From your hfslip-log & consulting Mimo's Updates List Page,

Files in your HFTOOLS folder:


bbie.lic --------> does not belong (as far as I saw)




cmdow.v1.4.3.hash.txt --------> does not belong (as far as I saw)



ModifyPE.asm --------> does not belong (as far as I saw)


modifype.txt --------> does not belong (as far as I saw)

PE-Header.INC --------> does not belong (as far as I saw)

readme.txt --------> does not belong (as far as I saw)

Standard.inc --------> does not belong (as far as I saw)

wget.exe --------> does not belong (as far as I saw) I have it in the hfslip folder itself. I'm not sure if that would make a difference, though....

Win32definitions.inc --------> does not belong (as far as I saw)

In the tools folder, I also have something called EXTRACT.EXE in the hftools folder. (I think it has something to do with how cab files are processed... I don't remember exactly.) MS' Cabsdk On the hfslip website, there is an explanation for it in the Extras section under the Guidelines tab. Also, in my hftools folder is the 7za.exe; I put it in there, even though I didn't think I would use it.

The only other thing in my hftools folder is HFSLIP_POST_getnewfiles_v3.cmd . An explanation is found under #9 of the Advanced Features page in the More tab.

When I run hfslip, the option I've used is A... (That should merge everything into 1 file, I think & is the default option).

As someone suggested before, I have the CD Install Path set to default.

Also, Piko, what OS are using hfslip on? (There are issues with slipstreaming sp3 into an XP source using Windows 2000, I believe.)

I think this is everything I saw from looking at the log files.

These are small things.... I do not know if they will solve the problem... but maybe they are worth a try??

Edited by keirkei
Link to comment
Share on other sites

To echo keirkei's post, if you aren't sure how to use hfanswer.ini, just don't use it. Hfanswer is more of an advanced thing and assumes that your fileset is functioning properly.

Link to comment
Share on other sites

  • 1 month later...

I have exactly the same problem as Piko (WinXP Home French SP3+IE8+DX9+WMP11+most updates, the missing ones being hotfixes and not recommended/wanted updates).

I then tried with IE6 (removed all IE8 and all its updates, replaced with IE6 updates), and manualy extracted DX9/WMP11 to the appropriate directories.

The result is: still have the missing mofcomp.exe message, Windows XP boots, but then there's a message box Rundll32.exe: not found framedyn.dll file (twice) and another telling srclient.dll failed to launch.

IE6 installation failed.

I can't find framedyn.dll nor mofcomp.exe anywhere on C:, but framedyn.dl_ and mofcomp.ex_ are in i386 folder of the installation DVD.

Any idea of what's wrong ?

I attached hfslip (1.7.10_beta_H) and hfslipc logs, and some files from I386 installation DVD (I sorted by date and took relevant text files).




Link to comment
Share on other sites

I'm unsure if piko solved his problem or if he gave up. You have some non-essentials in HF. KB961742 for starters. There's something that is extracting a file called uiautomationcore.dll and wdfcoinstaller01007.dll and some others that don't follow the 8.3 naming standard. The framedyn prob creeps up once in a while (search the whole forum). It's called out when wbemoc.inf is parsed. I'd recommend to re-re-re-review your HF structure and include only the critical hotfixes for starters. Then slowly add in the optional stuff. 9999 times out of 10000 you don't need the optional hotfixes unless you want to compromise your system by making WU happy. You may want to not use hfanswer (not sure if you're using it or not).

Link to comment
Share on other sites

Thank you very much for the very fast answer, I will investigate and report the results as soon as possible (in case it could help others).

I just did a test DVD with the content of my SOURCE directory (because I have a winnt.sif and I manualy integrated two SATA drivers by modifying TXTSETUP.SIF and DOSNET.INF + makecab of drivers files into I386, so I wanted to check that), evrything's fine.

I will try first to integrate some normal Windows updates with HFSLIP, if it's OK, I'll integrate more pieces...

It's not my first try at HFSLIP (I used it for 10 or 12 installations, for me, friends and familly) but it's the first time I had such strange results (before that, my only real problems were with winnt.sif badly configured or wrong driver integration).

By the way, many files were missing after the HFSLIP-with-IE6-only installation, not only mofcomp.exe and framedyn.dll, but also calc.exe and many, many more. Most of the shortcuts in the Start menu were missing too. With my SOURCE based installation (same winnt.sif), everything is perfectly OK.

I'd prefer to have updates+WMP11+DX9+IE8 integrated to minimize updates history that grows more and more and slow down Windows startup when it tries to check for new updates (6 month ago, I had a five year old XP Pro PC at work with all and every updates after the original version of Windows XP, it started slowwwww whatever I tried to fix it just because of that, almost locked for a full minute AFTER login, I diagnosed that with the help of SysInternals' ProcessMonitorit was processing \Windows\$*$ directories and DataStore for a full minute on each startup, DataStore.edb grown up to 54MB, even when forced to rebuild from scratch).

Edited by seabee
Link to comment
Share on other sites

I found a bug in HFSLIP :CHECKWINVER processing of non-US versions. On a WinXP Home SP3 French SOURCE, the line:


sets V1=XP (this is OK), V2=Édition (V2=Home expected later in the batch to execute set SUBTAG=ic) and V3=familiale (ignored for XP).

So SUBTAG stay undefined (empty), then when :WBEMFIX is executed, REN "WORK\WBEMFIX\wbemoc_UNI_%SUBTAG%.txt" wbemoc.inf fail !

But as IF EXIST WORK\WBEMFIX\wbemoc_%LNG%_str.txt is true (%LNG%=FRA), CMD/U/C "TYPE WORK\WBEMFIX\wbemoc_%LNG%_str.txt>>WORK\WBEMFIX\wbemoc.inf" is successfull and wbemoc.inf is completely corrupted !

Only two lines in Unicode but without the BOM (Byte Order Mark, FF FE on Little Endian plateforms):


WBEM_TIP = "Infrastructure de gestion Windows"

The only "automatic" solution is to have a mapping table between %LNG% and the exepected value for %V2%%V3% (for Home versions, HomeEdition for ENU, Éditionfamiliale for FRA etc. and pro versions).

The undefined SUBTAG probably have other negative effects.

I'd try to force SUBTAG=ic before excution of HFSLIP.

Edited by seabee
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...