Jump to content

Trace Windows 7 boot/shutdown/hibernate/standby/resume issues


Recommended Posts

What about the dcomlaunch svchost (844)  I see that takes about the same amount of time i am on that black window with a mouse cursor?

My boot time log details has this:



Log Name:      Microsoft-Windows-Diagnostics-Performance/Operational
Source:        Microsoft-Windows-Diagnostics-Performance
Date:          5/23/2015 8:21:34 AM
Event ID:      100
Task Category: Boot Performance Monitoring
Level:         Warning
Keywords:      Event Log
User:          LOCAL SERVICE
Computer:      Admin-PC
Windows has started up:
     Boot Duration        :    78019ms
     IsDegradation        :    false
     Incident Time (UTC)    :    ‎2015‎-‎05‎-‎23T13:19:06.578000100Z
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="Microsoft-Windows-Diagnostics-Performance" Guid="{CFC18EC0-96B1-4EBA-961B-622CAEE05B0A}" />
    <TimeCreated SystemTime="2015-05-23T13:21:34.289551000Z" />
    <Correlation ActivityID="{02EB6C40-F800-0000-2433-C50B5B95D001}" />
    <Execution ProcessID="1588" ThreadID="3744" />
    <Security UserID="S-1-5-19" />
    <Data Name="BootTsVersion">2</Data>
    <Data Name="BootStartTime">2015-05-23T13:19:06.578000100Z</Data>
    <Data Name="BootEndTime">2015-05-23T13:21:31.838410800Z</Data>
    <Data Name="SystemBootInstance">114</Data>
    <Data Name="UserBootInstance">111</Data>
    <Data Name="BootTime">78019</Data>
    <Data Name="MainPathBootTime">49819</Data>
    <Data Name="BootKernelInitTime">40</Data>
    <Data Name="BootDriverInitTime">519</Data>
    <Data Name="BootDevicesInitTime">697</Data>
    <Data Name="BootPrefetchInitTime">0</Data>
    <Data Name="BootPrefetchBytes">0</Data>
    <Data Name="BootAutoChkTime">0</Data>
    <Data Name="BootSmssInitTime">4005</Data>
    <Data Name="BootCriticalServicesInitTime">40736</Data>
    <Data Name="BootUserProfileProcessingTime">230</Data>
    <Data Name="BootMachineProfileProcessingTime">3</Data>
    <Data Name="BootExplorerInitTime">965</Data>
    <Data Name="BootNumStartupApps">10</Data>
    <Data Name="BootPostBootTime">28200</Data>
    <Data Name="BootIsRebootAfterInstall">false</Data>
    <Data Name="BootRootCauseStepImprovementBits">0</Data>
    <Data Name="BootRootCauseGradualImprovementBits">0</Data>
    <Data Name="BootRootCauseStepDegradationBits">0</Data>
    <Data Name="BootRootCauseGradualDegradationBits">0</Data>
    <Data Name="BootIsDegradation">false</Data>
    <Data Name="BootIsStepDegradation">false</Data>
    <Data Name="BootIsGradualDegradation">false</Data>
    <Data Name="BootImprovementDelta">0</Data>
    <Data Name="BootDegradationDelta">0</Data>
    <Data Name="BootIsRootCauseIdentified">false</Data>
    <Data Name="OSLoaderDuration">579</Data>
    <Data Name="BootPNPInitStartTimeMS">40</Data>
    <Data Name="BootPNPInitDuration">937</Data>
    <Data Name="OtherKernelInitDuration">201</Data>
    <Data Name="SystemPNPInitStartTimeMS">1132</Data>
    <Data Name="SystemPNPInitDuration">279</Data>
    <Data Name="SessionInitStartTimeMS">1418</Data>
    <Data Name="Session0InitDuration">2511</Data>
    <Data Name="Session1InitDuration">383</Data>
    <Data Name="SessionInitOtherDuration">1110</Data>
    <Data Name="WinLogonStartTimeMS">5423</Data>
    <Data Name="OtherLogonInitActivityDuration">43196</Data>
    <Data Name="UserLogonWaitDuration">5537</Data>


Do those times above help in determining what is causing the delay?


No changes that I know of.  I 'think' it started right after we ha d thunder storm go by, power to the house would go out and come right back on, Happened about 4 or 5 times in 10-15 minutes.  Computer was on each time. 

Link to comment
Share on other sites

Well that is unfortunate.   Nothing I can do about the dcomlaunch causing the delay now?


No changes, only thing diff is the storm I mentioned above.  Well I do appreciate you trying though.  Thanks a bunch.


Running the first script still shows rpcss as the cause but I guess the other ones ya had me run go deeper into the rpcss? 

Edited by Murf
Link to comment
Share on other sites

OT, and probably unrelated.


Over the years I have had every kind of *queer* hardware issues as the effect of storms (or of power surges or of both).

While the most typical one is obviously the PSU not working anymore, I had one case several years ago that may be loosely connected to your issue.

During a storm a lighting struck near the building and (presumably or at least this is the most logical explanation we could find) *somehow* raised the "ground level" in such a way that several devices (on the "low voltage" side, not on "mains" side) were affected, namely:

  1. a couple of modules of the telephone PBX
  2. the serial printer connected to the PBX (but not the serial port module on the PBX)
  3. a couple network cards on different PC's (replaceable)
  4. some ports ONLY on a network hub/switch (but NOT the ones to which the above and the below computer were connected to)
  5. a small VIA EPIA motherboard (with an integrated network card stopped booting, as a matter of fact it took like three minutes to boot to Windows 2000 and then the network card wouldn't work properly/reliably).


The strange thing is #5 as the network card diagnostics (in DOS, i.e. NDIS or whatever it is/was called) gave a fully working card as a result.

However, in the immediate I disabled the embedded network card and added a PCI one and everything went back to normal.

Later the motherboard was replaced and - just for the fun of it - I tried using the old, defective one for running just DOS (without network connection) and it worked fine, then I tried re-enabling the embedded network card and it did work (from DOS) just fine, still Windows 2000 would take forever to boot and then the network card had "intermittent" working.



So, I know that it sounds crazy :w00t::ph34r:, but since the issue revolves around rpcrt4.dll, which is connected with network, if that machine is a desktop, can you try and see what happens if you disable the network interface and/or use an add-on network card instead?



Link to comment
Share on other sites

Can u help me with analyzing my boot trace? 

Here is the file: http://www.filedropper.com/bootbasecswitchpower1


And this is my boot trace after I followed this guide: http://www.msfn.org/board/topic/140262-how-to-speed-up-boot-process-under-windows-vista-or-windows-7/

file: http://www.filedropper.com/bootbasecswitchpower1_1

Best regards~

Edited by Violent
Link to comment
Share on other sites

  • 4 weeks later...



I have spent hours and hours (and money on new drives) trying to work this one out. The Xperf file has led me to a slow BIOS startup (BIOSINIT).

When resuming from sleep it was taking 30 seconds, 29 of which were BIOS init. I guessed this as drives were seeking and the Windows Performance Toolkit had "No Trace" at this time.


The solution seems totally ridiculous but BIOS init is now down to 950ms:


I changed which SATA port I had each drive connected to on the motherboard. I had my boot drives (I have 2 OSs) randomly assigned, both to SATA slave ports. I changed them both to primary ports and disabled "boot from cd" etc in the BIOS and EUREKA.


System is a s775 with an intel G41 chipset, a few with the same chipset with similar problems. Good luck!

Link to comment
Share on other sites

  • 3 weeks later...

With Lenovo notebooks and SSD, Synaptics Thinkpad UltraNav Driver makes a boot-delay about 20 seconds.

Uninstall it to boot faster.


With Synaptics Driver:

BootTime 46871
MainPathBootTime 26471
OtherLogonInitActivityDuration 20913

Without Synaptics Driver:
BootTime 24348
MainPathBootTime 5848
OtherLogonInitActivityDuration 901


Successfuly tried on Lenovo Thinkpad X220 and Thinkpad E520.

Link to comment
Share on other sites

  • 3 weeks later...

MagicAndre1981, help me, please. I having a problem with a slow shutdown on Notebook ASUS K53SC with Windows 7 SP1 Home Basic 64-bit onboard.




The XML and ETL files inside this archive. I'll be very appreciated.


Edited by yuri
Link to comment
Share on other sites

  • 2 weeks later...


ok was able to solve my issue. It seems that some old drivers (like atipice, amdsata and others have existed in the system). But was hard to find and neede many tries :-) Now OSLOADERDURATION is less than a second.


*** original text ****

I have slow booting machine also :-(.

I checked Eventviewer and saw that "OSLOADERDURATION" is around 65 seconds.

The delay appears after the text "Windows starting" and before the flying windows are appearing (it takes really long till the flying windows are coming). After the flying windows it feels normal from a performance point of view. Drivers are actual (up to my knowledge) and all windows updates are installed. The issue is also the same after updating to win10.


Here you can find the summary boot: https://drive.google.com/file/d/0B8h6qtN6a-IMaUY5elYxTWZHNTg/view?usp=sharing

and the etl: https://drive.google.com/file/d/0B8h6qtN6a-IMY2NveUphQ19iV28/view?usp=sharing


I also already searched in the web for OSLOADERDURATION issues and the boot loader phase but was not really successful...


In parallel also the shutdown is relatively slow but as I normally do not sit in front of the machine during shutdown that is not so important ;-)

But here the output of the shutdown from the event log: https://drive.google.com/file/d/0B8h6qtN6a-IMckNkNGRCQWNDQ1E/view?usp=sharing

(I have not traced the shutdown till now- if it is helpful I will do)

If somebody has an idea it will be really great!


machine data:

motherboard: GA-MA78GPM-DS2H, AMD 780G (BIOS F6H)

Processor: AMD Phenom II X6 1090T

C-Drive: SSD Samsung SSD 850 EVO 250GB

D-Drive: ST2000DL



If anything else is needed tell me...

Thanks and Kind Regards,


Edited by Marco_E72
Link to comment
Share on other sites

  • 3 months later...

Hi Andre,


Once more I have problems with my boot process. And once more I dont know the reasons. Its probably at the end of the boot process, when the computer tries to connect to my router?

I have uploaded the zipped etl-file to google drive. Perhaps you can help me to find the error?

Many thanks in advance,

Edited by albert1234
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...