Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Syclone0044

FYI: Firefox 3.5 may cause your PC to lag and stutter on youtube - Sol

Recommended Posts

Guys I troubleshooted for months trying to solve this. LONG story short, the problem turned out to be a bad design in Firefox 3.5. It writes all your tabs and session data to disk in a blocking main thread, every 10 seconds.

The solution is to increase that interval in your about:config to something like once every 5 minutes. Check this out:

https://support.mozilla.com/tiki-view_forum...0&forumId=1

http://www.reddit.com/r/todayilearned/comm...ery_10_seconds/

This single issue is the largest Firefox performance disaster I've ever seen!

Here's a guy who bought a new PC JUST because of this issue (he thought his PC was the problem.) http://lifehacker.com/5342636/how-to-fix-a...ness-in-firefox

I just spent WEEKS troubleshooting the crap out of this problem, and could not solve it. I was tracing stacks on Firefox.exe threads in Process Explorer, debugging memory dumps in WinDbg, running safe mode, trying processor optimized builds, reverting to FF 3.5.0, reverting to FF 3.0.13, swapping out my Sessionstore.js, etc.

This post by a Mozilla developer sheds some light on the technicalities causing this: http://shawnwilsher.com/archives/294/

----------

This affected so many people it's outrageous. I had to share it here because I saw a thread where someone was complaining about their youtube and PC lagging in general. Hope it helps someone; it's helped thousands already!

Share this post


Link to post
Share on other sites

Confirm. Ff3.50 and 3.52 are worse on YouTube and other videos. Thanks to have pinpointed the cause!

Ff3.50 and 3.52 have other drawbacks. Nothing damning, but interface choices (leave the app open if no document displayed...) that are less comfortable now. And the improvements I hoped (a working mouse scroll, compatible with my added driver 4dmain.exe) don't arrive.

I'll revert to Ff3.00 next.

Share this post


Link to post
Share on other sites
I just spent WEEKS troubleshooting the crap out of this problem, and could not solve it. I was tracing stacks on Firefox.exe threads in Process Explorer, debugging memory dumps in WinDbg, running safe mode, trying processor optimized builds, reverting to FF 3.5.0, reverting to FF 3.0.13, swapping out my Sessionstore.js, etc.

have you guys tried reproducing the problem in newly released FF versions 3.0.14 and 3.5.3?

Share this post


Link to post
Share on other sites

FF runs into nearly 100% CPU-Usage when opening a chat (webkicks.de) when

flashed animations are used. I tried same page with same animations with Opera -

nearly NO CPU-Usage accured. It`s a strange behaviour, even a fresh install of FF is like that.

My girlfriend`s PC (my older outdated AMD SingleCore) run into freezes by that.

Share this post


Link to post
Share on other sites
FF runs into nearly 100% CPU-Usage when opening a chat (webkicks.de) when

flashed animations are used. I tried same page with same animations with Opera -

nearly NO CPU-Usage accured. It`s a strange behaviour, even a fresh install of FF is like that.

My girlfriend`s PC (my older outdated AMD SingleCore) run into freezes by that.

what specific versions of Firefox are you and your girlfriend are using, g-force?

Share this post


Link to post
Share on other sites

I`m running into these problems with

- FF 3.5.2 (fresh & clean install)

- FF 3.5.3 (portable, some addons)

- FF 3.6 (portable, some addons)

- FF 3.7 (portable, some addons)

Newest Flashplayer is installed.

Share this post


Link to post
Share on other sites

I've noticed this at work as well, but also at home. My PC at home has a newer version installed somehow, an update that made things a little better, but the one at work doesn't see that update available.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...