Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


The Solution for Seagate 7200.11 HDDs

Recommended Posts

My apologies for the slight threadjack, but the strangest thing has happened.

The suspect is a Seagate ST3500320AS 500GB SATA drive. It was used as an external backup drive with a CoolerMaster XCraft USB SATA enclosure.

Yesterday, I tried moving some files across from the external Seagate drive to a PC that had recently had Win XP32 reinstalled. All seemed fine until the drive went all quiet and it disappeared from Win explorer.

So I cycled the power on the external drive, but to no avail. Rebooted the PC - nothing. Tried it on the laptop - Nope! Tried it on my wife's XP PC - nothing again.

So after some searching on the NET I realised that SD15 is bad and I should update the firmware - so I plonked the ISO image from Seagate (SD1A) on a CDROM and placed the affected drive inside the PC. It doesn't have an OS installed on it, but that's OK, it is only used for backups and besides I was booting from the CDROM. Also, the PC is small factor so it only fits one hard drive at a time.

Anyways, the upgrade was successful. I cycled the power, BIOS recognised it, and showed capacity as 500G. Sweet!

So I take it out of the PC and back into the Cooler Master USB enclosure. No go! None of the Windows PCs could see it. Grmph....

After some digging today, I discovered this cool forum. So here I was ready to order a cable as per the procedure in this thread and do the deed (after those !@#&^%!@# at Seagate indicated that they didn't give a toss about the data on my drive).

Then it hit me. Why was my BIOS detecting the drive correctly (model and size)? So, I decided to plonk it back into the PC - but boot from the LIVE Ubuntu Linux PC (my actual Linux PC only has IDE).

To my surprise LINUX could read it!!! WTF? I take the drive out of the PC and placed it in the external USB enclosure. Again, same PC but connected via USB - Linux had no problems!!!

So is it something with Win XP and my external enclosure? OK, I took the bootable Maxtor drive out of my PC and placed it into the eternal USB enclosure. I can access it from any Win XP PC.

So now I am confused. The external enclosure works with Linux and Win XP - when the Maxtor SATA drive is used, but only works with Linux when Seagate is used. The drive is not bricked as Linux can access it. And this happened all of a sudden. I transferred all this data from it and when the transfer completed - nothing! Now, I don't know if the firmware upgrade to SD1A helped, I never tried accessing the drive via Linux with SD15.

I can't help but think that this is a related Seagate issue. I returned a Seagate Freeagent drive last year because that had issues with Win XP, and now this? Maybe its time to go back to WD...

Does anyone have any idea what is going on here? I am going to extract the data from the drive ASAP, and then this 'nutcracker' is going back to Seagate.


Share this post

Link to post
Share on other sites

I want to add my thanks to Gradius, Aviko and AlexLilic !!!!!

Without your excellent advice I would still be swearing and cursing. There were a few confusing parts, and definitely a few heart stopping moments, but my drive is now alive, and my data safe. :)

For anyone else going to give this a go then I totally recommend the FTDI TTL-232R-3V3 USB Cable. This was a very simple cable to use following AlexLilic wiring directions (on page 35). The ideal part about this cable is you don't have to play around with any additional power (battery or mains). For those in the UK I got mine from FTDI TTL-232R-3V3 USB . Outstanding service as this was posted to me the same day !!

Note: You DO need the standard SATA power cable connected to the disk drive. (This confused me for quite a while) I used a spare power lead from another PC. This also allowed me to easily turn on and off the power to the drive.

For those with a disk set up like mine I had the jumper over the 3rd and 4th pins on the disk. I had to take this off so that I could connect the ground cable. As soon as I did that then the "F3 T>" prompt.

Also note that as I only used the single card under the drive spindle (the one at the centre of the disk) it means YOU MUST TURN OFF THE POWER TO THE DRIVE (i.e turn off the SATA power supply you connected to the disk) before you issue the Partition regeneration "m0,2,2,,,,,22" command. Gradius clearly mentions this a number of times, but I noted a few others have missed this step. I missed this the first time, but maybe got lucky and now have a working drive :)

As an additional item, I also had trouble updating the firmware. I was getting an error on booting from the CD. I had to turn off the RAID support within the BIOS. After that everything worked and I managed to update to the latest firmware. I can only hope that this fixes the problem for good.

Share this post

Link to post
Share on other sites

I just wanted to add this note for the record. I am one of the ones that cannot get the drive (ST31000340AS) to spin up again. I get:

F3 T>/2

F3 2> Z

Spin Down Complete

Elapsed Time 0.154 msecs

(Paper card Removed)

F3 2> U

(Drive begins to emit a quiet Buzzing noise every 4.0 seconds. Seven Minutes later..)

Error 1009 DETSEC 00006008

Spin Error

Elapsed Time 7 mins 27 secs

R/W Status 2 R/W Error 84150180

It is repeatable everytime. I have:

1) Isolated both connectors

2) Cleaned both board contact pads and connection points

3) Tried both level 2 and 3 spin down

4) Read every post in 59 pages!

Nothing changed the symptoms. If anyone knows of any solution, I welcome the feedback. Otherwise, thanks for the excellent instructions Gradius2and Aviko and for the excellent feedback I've gotten here. You guys did a great job of diagnosing the problem and getting a solution for many users!

Share this post

Link to post
Share on other sites

Can anybody confirm that Seagate does the free data rescue?

I can't do the tutorial here, I would ruin the drive and lose my things forever.

Share this post

Link to post
Share on other sites

Annihilator: I have been around and around with Seagate all day. They will NOT recover my data, but it is because I have the SD14 firmware in my ST31000340AS. They are willing to replace the drive, but no repair or data recovery (my error: for $2900 they will recover the data). So forgive me if I'm a bit pi***d off at a company with a known design defect that refuses to assist their customers. Needless to say this is my LAST seagate pos. Having said this, you may want to call them. I got the impression that if my firmware was SD15 they might have worked with me. Also call their data recovery company and they may be able to handle it for you. Good luck!

Share this post

Link to post
Share on other sites

Oh s***. Thats no good news. I have SD15 tho.

And they are not even replying me! I sent them an email 3 days ago, and another one today, and the support doesnt reply.

Share this post

Link to post
Share on other sites
Ok, the drives are 100%. :w00t::thumbup

I didn't loss anything, it went back to it were before BSY error (and I almost had a heart attack!).

This is a direct guide for BSY error, for details and more, check the 1st msg on this topic.

Can you repost pics from your post about repairing seagate, due to deleted from original location ?

I mean this thread:


and this pics






Thank you!

Share this post

Link to post
Share on other sites

Guys, I have an odd solution for probably only some of you, but if you have SD14 firmware (and my drive is the ST31000340AS) and experienced the problem of the drive not being recognized by the BIOS, Seagate is going to do nothing to help you. My problem was identical to the BSY problem everyone else is experiencing, however the fix did not work for me. I could spin down the drive but not spin it up again. It would quietly buzz for about 7 minutes then display a read/write error (see about 3 posts back for a detailed failure). At any rate, after being quoted $2900 by Seagate to recover my data, and having tried every solution I have seen on the board, I finally was able to get my drive to boot up and I am now happily copying files to a different drive! Here is the process (and please do not laugh: desperate times breed desperate measures).

1. Remove your hard drive from the computer.

2. Place it in an antistatic bag.

3. Place the drive and antistatic bag into a large ziplock bag and seal it.

4. Place the drive in the freezer (yes, the refrigerator freezer) for 2-3 hours.

5. Remove the drive and quickly install it in your computer.

6. Turn the computer on to boot like normal (assuming this is your boot drive of course).

7. If you are lucky, yours will boot just like mine did!

8. Wasting no time, copy your files to another drive.

9. Remove the POS Seagate and burn it at an alter (not required step).

I know it sounds crazy but it worked for me. Muskieratboi (page 46) and a few others that had the same symptoms I did, you may be experiencing another problem. What does it hurt to try? Freeze that mofo and give it a whirl. After freezing, just install the drive and try to use it. I would not waste time trying to go through the repair process (not that it is a waste of time, I just do not know how long the frozen drive will stay in a working state.)

BTW, I cannot take credit for this fix. There was a quick post earlier by someone that did this and it worked for them. I blew past it then thinking it was a fluke, but hey! It worked!

Share this post

Link to post
Share on other sites

The thing with the freezer only works (sometimes) when you have physical damage I believe, but it won't help you with a software problem. Also you have only one try, because when it unfreezes, water will get in and your drive is gone. So be careful with that.

Share this post

Link to post
Share on other sites

Good point Annihilator, and maybe I should have been more clear that I would do this only as a last resort and in a desperate attempt to get your data. My POS drive is going to be replaced by Seagate then thrown in the garbage. I have no long term plans for the drive, so condensation was not an issue for me. I'm still bitter with the way Seagate handled this situation, so Hitachi gets my business next. Also, my company manufactures a product that uses a HDD and guess what I found out yesterday? We had just switched to Seagate drives!!! I sat down with the Engineers and Product Managers and showed them the printouts of Seagate's TS response and took them to some forums of Seagate users: needless to say all product shipments are on hold pending a new drive being spec'd in. I cannot do business with a company that has proven to be unwilling to do the right thing by their customers, even if the company has a good name for products overall. Sorry to digress but like I said I am still a little bitter.

Share this post

Link to post
Share on other sites

A small advise.

The problem with condensation can be reduced greatly if using one of those bags with a valve and using a vacuum pump (or a small vacuum cleaner) to remove air from it.

Something like this:


Even the poor man's method:

I hate to give a hint to take the place of the vacuum sealer, but what I do is put whatever I want to save in a re-sealable plastic bag, seal all but about 1/2 inch, put in a straw, then suck out the air and quickly close the last half inch. Gives you a completely airless package.

is better than having (humid) air inside the bag.

The bag itself should have been kept in a warm dry place before using, of course.


Share this post

Link to post
Share on other sites

Hi. Is this repair also for maxtor diamondmax HDDs? My drive is also dead, and is affected by this problem... I would like to test this solution, but there are no images in forum... It is not complicated solution for me, but I dont know, where is Tx and Rx on HDD. Thanks for your reply.

Share this post

Link to post
Share on other sites

A big heartfelt thank you to all those who have helped in providing the instructions and support on the forum. I have just managed to resurrect my Seagate drive with a USB to TTL Serial Cable (TTL-232R-3V3).

I did encounter 2 issues however:

1) I put a business card between the head contact and PCB, and rescrewed the PCB board back onto the hdd. I however tightened the screws too much and couldn't get the drive to spin down as I kept getting the LED:000000CE FAddr:00280569 error! I restarted the procedure after Aviko's post #465 (I believe I had retightened too much and hence there was still contact) and managed to get back to the magical F3 prompt!!

2) Second time round I managed to spin down the motor, but couldn't spin it up! This was because I was hoping that only screwing 5 screws (i.e. not screwing the one near the head contact) would be sufficient. After reading through the posts again, someone had kindly noted that the "Error 1009 DETSEC 00006008 Spin Error error" was due to lack of contact Post #701. I very tentatively placed the screw back (making sure it didn't touch the PCB) and its all back now!!

I am totally ecstatic that my hdd is back and that I can now recover all my photos - Again, thank you all to all those that have contributed, my success would not have been possible without your patience and willingness to help!

Share this post

Link to post
Share on other sites

Again, with the freezer method you will most likely kill your harddrive and if it works you only have 20 minutes at most until it dies, to copy off your data.

I wouldn't do it as long as you arent totally desperate, it should really be the last try. Also be sure to keep the hdd cool when using it, so you can maybe get a few more minutes out of it. Also keep it out of the case while running if possible. A

I wouldn't recommend it tho, because it will only work in certain cases if you harddrive has a physical damage and if you have a defect firmware etc, it will just kill it.

Share this post

Link to post
Share on other sites

Try these commands

Press Ctrl+Z and wait for the prompt

F3 T>

Enter commands

F3 T>i1,1,22 (and Enter)

F3 T>m0,2,2,,,,,22 (and Enter)

This helps to fix the problem for sure

Edited by LED_000000CC

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.