Jump to content

%cdrom% variable problem


 Share

Recommended Posts

I just start using WPI 7.2.1 and now all my application failed to install and when i look into the WPI logs there is a bug with the path for the programs to install, the variable %cdrom% return nothing so the cdrom drive letter is missing from the command to run.

Anyone have an idea ?

Link to comment
Share on other sites


That is correct. When run WPI from harddrive, %cdrom% is blank. When run from a cd/dvd %cdrom% will be set accordingly. If you want to do installs from desktop, you need to start WPI from the CD, not from C:.

Link to comment
Share on other sites

OK so the file you send me solve nothing so i tried to start WPI directly from the CDROM and still no luck with it. I am starting WPI from a batch file and i think the problem came from there because if i go directly in the WPI folder on the CDROM and start WPI.HTA by myself it work but i need to start it from a batch file any workaround for that ?

Link to comment
Share on other sites

Echo off

for %%i in (C D E F G H I J K L M N O P Q R S T U V W X Y Z) do if exist %%i:\win51ip.sp3 set CDR=%%i:

echo Found CD-Rom as drive %CDROM%

start /wait %CDR%\WPI\WPI\WPI.hta

start /wait %systemdrive%\clean.bat

CMD /C del %systemdrive%\clean.bat

Link to comment
Share on other sites

Dunno, man. I sent the same file to another guy, works fine for him in same situation.

I would download my $OEM$ scripts from the main version post to set the reg keys needed for some programs.

Your script is fine. I will think some more about it.............

Link to comment
Share on other sites

win51ip.sp3

this is the section of the script you have to worry about, it looks for this file on the CD if it is there then the %CDROM% parameter is set but if it does not find it then it will not be set.

Change this to the file on the CD you have and it will work

Don't worry I am on a steep learning curve with creating unattended installs so if this is wrong shoot me!!!!

Link to comment
Share on other sites

Here a C&P of my logs when i directly start WPI from the CD-Rom:

Fichier log d'installation WPI

Début d'installation à: 16 décembre 2008 11:57:08

Variables Globales :

%OSLANG%=

%WPIPATH%=D:\$OEM$\$1\WPI

%ROOT%=D:\$OEM$\$1

%CDROM%=D:

%DOSPATH%=

%SYSDRV%=C:

%WINDIR%=C:\WINDOWS

%PROGRAMFILES%=C:\Program Files

%TEMP%=C:\DOCUME~1\UTILIS~1\LOCALS~1\Temp

%SYSDIR%=C:\WINDOWS\system32

%ALLUSERSPROFILE%=C:\Documents and Settings\All Users

%USERPROFILE%=C:\Documents and Settings\Utilisateur standard

%APPDATA%=C:\Documents and Settings\Utilisateur standard\Application Data

%COMMONPROGRAMFILES%=C:\Program Files\Fichiers communs

Liste des programmes à installer:

.NET Framework 2.0

.NET Framework 3.5

.NET Framework 1.1

Mises-à-jour Diverses

Office 2007 Home & Student

PowerDVD 7.0

Nero 7.x OEM

Kaspersky Antivirus 2009

Flash/Shockwave pour IE7

9 Items, 12 Commandes

-----

16 décembre 2008 11:57:08

Program: .NET Framework 2.0

ID unique: NETFRAMEWORK20

Ordre: 900001

Catégorie: System

16 décembre 2008 11:58:02 - cmd1 Succès (Code de retour 0): "D:\WPI\Système\Dotnet\DNF20.exe"

16 décembre 2008 11:58:02 - Installation terminée.

-----

16 décembre 2008 11:58:02

Program: .NET Framework 3.5

ID unique: NETFRAMEWORK30

Ordre: 900002

Catégorie: System

16 décembre 2008 12:06:22 - cmd1 Succès (Code de retour 0): "D:\WPI\Système\Dotnet\DNF35.exe"

16 décembre 2008 12:06:22 - Installation terminée.

-----

16 décembre 2008 12:06:22

Program: .NET Framework 1.1

ID unique: NETFRAMEWORK11

Ordre: 900003

Catégorie: System

16 décembre 2008 12:07:02 - cmd1 Succès (Code de retour 0): "D:\WPI\Système\Dotnet\DNF11.exe"

16 décembre 2008 12:07:02 - Installation terminée.

-----

16 décembre 2008 12:07:02

Program: Mises-à-jour Diverses

ID unique: MISESJOURDIVERSES

Ordre: 900024

Catégorie: System

16 décembre 2008 12:07:20 - cmd1 Succès (Code de retour 0): "D:\WPI\Système\Updates\Silverlight.2.0.exe" /q

16 décembre 2008 13:13:57 - cmd2 Success (returned code 0): "D:\WPI\Système\Updates\windows-kb890830-v2.4.exe" Q

16 décembre 2008 13:15:14 - cmd3 Success (returned code 0): "D:\WPI\Système\Updates\WindowsSearch-KB940157-XP-x86-fra.exe" /q

16 décembre 2008 13:15:14 -

*** Installation aborted by user ***

-----

Number of failed installations: 0

Install process finished at: 16 décembre 2008 13:15:15

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...