Jump to content

Thoughts on rb_config.js bug

Recommended Posts

Sorry if the current state of the rb_config.js discussion outdates this post. I haven't followed it closely since it first popped up but searched around last night and it seems like it still crops up sometimes, no one is really sure why, and it's assumed to have something to do with bad MSI construction. Again, if I'm missing anything please let me know.

I ran into this bug twice in my most recent unattended disc build. I'm installing from a more-or-less standard unattended Windows DVD with XP SP3, RyanVM's post SP3 update pack, BTS's latest official driver packs (as of a few days ago) and WPI 7.0 (including the Excludes patch) which is started via RunWPI.exe before the desktop loads for the first time. This is the first version of this unattended disk that I've built that incorporated WindowsXP SP3. Office 2007 wasn't anywhere in the mix; I'm still using 2003.

My first rb_config.js bug popped up during the installation of Adobe Acrobat 6.0 Standard. The cmd line was:

cmd1[pn]=['"%ROOT%\\Software\\Acrobat 6.0 Standard\\Adobe Acrobat 6.0 Standard\\setup.exe" /wait /v/qb /noreboot'];

so I removed the Acrobat 6 install files from my disc (after all, it's getting on in years).

I added a new WPI entry for PDFCreator 0.95 to replace it. The cmd line was:

cmd1[pn]=['"%ROOT%\\Software\\PDFCreator-0_9_5_setup.exe" /SILENT /SUPPRESSMSGBOXES /NORESTART /COMPONENTS=\"!toolbar\" /TASKS=\"!desktop_icon\" /SP-'];

This gave me a very similar rb_config.js bug.

In both cases, the install would stop in the middle, show a "Could not open reboot configuration file rb_config.js" message, then offer to debug. It'd inevitably drop me into line 577 of installer.js and line 135 of installer_reboot.js. Script wouldn't be able to continue, so I'd break, exit the debugger, kill mshta.exe with taskmanager and resume WPI after the desktop loaded without further problems.

When I was still toying around with the Acrobat version of the bug, I tried to trigger it by removing and installing acrobat again from a version of WPI and the install files from the hard drive. No dice.

Both programs were written by different groups and use different installers but still I was getting the same bug. This makes me wonder if it doesn't have something to do with a document writing library. After all, both of these programs are for writing PDFs and the other time people are reporting this is when installing Office 2007 which, I believe, comes with it's own PDF printer doesn't it?

The only other similarity I see between my two programs is that they're both unattended instead of silent (/QB for Acrobat and /SILENT for PDFCreator) and they both have some kind of /NOREBOOT switch. I'm rebuilding the disk and trying again with the /VERYSILENT switch instead of /SILENT for PDFCreator. I'll let you know how it goes.

In the mean time, I'd be interested to hear any other thoughts on the matter. I've attached my full config.js for reference and here's useroptions.js, installer.js and installer_reboot.js while I'm at it.

// Edit: Fixed type on description.





Edited by vampus8
Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Someone posted that they have this issue with a network share with write priveledge denied. Yours too? I would say no since your file did write. Did it write to the correct path? Put a JSCRIPT=alert("Pause") in an early command, then check where the file is. If wrong or correct place, let me know. Vague, but trying simple ideas first...............

Link to comment
Share on other sites

Guys! Seems I found the decision of this problem. Beside I personally appeared such error, when in list of the installed programs stood the Office. When I check out Office, error was not.

Here is my decision:

1. Make SFX-archive (only unpacking; for example in C:\OFFICE)

2. The first program must must be the batch-file with such text:

@echo off
start msoffice.exe

(This script starting unpackagin' archive (msoffice.exe) with Office installation files to C:\Office in silent mode. Use start only, not start /wait!)

3. The last program must must be the batch-file with such text:

@echo off
start C:\office\setup.exe /settings setup.ini

(This script starting Office installation. Use start only, not start /wait!)

If you will do this, error with rb_config.js will not appears. Why? I don't know. As for me, with my WPI (6) it works. Office 2003, full, Ru.

PS I have tested this method on different computers and everywhere I tested it works!

Link to comment
Share on other sites

If i can put my two cents in with the "big guys". I realized that if i ran my install without office 2003 then I would not get the rb_config error. also i would like to add that my office install was working fine. then i upgraded from 6.5 and started getting all these errors. anyway thought i would add that. if anything further is need from me(log files, rb_config files) let me know.THANKS

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...