Jump to content

1.6 - Unable to extract IS


Recommended Posts

I'm coming across more and more Inno setups that UE is unable to unpack, such as;


The error data from UE is;

Signature detected: Inno Setup Setup Data (5.2.1)
This is not directly supported, but i'll try to unpack it as version 5110
; Version detected: 5201
Critical error: The setup files are corrupted. Please obtain a new copy of the program.
Unpacking failed. This version is not supported.

Link to comment
Share on other sites

This is a common question, so I"m setting this as a sticky. If you are unable to extract current Inno Setup installers, this should be the first thing to try. However, check here first for an official update:


If there is no official update (0.19 is the current stable version at the time of this post), then go ahead and download the latest test version that mushu13 referenced.

Link to comment
Share on other sites

I just thought I might add, even with the latest innounp the current release of uni extract will fail on certain versions of Inno (ex. v5.1.5). This has nothing to do with innounp itself, which can upack the files fine, but with peid's definition files. I attempted to add custom OEP sigs for newer versions but for some reason peid won't pick them up while in use by peid.

I don't know what you've done in new unreleased version but if I remember correctly finding an alternative to using peid was on your todo list. If not, maybe a modded version of peid is in order that will pick up the custom def files (I could be doing something wrong as well) as well as not overwrite settings in registry. I have two copies of peid, one with a batch of plugins and such and then one being used by uni extract. I think I posted a modded version of peid to prevent it from writing to registry its own settings so as to not mess up my standalone version.


Thought I would add an example. Scanning this installer with peid stock def files you get "Borland Delphi 2.0 [Overlay]" but if I do an "External scan" it picks up the definitions I made and correctly identifies it as "Inno Setup Module v5 [Overlay] *". So when uni extract scans this file it sees it as a delphi file and rejects it.


Edited by KyotoMint
Link to comment
Share on other sites

  • 1 month later...

At the moment, there is not much we can do but hope for an updated innounp.

We will have to keep an eye on the innounp forum.

EDIT: The test version does work on IS 5.2.2 files, but not on IS 5.2.3 yet.

Edited by mushu13
Link to comment
Share on other sites

  • 2 weeks later...

I also have some problems with inno unpacking

Few times UE 1.6 recognized inno installer as "probably ZIP archive" and unpacking failed with UE 1.6. The same installer in UE 1.5 was recognized as inno and unpacked without problems.

Also I tried to unpack this....


Process started fine, but about the half of unpacking i heard my PC beep at each file that was extracted. The same is happening in UE 1.6 and 1.5. After unpacking some files have got terrible names (they look like strings of random characters) :blink:

Thank you in advance for checking this

I really appreciate using UE everyday. It saves my system from unwanted trash left here and there after every install :)

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...

worked on http://www.msfn.org/board/redirect.php?url...ecoverSetup.exe so i can confirm it works :)

what would be really sweet is if universal extractor could self update, as in being smart enough to know when there is a new version of an internal tool used and ask the user if they wish to update and download the new build and then extract automatically...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...