Jump to content

Silent Install of LogMein.msi


ceez
 Share

Recommended Posts

I tried to make the changes in the latest .msi file from Logmein, I can't find the "actions" mentioned above.

Sorry but I am a rookie as far as editing an msi file.

Thanks for any help,

Andreas

Link to comment
Share on other sites


Yeah they changed the titles. Everything is still there, just named slightly different. I'll take a look when I get home tonight.

Have found any solution to the the new version....?

Andreas

Link to comment
Share on other sites

Yeah they changed the titles. Everything is still there, just named slightly different. I'll take a look when I get home tonight.

Have found any solution to the the new version....?

Andreas

Same as before but the only change is LMIDeployCookieReg is now GetDeployInfo and there is only one LicenseType entry.

Link to comment
Share on other sites

I went through all the steps in the previous posts and at the end a yellow dialog box popped up saying it couldn't attach the computer to my account. What could be doing this?

Could it be because i'm behind a proxy server? If so how do I remedy this?

Link to comment
Share on other sites

Hello friends,

Since this post was a lot of help to me, and I understand there is a lot of people just lazy enough, or even in a big hurry to get this done, I am posting here my version of the passive logmein installer. It is an exe creator preconfigured, easy to make, piece of cake! Just unrar the folder, open up and read the instructions.

For the Brazilians like myself, the readme file has instructions in portuguese too.

This is my first post here, I'll be waiting for replies!

Cheers!

http://www.gigasize.com/get.php?d=wcvh9cm6pvf

Link to comment
Share on other sites

Hello friends,

Since this post was a lot of help to me, and I understand there is a lot of people just lazy enough, or even in a big hurry to get this done, I am posting here my version of the passive logmein installer. It is an exe creator preconfigured, easy to make, piece of cake! Just unrar the folder, open up and read the instructions.

For the Brazilians like myself, the readme file has instructions in portuguese too.

This is my first post here, I'll be waiting for replies!

Cheers!

http://www.gigasize.com/get.php?d=wcvh9cm6pvf

Thanks for that, it's still saying "Couldn't attach computer to your account" though. As mentioned before i'm behind a proxy server, could this be the problem?

Thanks,

Link to comment
Share on other sites

I went through all the steps in the previous posts and at the end a yellow dialog box popped up saying it couldn't attach the computer to my account. What could be doing this?

Could it be because i'm behind a proxy server? If so how do I remedy this?

Yes, you need to specify the proxy settings in the Property section of the MSI. Look for ProxyServer, ProxySettings, ProxyPort, ProxyPassword, ProxyUserName and ProxyVerifyPwd

Link to comment
Share on other sites

Hello. First off let me say that this thread has helped me tremendously. Thank you everyone.

I have a logmein.msi to include all the necessary switches. However, when I go to install it, I get that Yellow dialog box that Mickbrad was talking about. I am not behind a proxy of any kind and I'm stumped by this one.

Any care to venture a guess?

Thank you!!!

4creep

Link to comment
Share on other sites

Hello. First off let me say that this thread has helped me tremendously. Thank you everyone.

I have a logmein.msi to include all the necessary switches. However, when I go to install it, I get that Yellow dialog box that Mickbrad was talking about. I am not behind a proxy of any kind and I'm stumped by this one.

Any care to venture a guess?

Thank you!!!

4creep

Hmmm... I'll have play and see if I can replicate the error and try find a solution, Just a question is the account your using passworded? I know if you run the normal install if the account your using isn't passworded it will ask you to enter a Computer Access Code.

Link to comment
Share on other sites

I went through all the steps in the previous posts and at the end a yellow dialog box popped up saying it couldn't attach the computer to my account. What could be doing this?

Could it be because i'm behind a proxy server? If so how do I remedy this?

Yes, you need to specify the proxy settings in the Property section of the MSI. Look for ProxyServer, ProxySettings, ProxyPort, ProxyPassword, ProxyUserName and ProxyVerifyPwd

Could you please explain what values do we put for the properties mention above, ProxyServer and ProxyPort i have entered them but i have no idea about the ProxySettings and i found one more SETProxy.

Link to comment
Share on other sites

  • 2 weeks later...
Thanks so much for the changes to the .msi and for the .bat instructions for the silent install. What a time saver!

Regarding the pc password versus access code. A lot of the people that I install this on have no pc password, and usually in this case, LMI will ask them to create and verify an Access Code. Assuming that the person does NOT have a pc password set for their computer, what will the access code be if I use the batch script for the silent install? Is there a way to edit the .msi or the .bat to account for this circumstance, and if so, how?

Also, some of my customers are Mac users. Is there a similar method to edit the LMI installer on the Mac?

Thanks!

-NKA

Anyone have a solution to the pc password vs access code issue?

Update*: I just figured this out, so I will post the solution in case anyone else is interested. *Note you need to have already done the above steps to make your custom LogMeIn install prior to applying the settings below.

  1. Open up LogMeIn.msi in Orca, and navigate to "property"
  2. Scroll down and change the values of USERPASSWORD & USERVERIFYPWD to whatever you want the PC access code set to for the computers that will be installing LogMeIn on.
  3. If you have a batch file set up for the silent install, change the values of USERPASSWORD & USERVERIFYPWD to the same PC access code that you set for the LogMeIn.msi property settings in Orca.

My batch file looks like this:

logmein.msi /qb- USERPASSWORD=******* USERVERIFYPWD=******* USEREMAIL=email@gmail.com USERWEBPASSWORD=password LicenseType=free

For those that are new to batches:

  1. Open up a blank text document using notepad or similar
  2. Enter the info above (replacing the *'s with the PC access code password that you set, and replacing the value of the useremail and password with your own LogMeIn account info).
  3. Save as filename.BAT

*Once that is complete, any user that wants to install LogMeIn on their computer using your Custom install, just has to double click on your batch file, and presto, LogMeIn nearly silently installs with no errors, and most importantly, the PC access code is set automatically.

I hope that helps anyone else who was seeking to perform the Silent install, but was running into the issue of having to know the username and password for each computer that you wanted to remotely access through LogMeIn.

The only issue that I still have, is that anyone who you send the Custom LogMeIn install will have access to your LogMeIn account online, because they can just get your email and LogMeIn password from the batch file. Anyone know of a way to protect this information from clients?

-NKA

PS: Sorry for the Caps, but that is how they are displayed in Orca and the batch.

Edited by nabilalk
Link to comment
Share on other sites

I went through all the steps in the previous posts and at the end a yellow dialog box popped up saying it couldn't attach the computer to my account. What could be doing this?

Could it be because i'm behind a proxy server? If so how do I remedy this?

Yes, you need to specify the proxy settings in the Property section of the MSI. Look for ProxyServer, ProxySettings, ProxyPort, ProxyPassword, ProxyUserName and ProxyVerifyPwd

Could you please explain what values do we put for the properties mention above, ProxyServer and ProxyPort i have entered them but i have no idea about the ProxySettings and i found one more SETProxy.

Can some one help me with the proxies of logmein, it seems that icannot set them up correctly

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...