Jump to content

Silent Install of LogMein.msi


ceez
 Share

Recommended Posts

Hello,

Sorry for my English, I speak German.

So here's my solution with the latest LogMeIn:

1.)Steps from slimbyte, a bit changed:

1. on InstallExecuteSequence table, find GetDeployInfo action and change condition

from: UILevel=2 AND UPGRADEPRODUCT<>1 AND InstallMode<>"Remove"

into: UPGRADEPRODUCT<>1 AND InstallMode<>"Remove"

2. on InstallExecuteSequence table add following 3 actions:

action: GetLMIRegistrationCookie condition: NOT Installed sequence: 3710

action: LMIGetLicense condition: NOT Installed sequence: 3730

action: LMIGetLicenseForProfile condition: NOT Installed sequence: 3720

3. on Property table change following properties:

find LICENSETYPE property and change value from: IT into: free

3.i. on InstallExecuteSequence table, find CreateUserSetProperty action and change condition

from: CANCREATEUSER AND PASSWORDSOK="true" AND VersionNT AND REMOVE<>"ALL"

into: VersionNT AND REMOVE<>"ALL"

3.ii. on InstallExecuteSequence table, find CreateUser action and change condition

from: CANCREATEUSER AND PASSWORDSOK="true" AND VersionNT AND REMOVE<>"ALL"

into: VersionNT AND REMOVE<>"ALL"

2.)Creating a batch file with following source: (new empty text file-> open with editor->write in following text-> save as file.bat)

@echo off

logmein.msi /qr USERPASSWORD=pcpassword USERVERIFYPWD=pcpassword USEREMAIL=email@email.com USERWEBPASSWORD=password LicenseType=free

del logmein.msi

del setup.bat

Information:

@echo off: This hides the code during installation so that the installer can't see the passwords etc.

del logmein.msi/setup.bat: This deletes those two files so that the user can't find the inforations about the adresses etc.

3.)Puting all that into Inno Setup:

; Script generated by the Inno Setup Script Wizard.

; SEE THE DOCUMENTATION FOR DETAILS ON CREATING INNO SETUP SCRIPT FILES!

#define MyAppName "LogMeIn"

#define MyAppVerName "LogMeIn"

#define MyAppPublisher "LogMeIn"

#define MyAppURL "http://www.LogMeIn.com/"

#define MyAppExeName "LogMeIn.exe"

[setup]

; NOTE: The value of AppId uniquely identifies this application.

; Do not use the same AppId value in installers for other applications.

; (To generate a new GUID, click Tools | Generate GUID inside the IDE.)

AppId={{CDA00B15-ADF5-4240-A14B-D436CF489D61}

AppName={#MyAppName}

AppVerName={#MyAppVerName}

AppPublisher={#MyAppPublisher}

AppPublisherURL={#MyAppURL}

AppSupportURL={#MyAppURL}

AppUpdatesURL={#MyAppURL}

DefaultDirName={pf}\Z-Tuning

DefaultGroupName={#MyAppName}

DisableProgramGroupPage=yes

OutputDir=C:\output\

OutputBaseFilename=setup

Compression=lzma

SolidCompression=yes

[Languages]

Name: english; MessagesFile: compiler:Default.isl

Name: german; MessagesFile: compiler:Languages\German.isl

[Files]

Source: C:\Dokumente und Einstellungen\EBI\Desktop\versuche\file.bat; DestDir: {app}; Flags: ignoreversion

Source: C:\Dokumente und Einstellungen\EBI\Desktop\versuche\LogMeIn.msi; DestDir: {app}; Flags: ignoreversion

; NOTE: Don't use "Flags: ignoreversion" on any shared system files

[icons]

Name: {group}\{#MyAppName}; Filename: {app}\{#MyAppExeName}

[Run]

Filename: {app}\{#MyAppExeName}; Description: {cm:LaunchProgram,{#MyAppName}}

information:

innosetup copy's the files file.bat and LogMeIn.msi into a folder, and after installation, file.bat starts automaticly and installs the LogMeIn.msi

One little disadvantage is an error screen durning installation of LogMeIn.msi. But if you just klick on the ok button, Installation continues and it works perfect.

So Thank's to all,

Greetings from Switzerland:

Andreas

Edited by Hexenkönig_92
Link to comment
Share on other sites


Hello,

Sorry for my English, I speak German.

So here's my solution with the latest LogMeIn:

1.)Steps from slimbyte, a bit changed:

1. on InstallExecuteSequence table, find GetDeployInfo action and change condition

from: UILevel=2 AND UPGRADEPRODUCT<>1 AND InstallMode<>"Remove"

into: UPGRADEPRODUCT<>1 AND InstallMode<>"Remove"

2. on InstallExecuteSequence table add following 3 actions:

action: GetLMIRegistrationCookie condition: NOT Installed sequence: 3710

action: LMIGetLicense condition: NOT Installed sequence: 3730

action: LMIGetLicenseForProfile condition: NOT Installed sequence: 3720

3. on Property table change following properties:

find LICENSETYPE property and change value from: IT into: free

3.i. on InstallExecuteSequence table, find CreateUserSetProperty action and change condition

from: CANCREATEUSER AND PASSWORDSOK="true" AND VersionNT AND REMOVE<>"ALL"

into: VersionNT AND REMOVE<>"ALL"

3.ii. on InstallExecuteSequence table, find CreateUser action and change condition

from: CANCREATEUSER AND PASSWORDSOK="true" AND VersionNT AND REMOVE<>"ALL"

into: VersionNT AND REMOVE<>"ALL"

2.)Creating a batch file with following source: (new empty text file-> open with editor->write in following text-> save as file.bat)

@echo off

logmein.msi /qr USERPASSWORD=pcpassword USERVERIFYPWD=pcpassword USEREMAIL=email@email.com USERWEBPASSWORD=password LicenseType=free

del logmein.msi

del setup.bat

Information:

@echo off: This hides the code during installation so that the installer can't see the passwords etc.

del logmein.msi/setup.bat: This deletes those two files so that the user can't find the inforations about the adresses etc.

3.)Puting all that into Inno Setup:

; Script generated by the Inno Setup Script Wizard.

; SEE THE DOCUMENTATION FOR DETAILS ON CREATING INNO SETUP SCRIPT FILES!

#define MyAppName "LogMeIn"

#define MyAppVerName "LogMeIn"

#define MyAppPublisher "LogMeIn"

#define MyAppURL "http://www.LogMeIn.com/"

#define MyAppExeName "LogMeIn.exe"

[setup]

; NOTE: The value of AppId uniquely identifies this application.

; Do not use the same AppId value in installers for other applications.

; (To generate a new GUID, click Tools | Generate GUID inside the IDE.)

AppId={{CDA00B15-ADF5-4240-A14B-D436CF489D61}

AppName={#MyAppName}

AppVerName={#MyAppVerName}

AppPublisher={#MyAppPublisher}

AppPublisherURL={#MyAppURL}

AppSupportURL={#MyAppURL}

AppUpdatesURL={#MyAppURL}

DefaultDirName={pf}\Z-Tuning

DefaultGroupName={#MyAppName}

DisableProgramGroupPage=yes

OutputDir=C:\output\

OutputBaseFilename=setup

Compression=lzma

SolidCompression=yes

[Languages]

Name: english; MessagesFile: compiler:Default.isl

Name: german; MessagesFile: compiler:Languages\German.isl

[Files]

Source: C:\Dokumente und Einstellungen\EBI\Desktop\versuche\file.bat; DestDir: {app}; Flags: ignoreversion

Source: C:\Dokumente und Einstellungen\EBI\Desktop\versuche\LogMeIn.msi; DestDir: {app}; Flags: ignoreversion

; NOTE: Don't use "Flags: ignoreversion" on any shared system files

[icons]

Name: {group}\{#MyAppName}; Filename: {app}\{#MyAppExeName}

[Run]

Filename: {app}\{#MyAppExeName}; Description: {cm:LaunchProgram,{#MyAppName}}

information:

innosetup copy's the files file.bat and LogMeIn.msi into a folder, and after installation, file.bat starts automaticly and installs the LogMeIn.msi

One little disadvantage is an error screen durning installation of LogMeIn.msi. But if you just klick on the ok button, Installation continues and it works perfect.

So Thank's to all,

Greetings from Switzerland:

Andreas

Sorry for my English, I speak Thai.

Thank you for Hexenkönig_92. It work great!.

Link to comment
Share on other sites

Hello,

Sorry for my English, I speak German.

So here's my solution with the latest LogMeIn:

1.)Steps from slimbyte, a bit changed:

1. on InstallExecuteSequence table, find GetDeployInfo action and change condition

from: UILevel=2 AND UPGRADEPRODUCT<>1 AND InstallMode<>"Remove"

into: UPGRADEPRODUCT<>1 AND InstallMode<>"Remove"

2. on InstallExecuteSequence table add following 3 actions:

action: GetLMIRegistrationCookie condition: NOT Installed sequence: 3710

action: LMIGetLicense condition: NOT Installed sequence: 3730

action: LMIGetLicenseForProfile condition: NOT Installed sequence: 3720

3. on Property table change following properties:

find LICENSETYPE property and change value from: IT into: free

3.i. on InstallExecuteSequence table, find CreateUserSetProperty action and change condition

from: CANCREATEUSER AND PASSWORDSOK="true" AND VersionNT AND REMOVE<>"ALL"

into: VersionNT AND REMOVE<>"ALL"

3.ii. on InstallExecuteSequence table, find CreateUser action and change condition

from: CANCREATEUSER AND PASSWORDSOK="true" AND VersionNT AND REMOVE<>"ALL"

into: VersionNT AND REMOVE<>"ALL"

2.)Creating a batch file with following source: (new empty text file-> open with editor->write in following text-> save as file.bat)

@echo off

logmein.msi /qr USERPASSWORD=pcpassword USERVERIFYPWD=pcpassword USEREMAIL=email@email.com USERWEBPASSWORD=password LicenseType=free

del logmein.msi

del setup.bat

Information:

@echo off: This hides the code during installation so that the installer can't see the passwords etc.

del logmein.msi/setup.bat: This deletes those two files so that the user can't find the inforations about the adresses etc.

3.)Puting all that into Inno Setup:

; Script generated by the Inno Setup Script Wizard.

; SEE THE DOCUMENTATION FOR DETAILS ON CREATING INNO SETUP SCRIPT FILES!

#define MyAppName "LogMeIn"

#define MyAppVerName "LogMeIn"

#define MyAppPublisher "LogMeIn"

#define MyAppURL "http://www.LogMeIn.com/"

#define MyAppExeName "LogMeIn.exe"

[setup]

; NOTE: The value of AppId uniquely identifies this application.

; Do not use the same AppId value in installers for other applications.

; (To generate a new GUID, click Tools | Generate GUID inside the IDE.)

AppId={{CDA00B15-ADF5-4240-A14B-D436CF489D61}

AppName={#MyAppName}

AppVerName={#MyAppVerName}

AppPublisher={#MyAppPublisher}

AppPublisherURL={#MyAppURL}

AppSupportURL={#MyAppURL}

AppUpdatesURL={#MyAppURL}

DefaultDirName={pf}\Z-Tuning

DefaultGroupName={#MyAppName}

DisableProgramGroupPage=yes

OutputDir=C:\output\

OutputBaseFilename=setup

Compression=lzma

SolidCompression=yes

[Languages]

Name: english; MessagesFile: compiler:Default.isl

Name: german; MessagesFile: compiler:Languages\German.isl

[Files]

Source: C:\Dokumente und Einstellungen\EBI\Desktop\versuche\file.bat; DestDir: {app}; Flags: ignoreversion

Source: C:\Dokumente und Einstellungen\EBI\Desktop\versuche\LogMeIn.msi; DestDir: {app}; Flags: ignoreversion

; NOTE: Don't use "Flags: ignoreversion" on any shared system files

[icons]

Name: {group}\{#MyAppName}; Filename: {app}\{#MyAppExeName}

[Run]

Filename: {app}\{#MyAppExeName}; Description: {cm:LaunchProgram,{#MyAppName}}

information:

innosetup copy's the files file.bat and LogMeIn.msi into a folder, and after installation, file.bat starts automaticly and installs the LogMeIn.msi

One little disadvantage is an error screen durning installation of LogMeIn.msi. But if you just klick on the ok button, Installation continues and it works perfect.

So Thank's to all,

Greetings from Switzerland:

Andreas

Sorry for my English, I speak Thai.

Thank you for Hexenkönig_92. It work great!.

Thanks a lot for your explanantion.

Right now, i dont want silent installation. But i need to pre-poulate the values.

Right now, i did the following things

1. In Orca, highlight the Property table

2. Press CTRL-R on your keyboard (or Tables -> Add Row in the menu bar)

3. In the Property field put USEREMAIL and in the Value field put your account's email address

4. Repeat steps 2-3 for USERWEBPASSWORD, USERPASSWORD, and USERVERIFYPWD

Above are working perfectly

I need to still customize the installer by following actions :

1) "Software Options" screen - Just need to gray it out

2) "Description" - can i have a message saying, "Please enter your

subscription email address"

3) "Computer Access Code" - can i have it non-editable for

the user? ( pre-filled by using orca)

4) Can i eliminate the choice of LogMeIn products (Free should be default)

5) Can i eliminate the "Create New" account feature?

please answer for my above questions. i know it needs a small tweak in my msi.

thanks

kamaraj.s

Link to comment
Share on other sites

i followed the entire guid, but logmein doesnt get installed.

i tried to do the command LogMeIn.msi /quite from prompt after values change, but nothing happen..can't see anywhere LMI installed.

any clue?

Link to comment
Share on other sites

i followed the entire guid, but logmein doesnt get installed.

i tried to do the command LogMeIn.msi /quite from prompt after values change, but nothing happen..can't see anywhere LMI installed.

any clue?

I haven't taken the time to look at it lately, but I do know that they have made slight changes to the MSI since the original proceedure was posted. Some of the heading names have changed. There is also a unique appID now from what I remember (though that may not be the exact heading name). It is different between the different versions of the MSI. Thus, using the previously posted feature (with changes for the heading titles) on a downloaded IT copy of the MSI works, but not on the "Free" version download. I believe its just a matter of a key change within the MSI itself.

But like I said, I haven't taken the time to look into it lately. I will TRY to find time to do so over the weekend, but no promises.

Link to comment
Share on other sites

i followed the entire guid, but logmein doesnt get installed.

i tried to do the command LogMeIn.msi /quite from prompt after values change, but nothing happen..can't see anywhere LMI installed.

any clue?

I haven't taken the time to look at it lately, but I do know that they have made slight changes to the MSI since the original proceedure was posted. Some of the heading names have changed. There is also a unique appID now from what I remember (though that may not be the exact heading name). It is different between the different versions of the MSI. Thus, using the previously posted feature (with changes for the heading titles) on a downloaded IT copy of the MSI works, but not on the "Free" version download. I believe its just a matter of a key change within the MSI itself.

But like I said, I haven't taken the time to look into it lately. I will TRY to find time to do so over the weekend, but no promises.

thank you so much,

anyway so this wont work on free version actually?

thanks again for your answers =)

Link to comment
Share on other sites

Its not that it won't work on the free version, its just that there is an additional property value that has to be changed IN the free version to match the IT version. I'll see if I can find it.

Link to comment
Share on other sites

Its not that it won't work on the free version, its just that there is an additional property value that has to be changed IN the free version to match the IT version. I'll see if I can find it.

shouldnt be it changed from "IT" to "free"? I read something about it

Link to comment
Share on other sites

Its not that it won't work on the free version, its just that there is an additional property value that has to be changed IN the free version to match the IT version. I'll see if I can find it.

shouldnt be it changed from "IT" to "free"? I read something about it

There is a property that has to be changed to allow silent install of the Free, (default is IT and above only)

But the one I'm thinking of was a numeric code. It isn't present in the older version I still use for my installs, I ran into it when I was trying out the latest version.

Link to comment
Share on other sites

I've downloaded the latest version, made the necessary changes and have had no luck with a silent install. As an echo to others on this thread, would it be possible for someone to provide me with an updates MSI file that is known to work?

Link to comment
Share on other sites

I downloaded the latest version today, and found 2 lines in the msi that cause no problems for normal install, but break the silent. Below are the updated instructions, tested and confirmed working on the version available today:

--credit to slimbyte for finding a lot of this--

1. on InstallExecuteSequence table, find GetDeployInfo action and change condition

from: UILevel=2 AND UPGRADEPRODUCT<>1 AND InstallMode<>"Remove"

into: UPGRADEPRODUCT<>1 AND InstallMode<>"Remove"

2. on InstallExecuteSequence - right click on the right panel, select "Add Row" to add following 3 actions:

action: GetLMIRegistrationCookie condition: NOT Installed sequence: 3710

action: LMIGetLicense condition: NOT Installed sequence: 3730

action: LMIGetLicenseForProfile condition: NOT Installed sequence: 3720

3. on InstallExecuteSequence table, find CreateUser action and change condition

from: CANCREATEUSER AND PASSWORDSOK="true" AND VersionNT AND REMOVE<>"ALL"

into: VersionNT AND REMOVE<>"ALL"

4. on InstallExecuteSequence table, find CreateUserSetProperty action and change condition

from: CANCREATEUSER AND PASSWORDSOK="true" AND VersionNT AND REMOVE<>"ALL"

into: VersionNT AND REMOVE<>"ALL"

5. on InstallExecuteSequence table -

Right click "SetX64Path" and select "Drop Row". Repeat for "SetX86Path"

6. on Property table find LICENSETYPE and change condition

from: IT

into: free

7. on Property table -

Right click "DEPLOYID" and select "Drop Row"

8. Click "File - Save" (do not save as a new file) Execute using:

logmein.msi /quiet USERPASSWORD=pcpassword USERVERIFYPWD=pcpassword USEREMAIL=email@email.com USERWEBPASSWORD=password LicenseType=free

If this doesn't work, try running it from a batch file to catch the errorlevel

Save in the same directory as LogMeIn.msi , save as "whateveryouwant.cmd"

@Echo Off
Title LogMeIn Installer
Echo Running LogMeIn.msi & start /wait logmein.msi /quiet USERPASSWORD=pcpassword USERVERIFYPWD=pcpassword USEREMAIL=email@email.com USERWEBPASSWORD=password LicenseType=free
Echo. & Echo. & Echo. & Echo. & Echo.
If %errorlevel% == 0 (GOTO SUCCESS) Else Echo INSTALLATION FAILED! Errorlevel: %errorlevel% & Echo. & Echo. & Echo. & Echo. & Echo.
pause
:SUCCESS
exit

If the command window closes on its own, LMI should be installed correctly. If not, post your errorcode and I'll look into it.

Link to comment
Share on other sites

Hi.

First of all: Great work. :thumbup But:

I did it like Camelot_One but there will be an error:

logerrorcyc8.jpg

Any ideas?

Is it possible to check with a litte script before installing Logmein, wether the user has admin rights?

Thanks in advance.

Link to comment
Share on other sites

If you will translate that error message for me, I'll see if I can reproduce it.

Also, when you download the logmein.msi, is it the same (english) version I would? Or is there a separate file for the alternate language?

Edit - if you followed my proceedure correctly, you wouldn't see that screen at all. Or any logmein screens. Not that it would fix your problem, but it makes me wonder if you are running the command line wrong.

Edited by Camelot_One
Link to comment
Share on other sites

Seems to be the same Version - you can choose between german and english.

Translation:

Unable to execute file: ...

CreateProcess failed; code 193;

%1 is no allowance Win32-Application.

:blink:

Edit: My command line:

@echo off
logmein.msi /quiet USERPASSWORD=pcpassword USERVERIFYPWD=pcpassword USEREMAIL=*** USERWEBPASSWORD=*** LicenseType=free
del logmein.msi
del setup.bat

Edited by Frank1970
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...