Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

My experience installing Windows 98SE

Recommended Posts

Saturday, I finally received the PC I had asked a friend of mine to assemble. Yesterday I ran it for an hour with Puppy Linux. Today he brought me the drivers, so I could start installing Windows 98SE.

I started by partitioning my hard drive with GParted on Puppy Linux. I try to run Setup, but it always complains that it can't read the last cluster of C:. It insists on performing a surface scan. I quit Scandisk, and it informs me that Setup cannot continue. Great. Next time I let it, and after a half hour, it tells me that it has encountered a problem, and asks me if he should fix it. I tell it to not do this, and it aborts.

After searching on the Internet for a solution to my problem, it came to my mind that I should have partitioned with FDISK, as that's native. I did so, and then couldn't find the FORMAT utility. I boot Setup anyway, and it offers to format my partitions. Sure, go ahead! After that, Scandisk runs and doesn't perform a surface scan, and setup continues smoothly.

Next I installed the necessary drivers, and at the same time configure the system to my liking. While it automatically installs Client for Microsoft Networks when you install the network card, it doesn't automatically enable file and printer sharing, which is good. Then it was time to install my graphics card...

My graphics card is an Asus/ATI Radeon 9250. I had made sure that the graphics card would be one that would work with Windows 98SE, but yet the box says Windows 2000/XP. I try to install the drivers, but the wizard fails when trying to 'configure' (aka install) .NET Framework 1.1. So I read the readme, and looked around on the CD. The .inf file seems to state that this driver should even work with Windows 95... Anyway, starting the setup of .NET Framework directly, I get an error that states that I need at least IE 5.01. Terrific. I already didn't want the .NET Framework, and then it turns out it's tied to IE. **** you, Microsoft. That's where I stopped for the day.

Tomorrow I'll install the unofficial Service Pack before continuing.

Link to post
Share on other sites

Some graphic card drivers do not work without the Internet Explorer 5. I think both Nvidia and Ati drivers do have such a requirement. So, it is necesary to install IE before the graphics card drivers. The Nvidia drivers do not need a NET Framework, as far as I know.

Link to post
Share on other sites

I installed IE6 SP1, and then setup continued. However, it crashed at the installation of the Enhanced Asus driver. The rest seemed to continue anyway. After a reboot, though, I still couldn't select more than 16 colours. So I tried installing only the VGA driver. Still couldn't.

I searched the Internet for the drivers, and after some searching, I found and installed Catalyst 6.2. The driver works, but the configuration panel seems to have problems, as it always crashes.

Installed the unofficial service pack. Gape should replace the icon vulnerability patch by the unofficial fix hosted by MDGx. I uninstalled that fix. I also renamed wmiexe.exe to wmiexe.bak to keep it from running. There is still a hourglass 5 seconds after the desktop appears, but it's better.

when install 98se you can use the is swith on the setup (setup /is)

so that it skips running scan disk

I was booting the CD and running setup, so I couldn't do that. Though I guess I could just have booted DOS from the CD and run setup that way. But it still was better to fix the actual problem.

For anyone who is interested, these are the PC's specs:

  • Motherboard: ASRock K51GX
  • CPU: AMD Sempron 2800+ (really an Athlon XP in disguise)
  • RAM: 1 GB DDR1
  • Graphics card: ATI Radeon 9250

Sound card and network card are part of the motherboard.

Link to post
Share on other sites

The windows 98 does not work well with memory amount exceeding 512MB. The problem is caused by a conflict with the graphics card memory adressing, as far as I undertand the problem.

It is possible to get around the 512MB memory limit, but I never did it by myself. There are topics about this particular problem, on the forum.

Link to post
Share on other sites

well with usp 2.1a the amount of ram is limited to about 1gb, the problem isnt usually getting to 1gb its getting over that amount but it does depend on you mobo and configuration

Link to post
Share on other sites

For begining I have problem with your MBO ?

You have been saying that name is ASRock K51GX. On ASRock site there is no this MBO so ... Name of MBO for AMD are K7 (socket A), K8 (socket 754), 939 (socket 939).

It is not possible for your "configuration" to have problems with memory. Example for that are my windows 98 SE which are working without problems with Core 2 Duo, 1 GB RAM and GPU Radeon 9600 with 256 MB.

I have 1 little problem during instalation of Windows 98 and this has been ease to solve.

My first instalation has been failure because of wrong order of drivers which I have been giving to system. You are having chipset drivers, GPU driver, USB driver and now I do not know what else. Simple I have been giving things in wrong order. My problem has been with USB and even now I do not have USB 2.0 which is making me angry !!

Link to post
Share on other sites

Correct order of driver installation *IS* important.

BenoitRen, have you installed latest *chipset drivers* for your mobo?

You should have install it first right after OS installation.

If your mobo have VIA chipset, then it probably uses one of the VIA's "4in1 driver" or something like that (search for it).

For Intel chipsets Im sure you know where to go...

*After* chipset driver you can go with sound/lan drivers (if not autinstalled).

Then install WMI (not neccessary - but sometimes needed), IE6 SP1, .NET 1.1 SP1 + updates (I'd do full Windows Update run at this moment), and finally ATI drivers package.

USB2 and other devices drivers are always last for me.

BTW, what happened with your devotion to Win95? Something couldnt run on it? ;)

Link to post
Share on other sites
You have been saying that name is ASRock K51GX. On ASRock site there is no this MBO so

My friend said that was the model. Looking on the box, it's actually ASRock K7S41GX.

BenoitRen, have you installed latest *chipset drivers* for your mobo?

You should have install it first right after OS installation.

That's what I did.

If your mobo have VIA chipset, then it probably uses one of the VIA's "4in1 driver" or something like that (search for it).

For Intel chipsets Im sure you know where to go...

The chipset is SiS 741GX.

BTW, what happened with your devotion to Win95? Something couldnt run on it? ;)

Nothing happened to that devotion. ;) But I wanted a newer PC that could run Phantasy Star Universe (would have gotten it on console if it was also for the GameCube of Wii) and for Mozilla development. Unfortunately, Windows 95 can't run on such a setup, at least not until someone creates the necessary motherboard drivers and figures out a way to port the timing issue fix which exists for Windows 98 and up. Also, the number of bishoujo games (not available on consoles) that don't run on my Windows 95 PC because of not having the required DirectX version and/or not the necessary computing power is increasing. So I went with the second best option, Windows 98 SE.

I still mainly use my Windows 95 PC, though, with the other PC more like a secondary machine. :)

Link to post
Share on other sites

BenoitRen, if you want a stable machine, specially with more than 512MB, do away with ACPI *and* APM.

Else you'll be plagued by spontaneous crashes with "Windows Protection Error" after >7h uptime.

Here's how:

1) In the BIOS, fully disable ACPI and select PIC, not APIC, as the programmable interrupt controller


2) Open regedit. Go to HKLM\Software\Microsoft\Windows\CurrentVersion\Detect and add as a dword

value ACPIOption=2. Close regedit and redetect your hardware: windows will remove all ACPI related devices

from the system and add APM.

3) Right-click on the desktop, select Properties -> Screen Saver -> Energy Saving Features of Monitor ->

Settings -> Power Schemes and select "Always On", "Never" and "Never", the select Advanced and uncheck

the "Always show icon on the taskbar". Click Apply, then OK, and reboot if so requested.

4) Open MSConfig, select "Startup" and unchek both "LoadPowerProfile" boxes (there are two of them)

and click Apply , then OK, and reboot.

5) Right-click on "My Computer", select Properties -> Device Manager -> System Devices -> Plug and Play BIOS -> Properties -> Settings, check the "Disable NVRAM/ESCD updates and click OK. Now select PCI Bus -> Properties -> Settings, check the "use hardware" option for Device Enumeration click OK. Reboot if so requested. (note of Nov 20, 2008: this next step can be omitted, because some machines do not accept disabling IRQ steereing, although most do accept it) Go back to Device Manager -> System Devices -> PCI Bus -> Properties, select the IRQ Steering tab and uncheck "use IRQ Steering", click OK and reboot if so requested.

6) Right-click on "My Computer", select Properties -> Device Manager -> System Devices and if it shows

an "Advanced Programmable Interrupt Controller", right click on it, select Properties -> Driver -> Update

Driver -> Specify the location of the driver -> Next, check "Display a list of all drivers...", click Next. It will

show only the driver already installed. Then select "Show all hardware" : A listbox will appear. In the

(standard system devices), choose "Programmable Interrupt Controller". You'll receive a dire warning.

Ignore it and click "Yes". Reboot.

7) Return once more to Device Manager -> System Devices and select the "IO Read Data Port for ISA

PnP Management", go to Properties -> Resources. If it says "The resources this device is using do not

match any of its known configurations..." click on "Set Configuration Manually". There may be a conflict

on the addresses of the Input/Output Range 0374-0377. Click on Change Settings and select a new

range from the list that shows "No devices are conflicting" in the Conflict information box (usually

0384-0387), click OK, OK, and reboot.

8) Return once more to Device Manager -> System Devices and select the "Advanced Power Management support" and *remove* it. Don't redetect the hardware and reboot. It'll not reappear automagically, but you should check for it every time windows finds new hardware, to remove it yet again if it ever reappears.

9) And, particularly if using more than 512MB, do not use EMM386.EXE at all. (Maybe many will disagree

with me about it, but in my experience Win 98SE and EMM386.EXE, Netroom, QEMM or 386-to-the-Max

don't mix, with more than 512 MB of memory, and, in fact, they are unnecessary to run windows).

And enjoy a stable Windows 98SE! :thumbup HTH. Win 9x rocks!

Of course, the standard disclaimer applies: YMMV and I may also be just a raving madman, but, then

again, anything you do is of YOUR SOLE RESPONSIBILITY, anyway... You have been warned.

Edited by dencorso
Link to post
Share on other sites
Else you'll be plagued by spontaneous crashes with "Windows Protection Error" after >7h uptime

I wouldn't go as far as removing ACPI/APM to 'fix' such an issue as it's likely caused by a certain piece of software running rather than the OS. I've literally hit around 908 hours last I looked (37+ days) before it got restarted due to a power outage.

Link to post
Share on other sites

Well, BenoitRen, it is easier to do than to describe. I've just done it again today on another

machine and it took me no more than 15 min to do it all. After I'd done it I decided to edit my

previous post, because I'd forgotten to talk about the I/O port range conflict that uses to

appear, and how to solve it. So I think that now my previous post is a really precise guide on

how to remove ACPI and APM...

Chozo4, I'm glad your machine is so stable. I don't think the "Windows Protection Error"s I

mentioned are software related, as I've seen them happen on plain vanilla instalations having

just windows and nothing more. But I do believe they're BIOS or hardware related, as I've

seen them only on Asus (A7V600-X or A7V400-MX) or Soyo (SY-K7VTA PRO) boards, and

updating their BIOSes to the latest existing versions did not solve the problem. But removing

ACPI and APM did the trick. They may originate in bad code deep within the ACPI/APM part of

their BIOSes. Or they may be related to the VIA chipsets employed in all these boards. I really

don't know. But, as BenoitRen's board is an AsRock, and that is related to ASUS, I thought my

post might be of help. Of course, if the problem is related to the chipset, BenoitRen will never

experience it. But others may. And there may be others who want or need to remove ACPI and

APM completely for other reasons, whatever those reasons may be. But, up to now I'd never

found on the net a detailed recipe on how to do it, so I decided to provide one. Then again, let

me ask you: in a desktop, what's the use of ACPI or APM? There is no battery which charge

must be preserved at any cost to worry about...

Link to post
Share on other sites

Some of my computers run for months without any crashes whatsoever (I dont remember when was last time any of my PCs crashed lol); one's uptime is almost 2 years (it works as PVR/DVR/Media Center, stable W2K and no connection outside my home network except for weekly tv guide updates - hence no reboots because no updates or such is needed ;-) )

Im skeptic - I never "removed" (disabled) ACPI or APM from any machine, and I never had any problems with "spontaneous reboots" after >7hrs... but then I never run W98 or ME (just 95 on 1 old box for them DOS/9x games).

Why would your computer crash because of ACPI or APM? I really can't see how having ACPI/APM enabled may have bad influence on your machine (short of having f**d up BIOS).

Someone please explain?

Edited by 888
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...