Jump to content

hasi001

Member
  • Posts

    324
  • Joined

  • Last visited

  • Donations

    $0.00 
  • Country

    Austria

Everything posted by hasi001

  1. shouldn't uid[pn]=['O2K3WEP'] deps[pn]=['O2K3WEPO','O2K3WE','O2K3W']be uid[pn]=['O2K3WEP'] excl[pn]=['O2K3WEPO','O2K3WE','O2K3W'] for the wizard doing nonsense in the config, I'll need some more time ...
  2. You're right. Found the bug and solved it. Will be included in next release. For a manual fix edit check.js, search for a line if (dflt[i][0]=='yes') {setChecked(i); checkDeps(i); }and replace it with if (dflt[i] && dflt[i][0]=='yes') {setChecked(i); checkDeps(i); } it's all located in function check(se)
  3. Despite me saying that here won't be theme support for WPI, I'm just now working on it. Problem is, that I do not have a webspace to put the files on. Webspace for WPI homapge i just 1Meg - this is why you can't download older versions. I'll find a free webspace provider somewhere. Then - hopefully - I can upload the image sources. Hey - and what's so bad about the vaio. Don't like sonys ?
  4. No no. Everything fine. It wasn't you to get me angry - it was the fact, that I know how to fix the prob with javascript, but javascript won't let me. I was so glad when I gor rid of that **** .cmd file - and now there's a .cmd and a .reg file. In fact I'm glad you reported the bug. I wouldn't have found it myself, since I'm not installing so many huge applications. So it's me who depends on your tests - and you're doing very well. So - thank you (for i=1 to infinite) {print("very "} much.
  5. This theme will only work on 1280x1024 systems. It isn't fully finished yet. I'll use it for installs on my sonys. BTW: Editors: The Gimp and UltraEdit (since i experienced, that dreamweaver and especially frontpage spoil my html code)
  6. a06lp. You are right. But the request quoted seems to originate from a user who has customized 'his' wpi and now doesn't want to spend more time on customizing the new (more functionality) version again and so he's pleading me to spend more time on modifications for him to save time in customizing. As I begin to customize WPI for my own needs, there will be some modifications to ease customization. But I'm sure these mods won't ever be enough for some users. At least there WILL be some sort of 'skinnig' or 'themeing' ... in the near future..
  7. First I want to say the following: THERE'S NOTHING WRONG WITH MY SCRIPT !!! I've given an answer before. Don't think I write first then think - I triple checked it before. I thought a value of 7fffffff would be enough - note that's 2.147.483.647 decimal. Maximum integer value of javascript seems to be 7fffffff, therefore i cannot write ffffffff (4.294.967.295 decimal) to the registry. this error also happens in my freeware registry editor called 'RegCool'. I fixed the problem in another way: first - WPI is started from a command script, that imports a tweak to the registry and starts wpi.hta. the setscriptwaittimeout is still in there - for those who do not want to start via command script - but there's a difference to former versions. if setscriptwaittimeout finds a preset value in the registry, it won't overwrite it with 7fffffff - it just does nothing in this case. if no value is found it writes 7fffffff to the registry. Exiting wpi still removes the value from the registry - a manual deletion is not necessary. FYI: this error only happens because i coded WPI to wait for the end of all install processes. It would be easy not to wait, but in this case WPI would close as soon as the first setup began. running a cleanup script after wpi would lead to errors. Uploaded to the WPI homepage. Version is still 3.2.3
  8. Bug fixed. Download anew. Thanks for the report.
  9. Found a new way to speed up config wizard. Download Version 3.2.3 now.
  10. Ok - I understand. disableOnDepsNotMet ONLY affects something that has to do with the deps property. some checkboxes could still be disabled - if these programs were excluded by others, that were checked.
  11. Hi dennis. Of course you could put WPI on DVD only. The only prob is for the install.cmd to find the cdrom-drive letter you could use the following for %%i in (C D E F G H I J K L M N O P Q R S T U V W X Y Z) DO if exist %%i:\WIN51 SET cdrom=%%i: start /wait %cdrom%\pathToWpi\wpi.hta ... test it. could be, that you have to replace the double %% with a single %, since the syntaxk changes, when run throug cmd-file
  12. .. I know what you're speaking of. I'm suffering the same, when I look into the code of dependencies and exclusions. All of it sounds so easy, but it isn't.Let me tell you this first: The option to automatically select a programs parent (the way you like it to work) was just a side effect of what I was trying to accomplish. My primary goal was to make the dependent program unselectable if its' parent wasn't selected. I wrote the code and saw 'hey - it's now possible to autoselect parents if I only change that single line of code' .... and now - after finishing the works on exclusions - it isn't a single line anymore. It's recursive functions calling themselves, and hard to keep track of (turn on debug and set it to level 5 - you'll see what I speak of). What I do not understand in your posting is the following: You know that it would work, when you set disableOnDepsNotMet=false, and now you're trying to accomplish the same behaviour (autoselect), when setting the option to true, right ? Note that disableOnDepsNotMet means 'DISABLE a programs checkbox, if its' DEPENDENCIES ARE NOT MET' - that means, a checkbox is disabled, if one of its parents is disabled or not selected. Everything unclear ? Perhaps you found a bug I do not yet know of. Try to rethink, what you want to achieve. Recheck the config. Post if you found an error. That's why I'm pleading all users to test it. The primary goal of a software test is destruction. Only bugs that are found can be fixed.....and the only good bug is a dead bug.
  13. Would you please read the 4th post? Would help alot not to have to answer the same question a thousand times. Or just read through the descriptions in the options wizard page ? then change your windows theme. i've nothing to do with how your checkboxes look like. and if it was a cows head if it's deselected - it wouldn't be my fault. Good to hear that.
  14. Ok I just added in Korean and also the Language template has changed some. Please use this template from now on. WPI now supports 22 Languages!!! lang = ''; // <=== FILL IN LANGUAGE CODE HERE msgStartInstall[lang] = ['']; lblTimerTitle[lang] = ['']; lblTimerStop[lang] = ['']; lblInstall[lang] = ['']; lblExit[lang] = ['']; lblHelp[lang] = ['']; lblSelectAll[lang] = ['']; lblSelectNone[lang] = ['']; lblSelectDefaults[lang] = ['']; lblOptions[lang] = ['']; lblConfig[lang] = ['']; lblSource[lang] = ['']; lblmanual[lang] = ['']; ttInstall[lang] = ['','']; ttExit[lang] = ['','']; ttHelp[lang] = ['','']; ttSelectAll[lang] = ['','']; ttSelectNone[lang] = ['','']; ttSelectDefaults[lang] = ['','']; ttOptions[lang] = ['','']; ttConfig[lang] = ['','']; ttSource[lang] = ['','']; ttmanual[lang] = ['','']; txtRunOnceExTitle[lang] = ['']; txtUsage[lang] = ['']; Last Update 7-17-05
  15. BTW - no support for customized versions of WPI. If you like the button back download WPI anew.
  16. Checked it. Problem is, that WPI can't write the value because of an overflow. Maximum value it writes is 2147483647 which is 7fffffff hex. Must be some sort of javascript or wsh bug. (It works on my machine at home, it doesn't at work). I'll change the value to 7fffffff in WPI. Should be more than enough. This could be the reason, why it works, if you apply a registry tweak BEFORE you call WPI. Sorry - can't do more than that. If you need a higher value, then apply a regtweak before you start WPI Windows Registry Editor Version 5.00 [HKEY_CURRENT_USER\Software\Microsoft\InternetExplorer\Styles] "MaxScriptStatements"=dword:ffffffff [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Styles] "MaxScriptStatements"=dword:ffffffff- you don't have to delete the values - WPI does that for you, when it ends. Download it again. Value has been changed. Post your results.
  17. Astalavista Please do not post such a question in this thread. open another one. I'll read it - for sure. Answer to your question: the hexadecimal value of decimal 4294967295 is FFFFFFFF and vice versa. You don't need to change a thing.
  18. How do exclusions work: imagine 2 apps PA and PB with uid=PA and uid=PB if PA should exclude PB and PB should exclude PA then excl[PA]=PB and excl[PB]=PA if only PA should exclude PB then excl[PA]=PB if program PC should exclude PA and PB then excl[PC]=PA,PB it wouldn't make sende to create contraproductive dependencies: PA shouldn't exclude PB if it's dependent on it !! deps[PA]=PB and excl[PA]=PB or deps[PA]=PB and excl[PB]=PA the code used above is pseudo code - don't use it in your config. the right syntac would be: excl[pn]=['PA'], excl[pn]=['PA','PB'] in the config wizard you could just use PA,PB - the wizard makes the rest for you. DON'T FORGET TO GIVE EACH APPLICATION USED IN DEPS or EXCL A UNIQUE IDENTIFIER (uid).
  19. if you want to disable the wizards, just disable the option to show the buttons. set "Show additional buttons" to false. There you are.
  20. I know you hate that options wizard, but there's an option there saying 'Disable, when dependencies not met' - set this to false and voila - 'old' behaviour (except for exclusions)
  21. Version 3.2.2 is online. There's been done a lot of things. Most important: exclusions should work now. I need some testers here. Other changes/enhancements: see the WPI homepage.


×
×
  • Create New...