Jump to content

RunOnceEx not working!

Recommended Posts

Hi everybody!

I was trying to make an unattended CD of Windows XP with Alanoll's guide (http://unattended.msfn.org/unattended.xp/), but when I tried to run the system from a virtual machine, I found out that RunOnceEx did not execute, although the registry keys of RunOnceEx had successfully been copied to the registry. I'm sure the problem is not linked to cmdlines.txt, because every command executes regularly.

One thing I noticed is that the only registry key missing is the TITLE value for HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx... It seems it doesn't get copied into the registry...

Why does this happen to me?

Here's a copy of my RunOnceEx.cmd, in case you need... I've ran through it thousands of times! (Text inside the quotation marks is in Italian :D )


Thank you everybody, the site and the guides are fantastic!

Link to comment
Share on other sites

  • 4 weeks later...

I have the same problem. The title is missing and the reg entries just sit there and do nothing.

I have added start /wait and still nothing. I have even copied the reg entries over to the HKCU and still nothing! This was working for me at one point, then it stopped working. I have even created a new .SIF file and even checked the effective hive permissions.

Anyone got any ideas?

Link to comment
Share on other sites

This also happened to me recently. I hadn't done an install for a while, but it was time again.

This time I thought I would try RyanVM's update pack and nLite. So when I started troubleshooting, I started with the stock CD and added my OEM and unattended stuff and Runonceex worked. I used that as a base and created 2 new ISOs from it. One had only RyanVM's extra touch on it, the other had nLite's extra touch. The RyanVM version worked fine but the nLite version didn't. Not sure if it was something I did, but I didn't have any more time to troubleshoot it any further. So I only used the latest RyanVM's update pack and my unattended stuff as researched on this great site.

Not sure if this will help in your case, maybe do some troubleshooting like I did if you have the time. Good Luck.

XPSlacker :ph34r:

Link to comment
Share on other sites

Have you slipstreamed IE7 and maybe some IE7 Hotfixes directly into the source?

Since I did so, RunOnceEx did not work as it should any longer. I then wrote a small XML-driven installer that mimics the RunOnceEx-Style and use it without problems now. :)

Edited by eirogge
Link to comment
Share on other sites

  • 4 weeks later...
If you have added IE7 to your install then that breaks the runonce function with this file iernonce.dll

I just used the iernonce.dll that comes with IE6 to fix this problem.

Here is a link to another thread where I posted a fix for this problem.


Where can we add this? for it to fully work when you come into xp the first time.

Link to comment
Share on other sites

What I did was - don't slipstream IE7! - instead install it on the first login to the OS, but the hotfixes don't take until you restart the system after installing IE7, and RunOnceEx is broken at that point. RunOnce however seems to be fine, so at the end of the first set of RunOnceEx installs, I create an entry in the RunOnce processes to run a batch command file to install the IE7 hotfixes, and creates more RunOnceEx processes before it restarts the system.

Works fine for me. But if somehow your RunOnce is broken to - why not place the script to install the IE7 fixes in %AllUsersProfile%\Start Menu\Programs\Startup - Just make sure it deletes itself after it has run!

I Actually have two .cmd files involved, and use a tag file because otherwise the RunOnce starts before the system restarts, and they get compiled to .exe files for use on my install disk - but, my codes for both batch command files:



reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce /v IE7 /D "%SystemDrive%\OS_UPDATES\IE7\install2.exe" /f



@echo off

cmdow @ /hid

set tagfile=%SystemDrive%\IE7.P2

if exist %tagfile% goto RunInstall

REM tag file not found

REM Write the tag file

echo Go finsh Internet Explorer 7 install >> %tagfile%

REM And put file back in the RunOnce processes


REM Exit running this script.

goto Done


cmdow @ /ren "Finish Internet Explorer 7 install"

cmdow @ /vis

REM Make IE7 install folder the default


cd %SystemDrive%\OS_UPDATES\IE7

REM Install IE7 HotFixes

echo Installing HotFixes for Internet Explorer 7

start /wait %SystemDrive%\OS_UPDATES\IE7\HotFix\IE7-WindowsXP-KB933566-x86-ENU.exe /passive /norestart /nobackup

start /wait %SystemDrive%\OS_UPDATES\IE7\HotFix\IE7-KB929969-WindowsXP-x86-enu.exe /passive /norestart /nobackup

REM Move default out of the IE7 install folder.

echo Setup next group of OS updates and applications to install

start /wait %SystemDrive%\OS_UPDATES\RunNextInstallSet.exe 3

REM Restart the system

echo Restart system

start %SystemDrive%\OS_UPDATES\restart.cmd

REM Rmove IE7 files

echo Delete Internet Explorer 7 install files

cd %SystemDrive%\

RD /Q /S %SystemDrive%\OS_UPDATES\IE7

REM Delete tag file

erase %tagfile%



Hope that helps......

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...