Jump to content

Network Location not sticking with Reg Key hack in unattend.xml

Recommended Posts


I've read numerous threads about the network location bug and have added the following synchronous command to the specialize pass in my unattend.xml:

reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\FirstNetwork" /v Category /t REG_DWORD /d 00000000 /f

The problem isn't with the command itself. I know the command is working because when I halt the computer during the auditsystem pass I can browse to the registry and see the value set. However, once the oobesystem pass goes through the reg key is deleted and so I end up getting prompted again.

I've tried different entries into the Shell Setup > OOBE > Network Location field and also leaving it blank. None of these have worked and I always end up getting prompted. One way I can get around this is to add yet another synchronous command in the oobesystem section to add the registry key and then reboot, but I really don't want to add yet another reboot to fix this bug when others seem to have it working in the specialize pass.

Can anyone point out what I'm doing wrong?

Thanks in advance,


Link to comment
Share on other sites

ummm...u can try to use ur tweak on first logon command!

That's what I suggested as a potential workaround. Using it at first logon and as a synchronous command are synonomous in this case since either way I'm required to reboot an extra time. That's what I'm currently doing in an effort to just get the whole process unattended, but I'm really curious as to how others have gotten it working in their setups as part of the specialize pass and why mine doesn't work.


Link to comment
Share on other sites

Well the workaround described on TechNet is a bit contradictorily. On the one hand it says to execute the reg add command after sysprep, which does mean after audit mode, cause you have to use sysprep to leave audit mode. On the other hand it says you could run the command in audit pass, too.

I don't know how to leave audit mode, than.

I'm still havin probelms with network location setting, too.



Link to comment
Share on other sites

Same here :angry:


got it working , but only when i make an admin and a user account togheter.

Only 1 account...no go

EDIT 2 :

When set <CopyProfile>false</CopyProfile> it also works.

But then PDVD7 deletes all the shortcuts from start menu again during install.

When set to false , the startpaneloff function also doesnt work.

Edited by sp00f
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...