Jump to content

Installing Winxp via winnt32 under Winpe v2.0 (Vista PE)


Recommended Posts

Thanks for the Help; the Option with bootsect was very helpful.

But I have still one Problem.

I have to install some HP and Dell Workstations with Windows XP 64 Professional

When I start my Installation with

winnt32.exe /m:Y:\amd64 /unattend:c:\unattend.txt /Makelocalsource:all /copysource:lang /dudisable /syspart:c: /tempdrive:c: /noreboot

it takes about 50 Minutes to copy the installation source to the Disk.

When I do the same command on my old WinpeV1 it takes about 3 Minutes.

I have tried so many Things, that this is my last hope to get help.

I tried to copy a 700Mb File with the copy command it takes about 1 Minutes so I think the Network or the SAS Driver aren’t the Problem.

What I also see is when I connect to Network share and start some Patch Files they work slower than the local ones.


Link to comment
Share on other sites

Hi! I need some expert help in dealing with a problem regarding this method of installing Windows XP (winnt32.exe).

I have put the installation files on a PXE server (Win2008 Server + WDS) and I've been trying to install the OS using those remote files. Trouble is, I can't get the **** thing to install with my region (region 2) locale, no matter what I do. The instructions MS bundles with deploy.cab suggest I should use a /copysource:lang switch on winnt32.exe, which i did (the entire line goes like this: Y:\i386\winnt32.exe /syspart:c: /copysource:lang /tempdrive:c: /makelocalsource /unattend:WINNT.SIF), but that doesn't make a difference (and whether the install is unattended via WINNT.SIF or not, it still won't work, so the catch is not in WINNT.SIF). If I use those same files to make a bootable CD and install as usual, the locale selection works O.K., so the particular needed files are indeed present.

Any ideas as to why winnt32.exe in this case is malfunctioning?

edit: Update: Traced the source of the problem to nLite driver integration - it does something that messes with the setup files.

Edited by omgi
Link to comment
Share on other sites

  • 2 months later...

Hello, thanks for the interesting thread!

I have been trying to install XP on my notebook using this method:

I have been trying to install XP on my notebook (already running Vista on the first partition) via PE 2.0, using the same method mentioned here:

1 Boot WinPE with regfix applied

2 diskpart second partition for XP, making it active

3 bootsect /nt52

4 winnt32 /dudisable /syspart:D /tempdrive:D /makelocalsource

5 Reboot

Now I am able to boot the XP partition (text setup starts), but I'm getting an error: 'INF file txtsetup.sif is corrupt or missing'

This file is not missing as it is present on the root of the XP partition.

What could be the problem? I was thinking of two options:

A) I didn't run winnt32 with the /s: switch because I got an error (source invalid).

B) Missing SATA drivers? I have an ICH9M chipset and I integrated the TXT and PNP drivers in the XP install.

Edited by riksox
Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...