Jump to content

DirectX 9.0c


ihatecatsCHUNK
 Share

Recommended Posts

Dear fellow nLiters,

I have been spending several weeks attempting to install DirectX 9.0c on this computer, which is running a stripped-down version of WinXP Professional Build 0. The installer downloads the necessary data and then fails, yet when I try it off of the same disc on another partition with nothing removed, it is successful. What could I have removed that is critical to install DirectX? I have only removed things like the Luna theme and IE, nothing that one would think could potentially compromise a DirectX install.

I have also attempted to scour this parallel installation for data pertinent to DirectX and transfer it to the stripped-down version of WinXP, but I can't imagine it ever being fully transfered or configured to run from a different partition with its resources in different places.

Thank you.

Link to comment
Share on other sites


I tried the offline install, the networking drivers aren't to blame. I get this error:

An internal system error occurred.

Please refer to DXEerror.log and DirectX.log in your Windows folder to determine problem.

The DirectX log says:

09/26/06 12:51:18: dsetup32: === SetupForDirectX() start ===

09/26/06 12:51:18: dsetup32: Jul 28 2006 08:45:06

09/26/06 12:51:18: dsetup32: DXSetupCommand = 0.

09/26/06 12:51:18: DXSetup: DSetupCallback(): Phase = 0, Steps = 0

09/26/06 12:51:18: dsetup32: DirectXSetupIsJapanese == 0

09/26/06 12:51:18: dsetup32: DirectXSetupIsJapanNec == 0

09/26/06 12:51:18: dsetup32: Installing on WinXP

09/26/06 12:51:18: dsetup32: IsWow64(): not Wow64 process.

09/26/06 12:51:18: dsetup32: GetFileVersionInfoBlock(): Unable to get FileVersionInfoSize, file: C:\WINDOWS\System32\user.exe, reason: 1812.

09/26/06 12:51:20: DXSetup: DSetupCallback(): Phase = 0, Steps = 0

09/26/06 12:51:20: dsetup32: start finalizing: phase: 0 - 0, total: 0 - 0

09/26/06 12:51:20: DXSetup: DSetupCallback(): Phase = 3, Steps = 0

09/26/06 12:51:20: dsetup32: Installation ended with value -9 = Internal or unsupported error

09/26/06 12:54:52: DXSetup: WM_APP_ENDINSTALL

09/26/06 12:54:52: DXSetup: ~CDXWSetup()

Judging from the log, perhaps "C:\WINDOWS\System32\user.exe" was modified by nLite. I'll look into it, please post in the meantime.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...