Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Anderz

Add/slipstream SATA drivers - A fully working solution

Recommended Posts

I followed the directions and when I try to install windows, almost right away it says can't find viamraid.sys and I have no choice but to restart the computer.

I have copied all the files from my floppy disk (from other computer on the network) that I know work and will let me install xp on this current machine.

txtsetup.oem

viamraid .cat, .sys, no extension, .in_, .inf, .sy_, .ca_

I copied all these files to:

root dir

i386

i386\nldrv

i386\nldrv01

" 002

" 003

Where the hell is windows looking for this file? Or am I missing something completely stupid?

Tried nlite, then before it burnt swapped out the txtsetup.sif, but on boot didn't like that (since initially couldn't find my sata hd...)

[sourceDisksFiles]

viamraid.sys = 1,,,,,,,4,1

[HardwareIdsDatabase]

"PCI\VEN_1106&DEV_3349","viamraid"

"PCI\VEN_1106&DEV_0591","viamraid"

"PCI\VEN_1106&DEV_3249","viamraid"

"PCI\VEN_1106&DEV_3149","viamraid"

"PCI\VEN_1106&DEV_3164","viamraid"

[sCSI.Load]

viamraid = viamraid.sys,4

[sCSI]

viamraid = "VIA VT8251/8237/8237A/6421/6410 SATA RAID Controller(Windows 2K/XP/SRV2003)"

Edited by gazix

Share this post


Link to post
Share on other sites

Hey Everyone,

Here are the steps I took to get the MT6840 downgraded to XP from Vista. Please note, this presumes you're comfortable with the concepts of installing an operating system and its device drivers. If you aren't, print this and give it to someone who is :)

If you're computer blows up, catches fire, or otherwise does something you don't like because of these suggestions, take it back to the manufacturer but DON'T assume that I am responsible for anything. I've just spent 15 hours of a holiday weekend compiling this. It should take you a couple of hours to accomplish on your own following this information.

Enjoy!

-----------------------

1. Log into the Gateway Support Site and provide your serial # to get SOME (not all) XP drivers. Do NOT use Model Number as they won't provide the files you need.

2. Use NLite (http://www.nliteos.com/) to slipstream an XP installation with the Text Mode drivers for the SATA install onto a new CD. The textmode drivers are provided by Gateway in the "F6 Floppy X86" directory.

3. Install XP

4. Install XP SP2 (off of a CD, thumbdrive, etc...) - download it here - http://www.microsoft.com/downloads/details...;displaylang=en

---Begin Installing Devices - I don't remember the order but it shouldn't be TOO important---

5. WIFI Driver - From Previous Gateway Download site (using your serial number) - Yes, you need to have downloaded this first :)

File Description: Intel Wireless Driver

Version: 11.1.0.86

Run AUTORUN

6. AUDIO Driver - Downloaded from http://support.gateway.com/support/drivers...p;uid=167551212

File Description: Audio Driver

Version: SigmaTel 5.10.4946.0

Run SETUP

7. MEDIACARD READER Driver - From Previous Gateway Download site (using your serial number) - Yes, you need to have downloaded this first :)

File Description: Windows XP and Vista (32/64-bit) TI Media Card Reader Driver

Version: 2.0.0.6

Run SETUP

8. LAN Driver - NOT the one from the Gateway Download Site - Not even an INTEL LAN Device - go to MARVELL

Marvell Yukon 88E8038 PCI-E Fast Ethernet Controller Drivers

http://www.marvell.com/drivers/driverDispl...d=175&pId=6

Decompress and RUN Setup

9. Install BLUETOOTH if you want - It doesn't do anything right now

10. MODEM Driver - Motorola Driver - Get it from the Motorola Site (SoftModem 56 or SM56)

http://www.motorola.com/softmodem/public_d...6.12.07_DFV.zip

RUN SSetup

11. VIDEO Driver - Download from Intel (for the Intel 945GM Chipset)

http://downloadcenter.intel.com/detail_des...amp;prdmap=2529

http://downloadcenter.intel.com/T8Clearanc...e=〈=eng

You can search on Win2K_XP1431 (as of this writing) and find the download + readme

--LAST STEP--

Lastly...you will likely have an SM Bus Device Issue in Device Manager...to correct it you'll need the correct chipset drivers.

12. Go to the Intel Site and Search on

http://downloadcenter.intel.com/Product_Fi...x?ProductID=816 (Intel Chipset Software Installation Utility)

If you are running XP Pro (not HOME), just go to the below...

http://downloadcenter.intel.com/filter_res...mp;submit=Go%21

Run SETUP

-------------------------

At this point, you should have all of the drivers installed and NO unknown devices in Device Manager. If you still do have issues, get into an online chat session with Gateway. If you ask nicely and are persistent, they'll try to help you although they don't have an obligation from a Warranty perspective to do so.

Good Luck...my experience with XP has been BLAZING FAST on the Gateway MT6840 after installing everything. (Sorry Vista but you need to lose some weight and become more stable). I hope your experience is great, too!

Share this post


Link to post
Share on other sites

So, where the heck are the Gateway SATA drivers in the "F6 Floppy X86" directory? I've put in my serial number on Gateway's website and have been searching all over with no luck.

Thanks in advance for any clues :)

Share this post


Link to post
Share on other sites

I have just tried this procedure with XP Pro x64 (with SP2 which I manually integrated with the /integrate switch) and the ICH8R Intel RAID driver (7.6.0.1011) and it wasn't successful. My RAID partition was seen and the installation seemed to go OK (both the textmode part and the GUI part), but after the first reboot (ie. after installation had finished), it brought up the Windows XP x64 boot screen but immediately reboots again (ie. the progress bar bit does not even start moving), only now it brings up the "Windows was not shutdown properly" boot screen, "Do you want to (a) Start Windows Normally, (B) Start Windows in Safe Mode" etc. It will then keep going in this cycle.

Because it's x64, TXTSETUP.SIF is placed in the AMD64 folder. Here's exactly what I added:

[SourceDisksFiles.amd64]
iastor.sys = 1,,,,,,_x,4,1
hal.dll = 1,,,,,,3_,2,3,,,1,2

[HardwareIdsDatabase]
PCI\VEN_8086&DEV_2822&CC_0104 = "iaStor"
1394\609E&10483 = "sbp2port"

[SCSI.Load]
iastor = iastor.sys,4
atapi = atapi.sys,4

[SCSI]
iastor = "Intel(R) ICH8R/ICH9R SATA RAID Controller"
aic78xx = "Adaptec AHA-294X/AHA-394X/AIC-78XX SCSI Controller"

As you can see, I added the new lines immediately after the section header, and before anything else in that section. Is that OK ?

Where am I going wrong ?

BTW, I also tried adding the Intel ICH8R ACHI driver, which is actually the same as the RAID driver (ie. iastor.sys). To do this, I simply modified the relevant sections to:

[HardwareIdsDatabase]
PCI\VEN_8086&DEV_2822&CC_0104 = "iaStor"
PCI\VEN_8086&DEV_2821&CC_0106 = "iaStor"
1394\609E&10483 = "sbp2port"

[SCSI]
iastor = "Intel(R) ICH8R/ICH9R SATA RAID Controller"
iastor = "Intel(R) 82801HR/HH/HO SATA AHCI Controller (Desktop ICH8R)"
aic78xx = "Adaptec AHA-294X/AHA-394X/AIC-78XX SCSI Controller"

Is this correct for also adding the ACHI driver ?

Edited by deipotent

Share this post


Link to post
Share on other sites

I just did the nlite install above, you MUST use the F6 Diskette install drivers from Gateway (not the drivers from Intel). Within Nlite, choose add drivers by directory, you the control key and add ALL the drivers, then burn your ISO XP install CD. It works perfectly and is the method I would prefer. As well in Nlite you can embed your product Key code.

Les Elton,

Network Admin.

Share this post


Link to post
Share on other sites

Hi,

I'm currently trying to get this to work but am getting nowhere fast.

I've created a $OEM$\$1\Drivers\SATA folder on the root of the CD containing the SATA drivers (verified to work as I installed XP with them on a Floppy)

I've copied the iaStor.sys file to i386

I've modified TXTSetup.sif

I've created a Winnt.sif file with DriverSigningPolicy set to Ignore and OemPnPDriversPath="Drivers\SATA"

I can get past the textmode portion of Windows setup, into the Windows XP portion and got as far as final procedures before Windows rebooted and gave me a bluescreen.

So close yet so far! Thankfully I'm using a CD-RW otherwise I'd have about 20odd coasters right now :)

I'm also trying a network install of this via WinPE and are having even worse luck, the files copy but upon restart textmode setup sits and claims it can't find iaStore.sys? It's in the i386 folder and the $OEM$ etc folders... it is a .sys file though, not a packaged one.

Edit, and now textmode setup isn't working again. Fantastic, I should of made a backup.

Edited by Deman

Share this post


Link to post
Share on other sites

Hi again,

After some more searching I've managed to get it to work, in my case the steps here worked for me, (had to change the PCI\VEN to match the ones in my txtsetup.oem file of course). I think it was the added inf etc drivers in the i386 folder and txtsetup.sif file that helped. Either way it's going.

One thing I did note that I don't think is mentioned here is that Notepad++ shows the hidden end of file marker in txtsetup.sif. It's quite good seeing it there, rather than the having the install fail and you're not sure why :)

Still haven't got it to install via WinPE 2, this thread mentions you need to modify dosnet.inf and place d1,iaStor.sys in various places but it hasn't worked for me yet. Has anybody got this working via WinPE2?

Share this post


Link to post
Share on other sites

:wacko:

I followed these instructions, and then I followed other posts I found out there for creating a bootable iso. What I've found on the error I received is related to the bootable part of things (I think). This is what I'm getting:

CDBOOT: Couldn't find NTLDR

It never even loads the XP Installation; this error appears in VMWare Player immediately. I am using InfraRecorder to build my ISO, and I don't know if perhaps there's just a bug in that software. I have the Nero 8 suite on another PC, so I might try that. This post, however, doesn't mention anything about how to make the iso bootable (but I'm assuming that I need to do that). Any help is appreciated. Here are two posts I've followed to build the ISO. I've tried burning the ISO with the Bootable_NoEmulation.img file located in [bOOT], and I've also tried with some other files I found online, xpboot.bin and boot.ima. Any suggestions? Thanks.

http://www.tacktech.com/display.cfm?ttid=297

http://old.bink.nu/xpbootcd/

EDIT:

I found a tool called PE Builder (which only runs under XP), and everytime I try to build my iso image with all my modified files, it throws:

Warning: File "iaStor.sys" not found

I checked, and iaStor.sys exists in the directory. I even tried changing the name to "IASTOR.SY_" to be sure. I'm wondering if maybe iastor.sys is compressed, not uncompressed, as the tutorial says. I got the file after installing the drivers and copying it from the c:\windows\system32\drivers directory.

Any suggestions? There is no emoticon to describe how I'm feeling. Maybe that stick figure one where the guy bangs his head on his keyboard until it's bloody? Thanks for the help.

Edited by SideshowMel

Share this post


Link to post
Share on other sites

Hi!

I did the "recipe" but:

- install starts works OK

- first reboot, OK

- install finishes OK

- last reboot -> blue screen (it resets, so I can't read it, but I guess it is the BOOT DEVICE NO FOUND 00007B error)

Any clue ?

The only difference I did, that instead of 1 line under [HardwareIdsDatabase] I added all these, to cover all supported hardware:

PCI\VEN_8086&DEV_2922&CC_0106 = "iaStor"

PCI\VEN_8086&DEV_282A&CC_0104 = "iaStor"

PCI\VEN_8086&DEV_2829&CC_0106 = "iaStor"

PCI\VEN_8086&DEV_2822&CC_0104 = "iaStor"

PCI\VEN_8086&DEV_2821&CC_0106 = "iaStor"

PCI\VEN_8086&DEV_2682&CC_0104 = "iaStor"

PCI\VEN_8086&DEV_2681&CC_0106 = "iaStor"

PCI\VEN_8086&DEV_27C3&CC_0104 = "iaStor"

PCI\VEN_8086&DEV_27C6&CC_0104 = "iaStor"

PCI\VEN_8086&DEV_27C1&CC_0106 = "iaStor"

PCI\VEN_8086&DEV_27C5&CC_0106 = "iaStor"

PCI\VEN_8086&DEV_2653&CC_0106 = "iaStor"

Driver version is 7.8, Windows CD used was Windows 2003 Enterprise R2 SP2 trial.

Funny that it works all thru the install and only then fails.

Regards,

David

Share this post


Link to post
Share on other sites

same as deipotent

I have been trying to slipstream it to Windows XP Pro x64 amd it was unsuccessful.

This method was completely successfully in my x86 version of Windows and a complete failure in x64 where:

-Setup recognizes AHCI drivers for textmode

-Setup recognizes AHCI drivers for GUI mode

-Windows recognizes drivers as IDE since it was installed as IDE?

-Blue Screen and restart automatically

I know it was installed IDE because if i switch my harddrive to ide emulation, Windows work fine.

Here is my old topics in case anyone finds the solutions fro x64:

http://www.msfn.org/board/how-does-nlite-s...tml#entry764287

http://www.msfn.org/board/Unable-to-slipst...Wi-t117304.html

Edited by banzemanga

Share this post


Link to post
Share on other sites

Alright, followed the Original Posters instructions EXACTLY,

EXCEPT for the following:

Although I used "iastor.sys" (I have an intel controller too) it was a newer version (ICH8-E/M).

I have a Flash Drive that acts a Windows 98se Boot disk (there are other tutorials on this site that show how to do that). More on how this helped later.

Actually, more on how that helped now!

So, after following everything the OP said to do EXCEPT burning the cd. Instead of burning an ISO, I just copied my entire modified XP Setup files (the i386 folder, etc) to the root drive of my flash drive (the boot disk one). Then I restarted my pc, and got my pc to boot up the flash drive boot disk.

Next, (into the C:\> prompt) I typed "SMARTDRV.EXE" and pressed enter.

Then, (into the C:\> prompt) I typed "i386\winnt.exe" and pressed enter.

Windows began the winnt.exe stuff....

NOTE!!!! Some times when doing the various XP install exes, an error will pop up saying "could not find ioStor.sys" (iostor.sys will probably be something different for you. But it's the uncompressed driver file). When this happened, I went back into my working os (vista in this case) and copied ioStor.sys manually to practically any folder it seemed to make sense to copy it to. (i.e. wherever all the other drivers are)

after winnt.exe finished (i think i had to go back into vista during this, copy manually, then retry) it restarted, and the textmode install took over. During which I had to do another manual copy of ioStor.sys. I'm still running stuff off the flash drive at this point.

After text-mode install finished, I was able to run the setup programs that are now on my sata drive. HOWEVER!!!! I had to edit my boot.ini folder (the one on the sata drive). I changed whatever was there ("multi(0)disk(0)rdisk(1)partition(1)\windows" i think) to "multi(0)disk(0)rdisk(0)partition(1)\windows" the "part(1)" may have to change if you have it on partition 2, or partition 3, etc. but the other parts should work. You also have to change the "default=" to the same.

Rebooted, booted off the sata drive....got a missing .sys error, went back to vista, copied it into the root drive, "windows\" folder, "windows\system32\" folder, and the "windows\system32\drivers\" folder. I'm sure not all of those are necessary, but did it just to be safe.

and after that, it installed fine!

Sorry if this may be hard to follow, The whole process took me over 3 days of fiddling around (not these steps, but the numerous attempts I made before this). If anyone could take the time (who knows what they're doing) to tidy this up, and repost, I'm sure people will appreciate it.

Feel free to e-mail me, I'll try to help.

Edited by Fritzendugan

Share this post


Link to post
Share on other sites

EDIT:

I spoke too soon....

It installed fine, rebooted, try to boot xp, blue screen flashes during the xp logo scrolling loading bar screen....

Any suggestions?

When I run in safe mode, and it shows the debug output, I notice that it freezes after "mup.sys" (or dll? can't remember) loads....either mup screws it up, or it's the one after that....

Share this post


Link to post
Share on other sites

well, I eventually gave and borrowed a usb floppy drive (mitsumi). Put the drivers on the disk, then it worked like it's supposed to....

Honestly, my advice to all of you out there trying to do this, it really is worth buying/borrowin/getting(somehow) a usb floppy drive. Way easier, way more efficient (unless of course, you're in some kind of situation where that doesn't work for you either......good luck!).

Just make sure you get one that works with the xp install (like I said, mine was mitsumi. BIOS and Windows picked it up no problem. I was using a Toshiba Satellite x205-something....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...