Jump to content

Install Problem with Net Framework v2 and Language Pack


zartrix
 Share

Recommended Posts

I post every step that I try:

1) Windows XP Professional (in Spanish) + SP2 + Updates (Without .NET 2.0) = All works fine and i can Integrate all the hotfixes and updates (Including .NET 1.1 + SP1 + KB886903 + LangPack all with my silent installers created using iexpress). Only have one missing update = .NET 2.0 update. The CD Works FINE!!

2) Windows XP Professional (in Spanish) + SP2 + Updates (Including .NET 2.0) = All updates are integrated except .NET 2.0 (the silent installer that i create with Iexpress works fine if i test in a Fresh Install). SuperMagician says to me that i need some registry information for intall the .NET 2.0 and i do that in the next step.

3) Windows XP Professional (in Spanish) + SP2 + Updates (Including .NET 2.0) = All Works fine, but when i finished the installation and I browse windowsupdate.microsoft.com i have the .NET 1.1 Update for download. The .NET 2.0 silent installer that i create with Iexpress works fine if i Tested with a fresh install of Windows XP and i run manually. I put my silent installer of .NET 2.0 in the HF folder and renamed to dotnet2.exe like Super-Magician told me.

4) I try to integrate all the .NET 1.1 + SP1 + KB + LangPack in one installer like Tomcat76 told me but the multiscript failed to do that. But i think that is not a problem of my silent installers because they works fine in the step 1. The problem is when i install the .NET 2.0 that removes the .NET 1.1 if a try to integrate. If i run the silent installer manually when the installation of step 1 finish the silent installer works fine.

For all the test i use the HFSLIP_60614b.CMD version.

Maybe an error of integration with the .NET 2.0 in HFSLIP???

Any ideas???

Anyone can help??

Thanks in advance.

Link to comment
Share on other sites


Maybe an error of integration with the .NET 2.0 in HFSLIP???
This might be a possibility, but the INF file and commands in HFSLIP.CMD do not seem it could cause your problem.

Can you upload your .NET 2.0 installer somewhere and let me take a look at it?

Link to comment
Share on other sites

Can you upload your .NET 2.0 installer somewhere and let me take a look at it?

I make the silent installer with this file using Iexpress with some parameters that i can´t remember right now but not using the metod of the msi installer. Something like install.exe /q <--- This silent installer Works fine if i install .NET 2.0 manually in a PC with Windows XP Professional + SP2 + .NET 1.1 + All the updates.

I make the second silent installer using iexpress but changing the install metod. I use this command in the installer: dotnetfx.exe /q /c:"msiexec.exe /i netfx.msi ADDEPLOY=1 /qn" for test purposes...

I´am testing it right now... <--- Not Work at all. Don´t install at all. I must try it first... and not to do the hfslip cd without trying first the installers!! jaja

In a few minutes i tell you if it works or not... Doesn´t Work!

I upload my two silent installers for you to donwload:

5DotNet2.exe => The silent installer created using iexpress with the msiexec.exe command Not Download it! Doesn´t Work at all!

5Net20.exe ==> The silent installer creater using iexpress with the install.exe command.

Thanks for the help.. and i post when finish my new XP install (testing the silent installer of .NET 2.0 with the msiexec.exe command).

zartrix

Edited by zartrix
Link to comment
Share on other sites

In the previous reply i did some test but they didn´t work at all!

I upload my silent installer and the original dotnetfx.exe file downloaded from Microsoft (in my language - Spanish).

The .NET 2.0 Silent Installer Link

The Original .NET 2.0 File Link

Please try to look if there any problems with that files... but i think that it´s all ok.

I can´t understand why installing the .NET 2.0 eliminates the .NET 1.1 from my pc... and windowsupdate is telling me to download again. The problem are the same: When i integrate .NET 2.0 in HSFLIP, the .NET 1.1 doens´t work any more and is for download again in windows update!, like .NET 2.0 uninstall .NET 1.1.

Thanks in advance...

zartrix

Link to comment
Share on other sites

You never answered my question: when you are trying to get both .NET 1.1 and .NET 2.0 in, where exactly are you placing your .NET 1.1 files and where exactly are you placing your .NET 2.0 files?

Anyway... I'm making a newer version of the MultiCompiler script. It already supports .NET 1.1 and .NET 2.0 (including updates, language packs and reg hacks). I suggest you try it because the .NET 1.1 section has been thoroughly revised. You can rename the output files to whatever you want and place them in the HFSVCPACK folder (then run HFSLIP).

MC2

Edited by Tomcat76
Link to comment
Share on other sites

You never answered my question: when you are trying to get both .NET 1.1 and .NET 2.0 in, where exactly are you placing your .NET 1.1 files and where exactly are you placing your .NET 2.0 files?

CASE 1

My silent installers in HFSVCPACK folder:

1DotNet.EXE = Microsoft .NET Framework v1.1

2NDP1.EXE = NDP1.1sp1-KB867460-X86.exe

3NDP1-2.EXE = NDP1.1sp1-KB886903-X86.exe

4LanPack.exe = Language Pack for Microsoft .NET Framework v1.1

RESULT: XP CD Install without errors. All the updates are installed except .NET 2.0.

Windows Update only shows that .NET 2.0 are missing and ready to download and install.

CASE 2

My silent installers in HFSVCPACK folder:

1DotNet.EXE = Microsoft .NET Framework v1.1

2NDP1.EXE = NDP1.1sp1-KB867460-X86.exe

3NDP1-2.EXE = NDP1.1sp1-KB886903-X86.exe

4LanPack.exe = Language Pack for Microsoft .NET Framework v1.1

5Net20.EXE = Microsoft .NET Framework v2.0

6LanPack.exe = Language Pack for Microsoft .NET Framework v2.0

RESULT: XP CD Install without errors. All the updates and are installed except .NET 2.0.

Super-Magician tolds me that i need to rename the .NET 2.0 silent installer to dotnet2.exe and place it in the HF folder. I do this in the next case.

CASE 3

My silent installers in HFSVCPACK folder:

1DotNet.EXE = Microsoft .NET Framework v1.1

2NDP1.EXE = NDP1.1sp1-KB867460-X86.exe

3NDP1-2.EXE = NDP1.1sp1-KB886903-X86.exe

4LanPack.exe = Language Pack for Microsoft .NET Framework v1.1

My silent installers in HF folder:

dotnet2.exe = .Net 2.0 Silent installer renamed.

RESULT: XP CD Install without errors. The .NET 2.0 update are installed but now Windows Update only shows that .NET 1.1, KB867460, KB886903, and LangPack for .Net 1.1 are missing and ready to download and install. And of course the LangPack.exe for .Net 2.0 are also missing and ready to download from windowsupdate (because i don´t copy to anyware).

CASE 4:

The originals windowsupdate files in HF folder:

dotnetfx.exe

NDP1.1sp1-KB867460-X86.exe

NDP1.1sp1-KB886903-X86.exe

LangPack.exe

RESULT: XP CD Install without errors but not integrate any of the .NET 1.1 Updates.

I will try your new script... but i need to ask if the RVM silent .NET 1.1 and 2.0 are for Spanish Language too?

If the silent installers of RVM are not compatible with spanish i need to know how can i do new silent installers that works.

The problem when i try your previous script maybe was that i put the originals updates in the MC directory and not my silent installers??

Thanks in advance.

zartrix

Link to comment
Share on other sites

The only difference between the main installers (.NET 1.1, SP1 & KB886903) is that the localized versions have the installation wizard in your language. The actual program files of the localized versions are still in English (which is why you need a lang pack).

So whether you install this:

English .NET 1.1 + English SP1 + English KB886903 + langpack.exe

or this:

Spanish .NET 1.1 + Spanish SP1 + Spanish KB886903 + langpack.exe

...the end result is completely identical.

Link to comment
Share on other sites

Anyway... I'm making a newer version of the MultiCompiler script. It already supports .NET 1.1 and .NET 2.0 (including updates, language packs and reg hacks). I suggest you try it because the .NET 1.1 section has been thoroughly revised. You can rename the output files to whatever you want and place them in the HFSVCPACK folder (then run HFSLIP).

MC2

I copy your script to C:\MC and put this files inside the working folder:

dotnet11sp1.exe --> Ryanmv .NET 1.1 silent installer + sp1 + Kb

dotnet2.exe ---> Ryanmv .NET 2.0 silent installer

langpack.exe ---> Language pack for .NET 1.1

langpack2.exe ---> Language pack for .NET 2.0

Output files:

DNF11.EXE = 11,3 MB (11.934.361 bytes)

DNF20.EXE = 18,0 MB (18.913.897 bytes)

I make the .NET 1.1 and .NET 2.0 installers with the language packs included using your script and the silent installers of RYANMV... Then I copy the output files (DNF11.exe and DNF20.exe) to the HFSVCPACK folder like you told me to do.

RESULT: XP CD Install wihout errors but the .NET 2.0 is missing. Windowsupdate is telling me that i need to download and install .NET 2.0!! What I am doing wrong??? I can´t understand the problem at all!!

Are you sure that i must copy the DNF20.EXE file to the HFSVCPACK folder??? Or i need to rename to dotnet2.exe and copy to the HF folder like Super-Magician told me???

Thanks in advance.

Link to comment
Share on other sites

My last two test:

TEST1:

With Tomcat MultiScript and .NET 1.1 Ryanmv silent installer + .NET 2.0 Ryanmv silent installer i get two files:

DNF11.exe (I put in HFSVCPACK folder.)

DNF20.exe (I put in HF folder renamed to dotnet2.exe)

RESULT: Windows Xp CD install without errors. .NET 2.0 is missing.

TEST2:

With Tomcat MultiScript and .NET 1.1 Ryanmv silent installer + .NET 2.0 Ryanmv silent installer i get two files:

DNF11.exe (in HFSVCPACK folder.)

DNF20.exe (in HFSVCPACK folder.)

RESULT: Windows Xp CD install without errors. .NET 2.0 is missing.

Everything i try i get the same error... i can´t get .NET 2.0 installed in my machine if I put the .NET 1.1 installer. The two versions of .NET are 100% compatible??

Sugestions?

zartrix

Link to comment
Share on other sites

RESULT: XP CD Install wihout errors but the .NET 2.0 is missing. Windowsupdate is telling me that i need to download and install .NET 2.0!! What I am doing wrong??? I can´t understand the problem at all!!

Are you sure that i must copy the DNF20.EXE file to the HFSVCPACK folder??? Or i need to rename to dotnet2.exe and copy to the HF folder like Super-Magician told me???

Did you remember to use latest test release (060616a)? Works for me with both files in HFSVCPACK directory.
Link to comment
Share on other sites

The latest test releases no longer support dotnet2.exe in HF. That functionality was removed because of several reasons.

You should try to make it all work from HFSVCPACK.

We seem to be getting closer. It appears that you no longer get an error message when trying to install one of the output files. That's good. Now we need to figure out why .NET 2.0 doesn't install.

Please download the latest version of MC2 (060616b); it allows you to merge .NET 1.1 and .NET 2.0 into one installer (that's six files in one) and you save about 5.2MB.

Link to comment
Share on other sites

Did you remember to use latest test release (060616a)? Works for me with both files in HFSVCPACK directory.

I try the test release HFSLIP_60616a.CMD with DNF11.exe and DNF20.exe in the HFSVCPACK folder and it´s not working. The .NET 2.0 are not installed at all. It Seems that i have a problem applying the .NET 2.0 into my machine.... maybe a language problem (because i use XP in Spanish) with the registry patch???

I am trying the Tomcat´s MC2 script and making a "all in one" net 1.1 + net 2.0. I post the result in a few minutes...

Thanks.

zartrix

Link to comment
Share on other sites

The latest test releases no longer support dotnet2.exe in HF. That functionality was removed because of several reasons.

You should try to make it all work from HFSVCPACK.

We seem to be getting closer. It appears that you no longer get an error message when trying to install one of the output files. That's good. Now we need to figure out why .NET 2.0 doesn't install.

Please download the latest version of MC2 (060616b); it allows you to merge .NET 1.1 and .NET 2.0 into one installer (that's six files in one) and you save about 5.2MB.

I explain step by step the things that i did:

1) I downloaded and decompressed the MultiScript (MC2 version 060616b) and then copy the .NET updates to that folder:

 MC2.bat <--- File from MC2

7za.exe <--- File from MC2

7zS.sfx <--- File from MC2

cmdow.exe <--- File from MC2

dotnet11sp1.exe <--- .NET 1.1 + SP1 + KB downloaded from RyanMV website.

dotnet2.exe <--- .NET 2.0 Downloaded from RyanMV website.

langpack.exe <--- Language Pack for .NET 1.1 (Original file downloaded from microsoft)

langpack2.exe <--- Language Pack for .NET 2.0 (Original file downloaded from microsoft)

StartX.exe<--- File from MC2

2) I ran MC2.BAT and the output file was: DNF.EXE [24,2 MB (25.439.032 bytes)]. I merge the .NET 1.1 and .NET 2.0 installers. There was no errors with the execution of MC2.

3) I copy the DNF.EXE file to the HFSVCPACK folder in HFSLIP. I executed HSFLIP (Version 60616b) and then i installed the .iso file. RESULT: Windows XP CD works without any error but .NET 1.1 and .NET 2.0 are not installed at all. The updates are in WindowsUpdate ready to download and install...

4) I try to execute the DNF.EXE file in the Windows XP installation manually and decompress fine and begins to install .NET 1.1 and .NET 2.0. Then it seems thats is uninstalling and then the installer finish...

RESULT: NET 1.1 and .NET 2.0 are not installed at all. The DNF.EXE File IS NOT WORKING!!!! When i reset my XP (Virtual machine) the system show this error: The system is not totally installed or something like that.

If i look into DNF.EXE i have this files and folders (is not a problem of language??):

Win\

Windows\

Program Files\ <-- In my Language this folder is named "Archivos de Programa"

-------Common Files\ <--- In my Language this folder is named "Archivos Comunes"

cmdow.exe

DNF.CMD

DNF.INF

langpack.msi

lngpack2.msi

netfx.msi

netfx2.msi

StartX.exe

Maybe i am doing something wrong with the MC2 Script??? Or maybe isn´t working and fails to integrate the Spanish Language? Or the registry fix is not for spanish? Maybe is a problem with my XP working machine?

I upload to my FTP the files:

LangPack.exe (.NET 1.1 LangPack for Spanish Version).

LangPack2.exe (.NET 2.0 LangPack for Spanish Version).

DNF.EXE <-- The result of merge .NET 1.1 + LangPack.exe and .NET 2.0 + Langpack2.exe

Maybe if you ran the MC2 script in your machine with the silent installers of RyanMV (dotnet11sp1.exe and dotnet2.exe) and my LangPack´s you can check if your script is working fine with my language.

Or maybe i can use another silent installer pack (for other person?) and install the LangPack.exe and LangPack2.exe in HFSVCPACK folder???

I accept any sugestion Tomcat...

And Very Thanks for the help!

zartrix

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...