Jump to content

Norton Antivirus 2006


Yungsters
 Share

Recommended Posts


Maybe you can tell us first how you did it.

All steps.

Cause it works like a charm here , maybe somewhere something went wrong ?

Third times a charm!! :thumbup I checked this topic this morning in the 15 minutes before school started and decided to try it once more on my computer. I'll go over what I did differently and what I suspect may have been the problem.

1. I have the downloaded version, so the first thing I did was start up the installer, NAV061200_2YR.exe. I opened explorer to %temp% and copy/pasted the NAV folder to my desktop.

2. I followed through with the install file and since I already installed Norton Antivirus 2006, it only showed me the option to Completely Remove Norton Antivirus 2006. I used that to uninstall Norton Antivirus 2006. The computer restarted afterward.

3. When the computer started back up, I went to 'C:\Program Files\Common Files\Symantec Shared\CCPD-LC\' and copy/pasted symlcrst.dll into the NAV folder that I copy/pasted earlier.*

4. I made two files named NAVSetup.cmd and NAVSetup.reg with the following contents:

Contents of NAVSetup.cmd

cmdow @ /HID
@echo off

COPY "%userprofile%\Desktop\NAV\symlcrst.dll" "%programfiles%\Common Files\Symantec Shared\CCPD-LC\" /Y

EXIT

Contents of NAVSetup.reg

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\CCPD-LC\KStore\00000082\0000001e\00000054]
"Key"="_________________________"

You'll notice my NAVSetup.reg is different. I checked with the registry on the system I had just uninstalled Norton Antivirus 2006 from and found that to be the location of my key, so I wanted to keep it the same.

5. Since I was only trying to test the setup, I didn't use RunOnceEx. Instead, I double-clicked the NAVSetup.reg and NAVSetup.cmd. Then I opened a command prompt window at my NAV folder and typed in:

NAVSetup.exe /O REBOOT=ReallySuppress /QB

6. I left for school and came back just now and found that a Norton Antivirus shortcut on my desktop. Good news! :thumbup So I restarted the computer and I got the activation wizard, etc. It's now working. I'll try it again on my friend's computer and hopefully it will work out right.

Thanks muiz!

*Step 3 is what I did differently. In the past, instead of uninstalling Norton Antivirus 2006, I used Process Explorer to end the task of the process that was locking symlcrst.dll. This time, I uninstalled the program before copying the file. Maybe the program does something to symlcrst.dll when it uninstalls? :huh:

Good luck to everyone else trying to get this to work! ;)

Link to comment
Share on other sites

6. I left for school and came back just now and found that a Norton Antivirus shortcut on my desktop. Good news! So I restarted the computer and I got the activation wizard, etc. It's now working. I'll try it again on my friend's computer and hopefully it will work out right.

Thats not going to work on your friends computer.

This method works only on the computer you copied the symlcrst.dll from.

Link to comment
Share on other sites

6. I left for school and came back just now and found that a Norton Antivirus shortcut on my desktop. Good news! So I restarted the computer and I got the activation wizard, etc. It's now working. I'll try it again on my friend's computer and hopefully it will work out right.

Thats not going to work on your friends computer.

This method works only on the computer you copied the symlcrst.dll from.

Is there something that causes the file to be specific to the hardware on the computer? I'm planning to... well, actually, it's a bit funny. I just came back from the door and the UPS man handed me my shipment containing my new motherboard, processor, and power supply unit. So once I upgrade, the unattended Norton Antivirus 2006 won't install properly? Hm... then I guess I'll have to do it manually like before, still... :no:

Link to comment
Share on other sites

Still poping up the registration after I reboot the PC.

I did all the steps and seems to me that the symlcrst.dll is either not overrighting the one on the CCPD-LC folder or it is getting corrupted once you intall.

Does anyone know if Norton overwrites this file?

Link to comment
Share on other sites

Still poping up the registration after I reboot the PC.

I did all the steps and seems to me that the symlcrst.dll is either not overrighting the one on the CCPD-LC folder or it is getting corrupted once you intall.

Does anyone know if Norton overwrites this file?

Use winrar and make a SFX of it.

Path=C:\Program Files\Common Files\Symantec Shared\CCPD-LC
SavePath
Silent=1
Overwrite=1

Edited by muiz
Link to comment
Share on other sites

Still poping up the registration after I reboot the PC.

I did all the steps and seems to me that the symlcrst.dll is either not overrighting the one on the CCPD-LC folder or it is getting corrupted once you intall.

Does anyone know if Norton overwrites this file?

norton won't overwrite it if it is exist...

what u need is extract it 1st before installing it....

u can't copy it out while norton is protecting your system...

u need to uninstall norton , and copy it out and make sfx of it by using winrar

Link to comment
Share on other sites

  • 1 month later...

These are the 2 Autoit scripts that I've written to make Insallations and Activations of Norton AntiVirus 2006 completely automatic in any system without any need for internet connection ( or disconnection),

ofcourse I have removed the Serial number from the first one (Norton), you should use your own.

the 2nd script (NorAct)should be complied to .exe,

in NAV2005 activation was possible at the time of installation and so everything could be done in one script, but NAV2006 requires a restart before Activation Wizard could be executed,

If anyone could find a way to be able to tell the Norton that computer has restarted to let us run the activation, this could have been made easier to be done at the time of installation.

Norton.au3

noract.au3

Link to comment
Share on other sites

  • 4 weeks later...
These are the 2 Autoit scripts that I've written to make Insallations and Activations of Norton AntiVirus 2006 completely automatic in any system without any need for internet connection ( or disconnection),

ofcourse I have removed the Serial number from the first one (Norton), you should use your own.

the 2nd script (NorAct)should be complied to .exe,

in NAV2005 activation was possible at the time of installation and so everything could be done in one script, but NAV2006 requires a restart before Activation Wizard could be executed,

If anyone could find a way to be able to tell the Norton that computer has restarted to let us run the activation, this could have been made easier to be done at the time of installation.

any progression?

These are the 2 Autoit scripts that I've written to make Insallations and Activations of Norton AntiVirus 2006 completely automatic in any system without any need for internet connection ( or disconnection),

ofcourse I have removed the Serial number from the first one (Norton), you should use your own.

the 2nd script (NorAct)should be complied to .exe,

in NAV2005 activation was possible at the time of installation and so everything could be done in one script, but NAV2006 requires a restart before Activation Wizard could be executed,

If anyone could find a way to be able to tell the Norton that computer has restarted to let us run the activation, this could have been made easier to be done at the time of installation.

any progression?

Link to comment
Share on other sites

  • 4 weeks later...

Yet I have not been able to run the activation before a restart,

As it is in the first script

================

RegWrite("HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\CCPD-LC\KStore\00000082\0000001e\0000004a","Key","REG_SZ","XXXXXXXXXXXXXXXXXXXXXXXXX")

RunWait("NAVSETUP.EXE /qb /noreboot REBOOT=ReallySuppress",@ScriptDir)

FileCopy(@ScriptDir & "\noract.exe", @SystemDir & "\noract.exe")

RegWrite("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce","NortonActivator","REG_SZ","noract.exe")

================

Norton it is installed, noract.exe is copied to the computer and it will run in RunOnce.

(don't forget your serial)

2nd Script (In this one I replaced the pauses with a loop and fixed some stuff, it should work perfectly)

=======================

RegWrite("HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings","ProxyEnable","REG_DWORD","00000001")

RegWrite("HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings","ProxyServer","REG_SZ","0.0.0.0:0")

$Norton="Norton AntiVirus"

ProgressOn("Activating Norton AntiVirus 2006", "Please Wait ...", "0 percent", 50, 50)

$runvar= RegRead("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run","NAV CfgWiz")

Run ($runvar)

ProgressSet( 10, "10 percent")

AutoItSetOption("WinTitleMatchMode", 4)

While 1

If WinExists($Norton,"Activation requires communication") Then Exitloop

If WinWait("classname=Sym_ccWebWindow_Class") Then

WinSetState("classname=Sym_ccWebWindow_Class","",@SW_DISABLE)

ProgressSet( 20, "20 percent")

WinActivate("classname=Sym_ccWebWindow_Class")

WinSetState("classname=Sym_ccWebWindow_Class","",@SW_DISABLE)

Send("!n")

EndIf

WEnd

ProgressSet( 30, "30 percent")

While 1

If WinExists($Norton,"Connecting to the Symantec server") Then ExitLoop

If WinWait($Norton,"Activation requires communication") Then

WinActivate($Norton,"Activation requires communication")

WinSetState($Norton,"Activation requires communication",@SW_DISABLE)

ProgressSet( 40, "40 percent")

WinSetState($Norton,"Activation requires communication",@SW_ENABLE)

WinActivate($Norton,"Activation requires communication")

Send("!n")

WinSetState($Norton,"Activation requires communication",@SW_DISABLE)

If WinExists("Internet Connection Required","") Then

WinActivate("Internet Connection Required","")

Send("{ENTER}")

EndIf

EndIf

WEnd

ProgressSet( 50, "50 percent")

While 1

AutoItSetOption("WinTitleMatchMode", 1)

If WinExists($Norton,"Activate by phone") Then ExitLoop

If WinWait($Norton,"Connecting to the Symantec server") Then

WinActivate($Norton,"Connecting to the Symantec server")

WinSetState($Norton,"Connecting to the Symantec server",@SW_DISABLE)

EndIf

AutoItSetOption("WinTitleMatchMode", 2)

If WinExists("Internet Explorer") Then

WinClose("Internet Explorer")

EndIf

WEnd

While 1

AutoItSetOption("WinTitleMatchMode", 2)

If WinExists("Internet Explorer") Then

WinClose("Internet Explorer")

EndIf

AutoItSetOption("WinTitleMatchMode", 1)

If WinExists($Norton,"Phone Activation") Then ExitLoop

If WinWait($Norton,"Activate by phone") Then

WinSetState($Norton,"Activate by phone",@SW_DISABLE)

Sleep(2000)

ProgressSet( 60, "60 percent")

WinActivate($Norton,"Activate by phone")

Sleep(1000)

WinSetState($Norton,"Activate by phone",@SW_ENABLE)

ControlClick($Norton,"Activate by phone","Button4")

WinActivate($Norton,"Activate by phone")

Sleep(1000)

Send("!n")

EndIf

WEnd

If WinWait($Norton,"Phone Activation") Then

ProgressSet( 70, "70 percent")

WinSetState($Norton,"Phone Activation",@SW_DISABLE)

ControlSend($Norton,"Phone Activation" ,"Edit8","000000")

ControlSend($Norton,"Phone Activation" ,"Edit9","000000")

ControlSend($Norton,"Phone Activation" ,"Edit10","000000")

ControlSend($Norton,"Phone Activation" ,"Edit11","000000")

ControlSend($Norton,"Phone Activation" ,"Edit12","000000")

ControlSend($Norton,"Phone Activation" ,"Edit13","000000")

ControlSend($Norton,"Phone Activation" ,"Edit14","000000")

ControlSend($Norton,"Phone Activation" ,"Edit15","000000")

ControlSend($Norton,"Phone Activation" ,"Edit16","000555")

WinActivate($Norton,"Phone Activation")

Send("!n")

ProgressSet( 80, "80 percent")

EndIf

RegWrite("HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings","ProxyEnable","REG_DWORD","00000000")

RegDelete("HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings","ProxyServer")

If WinWait($Norton,"Your product key is") Then

ProgressSet( 90, "90 percent")

WinSetState($Norton,"",@SW_DISABLE)

WinKill($Norton,"Your product key is")

If WinWait($Norton,"Are you sure you want to exit") Then

WinSetState($Norton,"",@SW_DISABLE)

ControlClick($Norton,"Are you sure you want to exit","Button1")

ProgressSet(100 , "Done", "Complete")

EndIf

EndIf

ProgressOff()

Sleep(5000)

RegWrite("HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings","ProxyEnable","REG_DWORD","00000000")

RegDelete("HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings","ProxyServer")

FileDelete(@SystemDir & "\noract.exe")

==========================

Link to comment
Share on other sites

  • 2 weeks later...
  • 7 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...