Jump to content

Nero 7 Ultra only The Basic's.


keytotime
 Share

Recommended Posts


Hey guys, great guide keytotime, i have a contrabution to it (ok so i found a typo) then 2 questions.

there is a typo in post one below 2)In order to add the shortcut's add this your cleanup.cmd. This is for the tools and nero itself.

If Exist "%PROGRAMFILES%\Nero\Nero 7\Core\nero.exe" md "%ALLUSERSPROFILE%\Start Menu\Programs\Nero 7 Ultra"
If Exist "%PROGRAMFILES%\Nero\Nero 7\Core\nero.exe" md "%ALLUSERSPROFILE%\Start Menu\Programs\Nero 7 Ultra\Tools"
XMKLINK "%ALLUSERSPROFILE%\Start Menu\Programs\Nero 7 Ultra\Nero Burning Rom" "%PROGRAMFILES%\Nero\Nero 7\Core\nero.exe"
XXMKLINK "%ALLUSERSPROFILE%\Start Menu\Programs\Nero 7 Ultra\Tools\Nero CDSpeed" "%PROGRAMFILES%\Nero\Nero 7\Nero Toolkit\CDSpeed.exe"
XXMKLINK "%ALLUSERSPROFILE%\Start Menu\Programs\Nero 7 Ultra\Tools\Nero DriveSpeed" "%PROGRAMFILES%\Nero\Nero 7\Nero Toolkit\DriveSpeed.exe"
XXMKLINK "%ALLUSERSPROFILE%\Start Menu\Programs\Nero 7 Ultra\Tools\Nero InfoTool" "%PROGRAMFILES%\Nero\Nero 7\Nero Toolkit\InfoTool.exe"

there is an x missing in the first XXMKLINK line of the cleanup file which prevents loading the start menu shortcut to nero.exe

Question/Problem 1

I also get the uninstal error complain about NEResize.ax (I did check the location, and the file is actually there ??? any other ideas on how to fix this)

Question/Problem 2

Has anyone figured out how to run the msi file with anything besides the /qb switch, Basically what im doing is creating a cmd file to install nero, then packaging that along with all the install files in a sfx file and calling my install.cmd file after extracting to a temp dir, thus creating my own switchless installer, now i all ready have this 100% working, my only complaint is running it with quiet basic UI. Too many dialogue boxes, I tried all the other switches and they complain about setupx.exe. Has anyone figured out how to trick setup into using setupx.exe but with our own configuration so to speak?

Edited by twizt3d
Link to comment
Share on other sites

ya, supprising the thread got 10 pages long and no one else noted that, anyway, another 2 problems....

I added a shortcut to the start menu that points to %PROGRAMFILES%\Nero\Nero 7\Nero\Uninstall\UNNERO.exe but when you run that file, you get this error message.

There is already a newer Nero application on your system.
Please uninstall the newer applications and start the installation again.

Ok well control panel - Add/Remove Programs - Remove Nero Ultra Edition works, but still complains about that .ax file (you know, the one thats actually there, but setup cant see it.) ok well its still uninstalled. There are some files that are left over tho, mainly empty folders in %PROGRAMFILES%\Nero\. Any idea on how to delete that dir when uninstalling?

Second problem, /qn doesnt work. It still complains about setupx.exe missing, /qb seems to be the only switch that works. As soon as i figure all this out im gonna start a thread with a switchless installer file, i havnt seen any for Nero 7 yet and im pretty close (YAY! MY FIRST RELEASE) Uhh anyway, anyone have any ideas on how to fix any of this. Or does anyone know how to get rid of snake mites lol? (My pet pyton has little black things crawling on him and he doesnt seem happy)

Link to comment
Share on other sites

I have some problems with a silent custom install of Nero 7 Premium.

If I use the following, the whole pack is installed:

NeroSuite.msi ADDLOCAL=ALL /norestart /qb-!

I would like to only install the basic and Nero Cover Designer, however I can't seem to get it right. I tried to use the files that keytotime provided, however it gives me some problems.

NeroSuite.msi TRANSFORMS=Nerocover.mst /qn

Error: "Sorry, but the installer has to be started with SetupX.exe file."

NeroSuite.msi TRANSFORMS=Nerocover.mst /qb-!
msistub.exe NeroSuite.msi TRANSFORMS=nerocover.mst /qb-!

Both the above don't give any errors, however the program isn't installed. I briefly get a program "Nero 7 Premium Installer" but it dissapears very fast again.

I tried changing the Redist\Config\conf.txt file to only include the features that I whish, but it dosen't help.

What am I doing wrong? :o

Link to comment
Share on other sites

Guys

After much mucking around this appeared to work very well for me and I did not have to do any extractions or anything.

I downloaded the file from Nero (Nero-7.0.1.2_eng.exe)

I downlaoded the file from the 1st post (Nerocore.mst)

And ran this. Assuming you are running it from D:\Install

D:\Install\Nero-7.0.1.2_eng.exe TRANSFORMS=D:\Install\Nerocore.mst /qn /norestart

Note: You must specify the full path to the MST file.

Worked Perfectly for me hope it works fine for you guys.

P.S. It even created the icons only for the install components.

this is not a very reliable method. i tried it several times, and sometimes it worked, sometimes it didnt. sometimes icons were created, other times the application was installed properly but no icons were created.

i do however have problems when i do it exactly how keytotime recommends it. the installer never finishes the creation of the administrative installation point, it always asks for a cab file that isnt there.

my installer file is also called nero.msi instead of nerosuite.msi.

Edited by what3v3r
Link to comment
Share on other sites

That's is why you have the installer first, and when you see the actual nero install screen you have to go to your local Setting\temp and find where nero extracted the files. Use that to make you AIP. I recommend using Nero 6, it's so mcuh less buggy.

Link to comment
Share on other sites

Seeing that it's probably going to be quite some time before I get Blu Ray burner, I'll be sticking with V6 as well. Ahead even updated 6 after they released 7. Let's hope they keep that up. This whole situation is so ironic too. I've always preferred applications that use .msi files for doing repacks, but in this case :puke:

Link to comment
Share on other sites

hey guys im trying 2 get Nero Burning rom, recode & vision ONLY in an mst , they all install ok, but im missing something cuz in nero vision if u goto make a dvd out of files on harddrive it says it cant import them, but if i use originally installer, reinstall it it works ok :S

can some 1 try 2 make an mst with only those 3 programs in it & see if they can get it 2 work?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...