Jump to content

Unlimited number of drivers + keeping the drivers.


Recommended Posts

Hello Bashrat!

I tested M3 in combination with M2 and added this to my presetup.cmd:

START %DPDIR%\WatchDriverSigningPolicy.exe
TASKKILL /F /IM WatchDriverSigninPolicy.exe

But problem with failed integration of drivers persists :(

It doesn't work in DetachedProgram too.

Link to comment
Share on other sites

Hello everyone,

This method works  :thumbup

Here's the AutoIt script I use at detached programs stage:




$CD = DriveGetDrive("CDROM")
For $I=1 to Number($CD[0])
   $pa = $CD[$I] & "\win51ip.SP2"
     If FileExists($pa) Then
ProcessSetPriority ( "setup.exe", 0)
Run(@SystemDir & "\WatchDriverSigningPolicy.exe")
RunWait(@SystemDir & "\SetupCopyOEMInf.exe " & $instDrv & "\Drivers")
ProcessSetPriority ( "setup.exe", 2)
FileDelete(@SystemDir & "\presetup.au3")
FileDelete(@SystemDir & "\WatchDriverSigningPolicy.exe")
FileDelete(@SystemDir & "\SetupCopyOEMInf.exe")

It's also compatible with the Driver Compressor Tool.

I am searching for an alternative to the guide reference method (Pyron's first one) with SetDevicePath.exe lounched by presetup.cmd which is lounched by hacked setup.exe. For an unidentified reason, it has never worked in my different trials.

So I'd like to test yours, Hp38guser. Could you please tell me where can I get the

SetupCopyOEMInf.exe executable ?

Thanks in advance and see ya.

EDIT : I found it, sorry for not seeing it before (it is attached in the topic menu).

Great, I am now able to test it. I ll be back with the results of testing ;o))

thanks !!!

Link to comment
Share on other sites


Drivers for things like monitors and printers don't change very frequently, but these are exactly the kind of devices that I could see someone plugging in. Monitor drivers take up practically no space at all. Printer drivers, especially when poorly authored, can. So maybe printers could be a concern in terms of extreme bloat in a KtD scenario.

I'm currently writing a small batch to pre-install HP DeskJet 3740 or 3840 Series driver and help file (from a network share to local drive) without using bloated (>70Mb) CD install from HP. The CD install cannot be run unattended because you must first start the install, and then plug the USB cable during install...

:: Pre-install HP DeskJet %SERIES% Series Driver and help file
md "%ProgramFiles%\HP\hpz"
cabarc -r -p X %SERIES%hpz.cab *.* C:\Progra~1\HP\hpz\

copy "%ProgramFiles%\HP\hpz\glue\fra\drivers\com_lang\hpf2vw10.dat" "%SystemRoot%\system32\spool\drivers\w32x86\3" /Y
expand hpztsb10.ex_ %SystemRoot%\system32\spool\drivers\w32x86\3\hpztsb10.exe
::missing switch -r  to expand command added May 13, 2005
FOR /F "USEBACKQ DELIMS==" %%J IN (`DIR /A-D /OGN /B "%ProgramFiles%\HP\hpz\glue\fra\drivers\com_lang\*.??_" 2^>NUL`) DO expand -r "%ProgramFiles%\HP\hpz\glue\common\drivers\win2k_xp\%%J" "%SystemRoot%\system32\spool\drivers\w32x86\3" > NUL
FOR /F "USEBACKQ DELIMS==" %%J IN (`DIR /A-D /OGN /B "%ProgramFiles%\HP\hpz\glue\common\drivers\win2k_xp\*.??_" 2^>NUL`) DO expand -r "%ProgramFiles%\HP\hpz\glue\common\drivers\win2k_xp\%%J" "%SystemRoot%\system32\spool\drivers\w32x86\3" > NUL
FOR /F "USEBACKQ DELIMS==" %%J IN (`DIR /A-D /OGN /B "%ProgramFiles%\HP\hpz\glue\common\drivers\com_os\*.??_ 2^>NUL`) DO expand -r "%ProgramFiles%\HP\hpz\glue\common\drivers\win2k_xp\%%J" "%SystemRoot%\system32\spool\drivers\w32x86\3" > NUL

md "%ProgramFiles%\HP\Digital Imaging\help"
cabarc -r -p X %SERIES%hlp.cab  *.* C:\Progra~1\HP\Digita~1\help\

md "%ALLUSERSPROFILE%\Menu Démarrer\Programmes\HP\HP Deskjet %Series% Series"
shortcut /f:"%ALLUSERSPROFILE%\Menu Démarrer\Programmes\HP\HP Deskjet %Series% Series\Restaurer l'icône de la barre des tâches.lnk"  /a:c /t:"%SystemRoot%\system32\spool\drivers\w32x86\3\hpztbu10.exe -n """HP Deskjet %SERIES% Series""" -force" /d:"Restaure l'icône de la barre des tâches pour un accès aisé à la boîte à outils et aux propriétés de l'imprimante" /r:1
shortcut /f:"%ALLUSERSPROFILE%\Menu Démarrer\Programmes\HP\HP Deskjet %Series% Series\Guide de l'utilisateur.lnk" /a:c /t:"%ProgramFiles%\HP\Digital Imaging\help\dj%SERIES%.chm" /d:"Parcourez le Guide de l'utilisateur pour obtenir des informations et des conseils de dépannage" /r:1

setupcopyoeminf "%ProgramFiles%\HP\hpz\glue"

I just need to change the 3 lines starting with a FOR command to make it run fine and make some improvments. Can someone check the correct syntax of the FOR command to expand a series of compressed files (*.??_) from the source "%ProgramFiles%\HP\hpz\glue\<whatever_subdir>" to the destination "%SystemRoot%\system32\spool\drivers\w32x86\3"

EDIT: missing switch -r to expand command added May 13, 2005

Link to comment
Share on other sites

It seems several users of my DriverPacks have reported that, when SetupCopyOEMInf.exe is doing its job, alot of annoying 'not WHQL signed warnings' pop up. I found a way to easily circumvent this:

START %DPDIR%\WatchDriverSigningPolicy.exe
TASKKILL /F /IM WatchDriverSigninPolicy.exe

That is: using WatchDriverSigninPolicy.exe to get rid of them! (Thanks again, Pyron :) )

Hi Bashrat & hp38guser,

I have attached the image that I am experiencing applying this method.

XP Installation still keeps on prompting me with that message even when WatchDriverSigninPolicy.exe is running... I tried the following:

- launched another instance of WatchDriverSigninPolicy.exe

- terminate any instance of WatchDriverSigninPolicy.exe and relaunched a new instance of it.

However, both options neither worked. I am thinking on using the autoit script made by hp38guser... But still I will have to test it again...

I am running this via the 1st line of RunOnceEx.

Integration is working well though.

Thanks in advanced.

UPDATE: I have tried the autoit approach, but still no go. :blushing:

any ideas how can i prevent this popup from recurring when running SetupCopyOEMInf.exe?


Link to comment
Share on other sites

I don't have this problem. For me it works perfect. Then again, I only use Bashrat's packs, and other WHQL drivers.

edmoncu, do you get this pop-up when you install non-WHQL drivers, or do you get it all the time (even without non-WHQL drivers)?


I did some testing with non-WHQL drivers.

First I tried non-WHQL drivers for my wireless card. When I use WatchDriverSigningPolicy.exe, they install (slipstream) fine.

The next test was with the latest Nvidia (video) Beta driver. When I use WatchDriverSigningPolicy.exe this time, it didn't work.

Compare the above with this:

When I tell windows not to whine about the driver signing (turn it to ignore) my Wireless drivers install fine. My Nvidia drivers however, still give me the pop-up :blink:

It seems that for some drivers (or devices) the drivers signing can't be ignored


Edited by erik_demon
Link to comment
Share on other sites

hi guys,

from the screenshot attached at my previous post, i am installing BTS. this installation includes RVM's pack... this message keeps on popping up not totally for every driver that SetupCopyOEMInf.exe installs but for almost every driver that SetupCopyOEMInf.exe installs... in other words, it pop-ups almost all the time after i click on "continue anyway".

btw, this portion is running during runonceex. i wonder if it has anything to do with that one.

also, i would like to note that i am using both the latest BTS and RVM pack.

Link to comment
Share on other sites

but for almost every driver that SetupCopyOEMInf.exe installs... in other words, it pop-ups almost all the time after i click on "continue anyway".
****, that is nasty. In that case you have to click a zillion times :P
btw, this portion is running during runonceex. i wonder if it has anything to do with that one.

I don't think that this is the problem. My SetupCopyOEMInf.exe was once running next to WPI, which launched a RunOnceEx kind of screen. All went fine.

I don't use RVM's update pack myself, but a lot of people have/had problems with his pack combined with Bashrat's pack. I wonder if the problem is solved without RVM's pack?

Link to comment
Share on other sites

hmm... i believe it could be one of the registry settings that i have set that triggered those messages about driver signing to popup like hell. anyways. tried re-running my compilation w/o any registry mods and it seems the popups were removed.

Link to comment
Share on other sites

  • 2 weeks later...
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...