Jump to content

SI3112 SATA unattended help


Recommended Posts

I am trying to add the SI3112 SATA drivers to my UXPCD. I followed greenmachine's guide exactly as it was written.

Im getting this error when setup tries to copy all the files over for installation right after formating. Ive condensed the exact wording.

Setup cannot copy the file: si3112.inf

to retry press enter

to skip press esc

to quit press F3

anyone know what I am doing wrong?

Driver call from winnt.sif:

UnattendMode = FullUnattended
UnattendSwitch = Yes
OemPreinstall = Yes
OemSkipEula = Yes
FileSystem = *
WaitForReboot = No
TargetPath = "\Windows"
DriverSigningPolicy = Ignore
NonDriverSigningPolicy = Ignore
Hibernation = No

I am trying to verify the UXPCD using VMWARE could this be the problem? Ive read a few posts saying that you cant test SATA drivers under VMWARE which makes sense, but shouldnt I still be able to install windows?



Link to comment
Share on other sites

  • 2 weeks later...


Still no luck. Im about ready to smash this dang thing.

At this point Ive given up on the unattended for now. Ive been trying to use the F6 option to load the SATA drivers. I cant get that to work either. Im even using the floppy disk with the SATA drivers that was provided.

Here is what is happeneing. Any ideas on this? Ive tried several floppies and even XP CDs. Where is it looking for the si3112r.sys file? The floppy or XP CD?

Selected: "Press F6 to install RAID or 3rd party driver"

I selected to install mass storage drivers

When prompted for floppy I inserted the floppy containing the files mentioned above

I selected Silicon Image Sil 3x12 SATALink Controller for Windows XP

It loaded and then formatted my HDD

The formatting completed and I get the following error

Setup cannot copy the file: si3112.sys

To Retry press enter

If you are installing from a CD make sure that the Windows XP CD is in the CD-ROM drive

To skip file press ESC

Caution if you skip this file setup may not complete and XP may not work properly

To quit press F3

Link to comment
Share on other sites

update: I was able to use the 6 floppy disk method along with the F6 method and was able to install XP.

Any ideas as to why I get the above error when I do it with a bootable slipstreamed XP CD?


Link to comment
Share on other sites

@Sanjat - thanks for pointing that out. :blushing:

Im not having any luck trying to integrate my Si3112 Sata drivers into an unattended install disk.

Just to test the drivers to make sure I had the correct ones I did an attended install with the F6 option. I was able to successfully install XP with the driver disk I have.

Can anyone help me figure out how to debug or get the unattended version working?

Ive tried the following methods multiple times.

1. Ive tried Greenmachine’s method with no luck: http://greenmachine.msfnhosting.com/READING/addraid.htm

No idea why this didn’t work. I never saw the SI drivers flash by appear on the bottom of the setup screen. Received the hard drive not found screen.

2. Bâshrat the Sneaky/Pyron’s Method no luck: http://www.msfn.org/board/index.php?showto...161&hl=textmode

This one didn’t work either. Just received the hard drive not found screen.

3. And last Ive tried Trainee’s RASOR method: http://www.msfn.org/board/index.php?showtopic=30231

I received this error when trying to use this method:

FIle txtsetup.oem caused an unexpected error (18) at line 1747 in d:\xpsprtm\base\boot\setup\oemdisck.c.

Press any key to continue.

In all methods I never saw any new drivers flash by on the setup screen at the bottom.

So I don’t think they are being loaded properly.

Here is a list of files I have on the disk (the one I used for a manual install):


There was not a si3112.cat file so I added it from a download.

Here is the first section of the txtsetup.oem file. I can post the complete if needed.

; This file installs the SiI 3112 non-RAID seial ATA driver as part
; of text mode setup on Windows NT, Windows 2000, and Windows XP.
; Copyright (C) 2002-2003 by Silicon Image, Inc.
; All rights reserved

disk1 = "Silicon Image SiI 3x12 SATALink Driver Installation Disk",\si3112.sys,\

SCSI = Si3112

[SCSI]                 ; HwComponent section
Si3112_XP = "Silicon Image SiI 3x12 SATALink Controller for Windows XP"
Si3112_NT = "Silicon Image SiI 3x12 SATALink Controller for Windows NT 4.0 and 2000"

driver = disk1,si3112.sys, Si3112
driver = disk1,SiWinAcc.sys, SiFilter
inf = disk1,SI3112.inf
dll = disk1,SilSupp.cpl
;;catalog = disk1, Si3112.cat

id = "PCI\VEN_1095&DEV_3112&SUBSYS_31121095", "Si3112"
id = "PCI\VEN_1095&DEV_3112&SUBSYS_34238086", "Si3112"
id = "PCI\VEN_1095&DEV_3512&SUBSYS_35121095", "Si3112"
id = "PCI\VEN_1095&DEV_3512&SUBSYS_34238086", "Si3112"

I don’t know for sure, but I don’t think the drivers are being copied over. Could the sourcediskfiles be the problem?

Ive tried this:
si3112.sys = 1,,,,,,3_,4,1

si3112.sys = 1,,,,,,4_,4,1,,,1,4

Im really frustrated with this and don’t know what else to try from here. So any help or suggestions are greatly appreciated.

By the way the Mobo is a Gigabyte GA-7N400 Pro2


If you need any more info let me know. I wasn’t sure what all I needed to post.


Link to comment
Share on other sites

Its definitely there.

I put both the SI3112.sys and the SI3112.sy_ cab to make sure. still no go.

I should be able to see "Silicon Image SiI 3x12 SATALink Controller for Windows XP" go by on the bottm of the setup screen right? I never see it.

Even when using Bâshrat the Sneaky driver pack I should see a lot of new drivers go by the bottom of the setup screen but I dont.


Link to comment
Share on other sites

For me BTS driverpack does work for recoginsing te sata drive but it doesn't help installing windows.

I mean, no matter what I try the disk is being recognised but when all files have been copied and windows restarts for the first to go into GUI mode I get a BSOD just before the GUI mode.

Believe me, I tried every option and the only way to install windows wad to NOT use a unattended cd and go for the old fresh SP1 win xp cd with a floppy to integrate the SI3112 driver.

If I use method 1 WITH floppy than the windows hangs at the 12 minute stage. The same cd works perfectly fine with non sata drives.

Must have seen the windows screen 1000 times.

I checked on a Maxtor 40GB, 60 Gb and Samsung 80gb, all sata drives, BSOD with method 2 and hanging at 12 minute stage with method 1.

Using an IBM 60 gb ata drive (no sata) windows installs fine with method 1 but still hanging on the 12 minute stage with method 2.

Mobo = Epox 8rda3+.

Same problems with ALL tests on an asus mobo.

Link to comment
Share on other sites


maybe this had something to do with an older version of the si3112.sy_ file in the I386 folder?

I checked versions, the ones from Bashrat are the correct version from 2004, so that can't be it. Maybe in textmode setup it still goes for the older driver (2003).

Link to comment
Share on other sites

I actually have the same mobo that you do, and I have had success both using bashrat's and greenmachines methods for that si3112 chipset.

In your case, I would suggest starting from the beginning w/ a new txtsetup.sif, and winnt.sif, just to make 100% sure that it wasn't a misplaced file or anything of that nature.

A big thing w/ the txtsetup is that the end of the file marker may be invisible, so what may be happening is that the text you're adding is coming after the eof marker. Maybe find the last line of text, and just hit enter a couple times to space it out a little bit so that you know you're above the marker.

I did run into a problem w/ bashrat's driverpack that was telling me one of the .sys files was missing, even though when i searched for it in the dir, it was there... turned out that I had multiple entries of [scsi], [scsi.load], etc.. and that was messing up the windows text mode loading the files.

Good luck

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...