Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


jeffsu28

Any one get AutomaticUpdates to work?

Recommended Posts

[Data]
   AutomaticUpdates=1
   MsDosInitiated=0
   UnattendedInstall=Yes

Everything else in the Winnt.sif works great. AutomaticUpdates prompts on the Windows Welcome section. Anyone get this to work correctly?

Share this post


Link to post
Share on other sites

AutomaticUpdates=1

should be

AutomaticUpdates="Yes"

Good luck!

Share this post


Link to post
Share on other sites

It does the same thing.

Jeff, what else do you have in your winnt.sif file, there's possibly something else preventing Windows from skipping the Help Protect your PC Page.

Below is a winnt.sif file that works for skipping that and the Welcome to Windows XP pages:

[Data]
   AutoPartition=0
   MsDosInitiated="0"
   UnattendedInstall="Yes"
   AutomaticUpdates=yes

[Unattended]
   UnattendMode=FullUnattended
   OemSkipEula=Yes
   OemPreinstall=Yes
   TargetPath=\WINDOWS
   Filesystem=*
   UnattendSwitch=Yes
   WaitForReboot=No
   KeyboardLayout="United Kingdom"
   OemPnPDriversPath="drivers\001_INF"
   DriverSigningPolicy=Ignore

[GuiUnattended]
   AdminPassword=*
   EncryptedAdminPassword=NO
   OEMSkipRegional=1
   TimeZone=85
   OemSkipWelcome=1

[UserData]
   ProductKey=removed
   FullName="Aaron"
   OrgName="Home"
   ComputerName=TEST

[Display]
   BitsPerPel=32
   Xresolution=1280
   YResolution=1024
   Vrefresh=85

[RegionalSettings]
   LanguageGroup=1
   Language=00000809

[Identification]
   JoinWorkgroup=PHOENIX

[Networking]
   InstallDefaultComponents=Yes

[Branding]
   BrandIEUsingUnattended=Yes

[URL]
   Home_Page=http://www.google.co.uk
   Search_Page=http://www.google.co.uk

[Components]
   msmsgs=off
   freecell=off
   hearts=off
   minesweeper=off
   pinball=off
   solitaire=off
   spider=off
   zonegames=off
   msnexplr=off

[Shell]
   DefaultStartPanelOff=Yes
   DefaultThemesOff=Yes

[IEPopupBlocker]
   BlockPopups=No
   FilterLevel=Low
   ShowInformationBar=Yes

[WindowsFirewall]
   Profiles = WindowsFirewall.TurnOffFirewall

[WindowsFirewall.TurnOffFirewall]
   Mode = 0

Share this post


Link to post
Share on other sites

It doesn't work here either.

@ Aaron : the only difference i see with my winnt.sif seems to be UnattendSwitch=Yes. On 'Yes', it skips the oobe so the 'Help protect' page won't appear anyway.

Share this post


Link to post
Share on other sites

Here it is...

;SetupMgrTag
[Data]
   AutomaticUpdates=1
   MsDosInitiated=0
   UnattendedInstall=Yes

[Unattended]
   UnattendMode=DefaultHide
   OemSkipEula=Yes
   OemPreinstall=Yes
   TargetPath=\WINDOWS
   WaitForReboot=No
   UnattendSwitch=No

[GuiUnattended]
   EncryptedAdminPassword=NO
   OEMSkipRegional=1
   TimeZone=35
   OemSkipWelcome=1

[UserData]
   ProductKey=removed
   FullName=""
   OrgName=""

[Identification]
   JoinWorkgroup=WORKGROUP

[Networking]
   InstallDefaultComponents=No

[NetAdapters]
   Adapter1=params.Adapter1

[params.Adapter1]
   INFID=*

[NetClients]
   MS_MSClient=params.MS_MSClient

[NetServices]
   MS_SERVER=params.MS_SERVER

[NetProtocols]
   MS_TCPIP=params.MS_TCPIP

[params.MS_TCPIP]
   DNS=Yes
   UseDomainNameDevolution=No
   EnableLMHosts=Yes
   AdapterSections=params.MS_TCPIP.Adapter1

[params.MS_TCPIP.Adapter1]
   SpecificTo=Adapter1
   DHCP=Yes
   WINS=No
   NetBIOSOptions=0

[Branding]
   BrandIEUsingUnattended=Yes

[Proxy]
   Proxy_Enable=0
   Use_Same_Proxy=0

[PCHealth]
   RA_AllowToGetHelp=0

[GuiRunOnce]
%systemdrive%\install\installer.cmd

Share this post


Link to post
Share on other sites
AutomaticUpdates=1

should be

AutomaticUpdates="Yes"

Good luck!

I agree. Look under system32 directory. Inspect $oem$.inf file for what setup saw of your winnt.sif. See if AutomaticUpdates= ? in there.

Share this post


Link to post
Share on other sites

I want the Windows Welcome screens to show up but I want it to skip the "Help protect your PC" section and have automatic updates on. Is this possible?

Share this post


Link to post
Share on other sites

I just tried it again using AutomaticUpdates="Yes" instead of AutomaticUpdates=1 but it again asks to protect or not still at windows welcome.

Share this post


Link to post
Share on other sites

expand you oobeinfo.in_ in your i386 to oobeinfo.ini:

expand oobeinfo.in_ oobeinfo.ini

and add SkipAutoUpdate=1 under the [options] part.

[options]
SkipAutoUpdate=1

cab it back to oobeinfo.in_ using makecab:

MAKECAB.EXE /D COMPRESSIONTYPE=LZX  oobeinfo.ini.

and replace the one in your i386 folder.

That should do it, Windows Welcome Screen without automatic updates promt.

For more options about oobeinfo check ref.chm in deploy cab in your support\tools folder on the winxp cd, or get it here.

Share this post


Link to post
Share on other sites

I did that but it didn't work. Here is my oobeinfo.ini :

[Options]

NoIspPreconfig=1

SkipAutoUpdate=1

[startupOptions]

Offline=1

Registration=1

Share this post


Link to post
Share on other sites

er im lost in this ...

anyone post this ini completed please

cos that was just rocket science for me

Share this post


Link to post
Share on other sites

Do you still have AutomaticUpdates=1 in winnt.sif? You must have that as well...

That shoud be enough really, but the oobeinfo tweak is just to tell windows that you really don't want to see that page. :D

You don't have any regtweaks that disables Automatic Updates?

No autoupdate=off in the [Components] sections of winnt.sif?

Share this post


Link to post
Share on other sites
I just tried it again using AutomaticUpdates="Yes" instead of AutomaticUpdates=1 but it again asks to protect or not still at windows welcome.

I have the same problem doing a OPK install, neither automaticupdates= methods work.

Share this post


Link to post
Share on other sites

I have the same problem, as in although I have "AutomaticUpdates = 1" (I have also tried "AutomaticUpdates = Yes"), I still end up with Automatic Updates under Securtity Center not being set. I still have to manually turn on Automatic Updates after install is complete. But unlike some others here I don't get any screens while installing and the entire install process goes thru without any input needed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...