Jump to content

Kanopy videos and WinXP?


jbclem
 Share

Recommended Posts

Kanopy.com is a website that has many classic movies available to stream (ie: Seven Samurai, Rashamon, Citizen Kane, 8 1/2), for free is you have a public library card at qualifying libraries.  But it requires an OS newer than WinXP, and every time I try to play a video I get a DRM error, There's a help chart that shows it's only supported on WIndows 8 and above, using Firefox 47 and later.  I use Firefox 52.9 ESR.

Has anyone found a way to get Kanopy to work with WinXP?

Edited by jbclem
Link to comment
Share on other sites


You should be able to spoof the browser changing the useragent. You can search other user agent strings or modify your one's. It could be solved if you replace NT 5.1 with NT 6.3 or NT 10.0. So websites would believe that you use Win8.1/10

Link to comment
Share on other sites

  • 1 month later...

I've spoofed the useragent and it shows me as Firefox 77 and Windows 10.  That's apparently not enough to fool the Kanopy website.  Are there other ways to do this?

Sorry for the delay in answering your message, this website didn't notify me.

 

Link to comment
Share on other sites

1 hour ago, jbclem said:

Sorry for the delay in answering your message, this website didn't notify me.

I think you have to follow the thread, otherwise you only get a notification when someone quotes or mentions you.

On topic, modern DRM doesn't work on XP, in this case Widevine CDM specifically. The information on that site is outdated, it doesn't work on newer OS with older browsers such as Firefox 47 neither.

You need both the browser that supports current Widevine version and an OS that can support both the browser and the Widevine - that's an additional executable plugged into the browser.

Edited by UCyborg
Link to comment
Share on other sites

I've never heard of Kafan Minibrowser, I'll give it a try.  Ditto 360 Chrome Explorer.  Thanks for mentioning them.  I have Chrome 43 but can't get most websites to work, always getting error messages like :

This site can’t provide a secure connection

mybrowseraddon.com uses an unsupported protocol.

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...