Jump to content

AutoIt and other programming languages which still support XP!


Sergiaws
 Share

Recommended Posts

On 3/9/2021 at 12:28 AM, gerwin said:

I just tried their last version in Windows XP x86

Because they forgot to place these file in installer. While I can't write them about issue.

Link to comment
Share on other sites


7 hours ago, DrunkenTanker said:

Because they forgot to place these file in installer. While I can't write them about issue.

Even if they included those, one would still have missing calls in kernel32.dll and ntdll.dll.

On second look codeblocks-20.03 still shows promise for running under Windows XP.

The dependency trouble all branches from exchndl.dll, which branches to dbghelp.dll and mgwhelp.dll.

The issue is with this debugging library, v0.9.1.0  https://github.com/jrfonseca/drmingw

Download v0.8.2.0 from there and copy the dll and sym files to the codeblocks 20.03 folder to make it run in Windows XP.

(I did have some wxWidgets non-fatal error, which was caused by v20.03 portable referring to my v16 install location. When putting 20.03 portable in the path that I had previously installed v16 to, there is no error)

Edit: Deal breaker in attached image, back to v16 or v17. Or if someone manages to find a Win32 nightly build dated march 2021 or later, which is when the symbols browser was fixed.

codeblocks-20-03-Symbols.png

Edited by gerwin
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...