Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Is it possible to install latest Streamlink ?


kuja killer
 Share

Recommended Posts

Hello again, i was hoping to get a little bit of assistance with installing the latest streamlink 1.7.0, for watching Twitch streams in an exteneral player (in my case, Media Player Classic HC) - First of all, i have an older version one of the developers made for Windows XP back in 2017, which came with a pre-bundled python 3.4.4 found in this topic:

https://github.com/streamlink/streamlink/pull/680

It's worked just fine for me, no problems up until only a week ago when Twitch changed their API system, causing streamlink to always return a  "404 gone" or not found error from the twitch website itself. And from what I understand, that's not a problem in the current 1.7.0 - i think and they've addressed it for a new update later (using twitch's new setting)

I researched awhile and found some topics on the XP board here about python 3.5 and 3.7 by "dibya" First i tried the file by Dibya from this thread, but it didnt work as it would crash about "couldnt find encodings" or something.

https://msfn.org/board/topic/177972-python-371-for-windows-xp/

Then i tried the downloading the folder someone posted here, and this worked just fine, and i think it has the "pip" already included.

https://msfn.org/board/topic/176131-python-35-runtime-redistributable-backported-to-xp/page/9/?tab=comments#comment-1181554

I emailed the developer beardypig about it, he said it would require at least python 3.6, then install streamlink with "pip" which i havent exactly done yet cause i dont know the step-by-step procedure. I just only tried the regular Streamlink 1.7.0 installer but it did not ever create the "streamlink.exe" in the bin folder for some reason. is it because of it coming with a bundled python 3.6 of it's own apparently ?? it created it's own python folder with 3.6 files, which i assume were Windows 7+ related. :( At the end of the installer, the window mentions "byte compiling" files..which im guessing was supposed to be the streamlink.exe which did not get generated.

I used the installer exe from here:

https://github.com/streamlink/streamlink/releases/tag/1.7.0

How would i use this "pip" thing exactly with the XP python 3.7 ? does it compile it with that specifically ? And i dont understand the procedure about "sudo pip install --upgrade streamlink" -- do i need the installer exe in the same folder where the pip exe is at, in the python 3.7 folders or something ? i really dont understand how this works. :(

Edited by kuja killer
Link to comment
Share on other sites


This seems to be written for newer Windows versions, but should work as a guide - https://phoenixnap.com/kb/install-pip-windows

Regarding "sudo pip install --upgrade streamlink" - sudo is a Linux command to run the following as administrator (root). In Windows you instead just start the command prompt itself (cmd.exe) as administrator (only if needed), then use "pip install --upgrade streamlink".

Upgrade through pip may need a previous install through pip as well, not sure about this. If it doesn't work, try "pip install streamlink" instead.

Link to comment
Share on other sites

this is really fustrating. :( well that person's folder that i downloaded that i linked to specifically ..well it already has a get-pip.py file ...and the pip.exe is in the "scripts" folder. but i did the python get-pip.py - and it says it's version 19.1.1 - so that's good right ?

then i tried going to the scripts folder, and do the version test, like that site says in the tutorial ...but it gives this error about no encoding ? All of them say the same thing - pip3, pip3.7, and wheel...i dont know what to do next. :(

5IH3uVG.png

Edited by kuja killer
Link to comment
Share on other sites

I finally got it to work. I've been fighting with this for seriously hours on end for the past 3 days straight until i finally got through. I'd always get some type of error like that "non utf8 encoding" one above ... python line errors this and that ... when i finally tried just the "install streamlink" thing, i'd get some error about failed to install iso-639  "import version" and "no module named iso-639"  ...then i manually got the iso 639 from the py website, and put the directories in the python37\lib\site-packages\ folder ...try again, and it actually installed. :)

But with more errors though about "not on path" or something 

quote "WARNING: The script streamlink.exe is installed in 'C:\Python37\Scripts' which
 is not on PATH." (and a few other files)

It took forever, but it actually worked after that. :) Streamlink 1.7.0 + media player opens like normal the way it always did before, the whole twitch changing their API system.

RtpaP9X.png

Edited by kuja killer
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...