Jump to content

Windows 2000 SP4 on an i7-4790 possible?


Recommended Posts


It seems like only a little while ago I was asking for help to get audio drivers on an old AMD system. Well, that system is starting to show its age (especially the iGPU) and is having trouble with newer running software. So I moved the hardrive with the W2K to the new machine:

Dell Optiplex 7020

i7-4790 (Haswell)

Intel Q87 chipset ~Limited XP embedded support

GTX 750 ti ~XP driver available


500 GB HDD + 320 GB HDD (Windows 2K)


Now, this presents a problem as XP support is limited on systems newer than Ivy-bridge and 2000 is non-existent. I also had a partition of XP on the 2K drive and was able to install almost all drivers except USB 3.0 (XP has limited support anyway) and an SM Bus controller. So I started installing Windows 2000 Advanced Server SP4 over the old 2K SP4 Professional installation. I made sure to change the BIOS to ATA mode before the installation (That was the only other option). Windows 2000 SP4 installation went smoothly until it hanged on "Setup is starting Windows 2000". I searched this forum and saw that the communications port needed to be disabled because the W2K setup incorrectly identifies it as a floppy disk controller. After that was resolved, W2K installed with no issue except while it was detecting devices. Two error dialog came up with errors pertaining to "usbhub20.sys". After the system finished setup, it rebooted to a BSOD with this message: 


STOP: c000026c {Unable to Load Device Driver}

\SystemRoot\system32\DRIVERS\usbhub20.sys device driver could not be loaded.

Error Status was 0xc0000034

Safe Mode could not be used to overcome this, so I booted into the Windows 7 drive and deleted the usbhub20.sys and backed it up in another folder. This allowed W2K to boot, but with no USB 2.0 support. I heard that W2K has issues with USB 2.0 on newer hardware because it has old drivers.  The device manager shows many unknown devices. The most important of these are USB 2.0, Networking, and graphics drivers. The first thing I attempted to do was install the Windows XP embedded network drivers for this chipset (https://downloadcenter.intel.com/download/24555/Intel-Ethernet-Drivers-for-Microsoft-Embedded-Operating-Systems?v=t these worked fine on the XP partition). When I use the device manager to install the drivers, W2K states that it was unable to locate a driver for the device, even if I specify the directory. I do have a wireless USB networking adapter that supports XP, but without USB 2.0 there is no hope of getting that to work.

I decided to just try updating Windows 2000, starting with IE6 SP1 and the SP4 update rollup 1. The next thing I went to install was IE6SP1-KB2817183-x86 but upon trying to install this it states "Setup could not verify the integrity of  the file Update.inf. Make sure the Cryptographic service is running on on this computer". I tried using Start>Run and using regsvr32 to register dlls as suggested online, but sccbase.dll cannot be found and the problem is not resolved.


At this point I am wondering if I should abandon this altogether, and be happy with XP (after fixing Win2K's corruption of XP, that is). :wacko:

Help is greatly appreciated! :)

Link to comment
Share on other sites

Well, I will continue trying regardless. I was able to get networking working (no pun intended) by taking a Realtek PCI networking card out of Celeron Windows 98 system.

I ended up reinstalling to fix that integrity error. (This is NOT necessary, there is an update which fixes it available through Windows Update!)

[First reinstall] Installed again, began fully updating, installed BWC's Extended Kernel, but then realized that I left the Windows 7 drive in the machine during W2K installation which means that W2K is the 'D' Drive. This is a problem because the Windows 7 C:\ drive is inaccessible in W2K and GPU drivers require the C drive to install files.

[Second reinstall] Installed again, this time while removing the 7 drive during installation so that W2K sees itself as 'C:\'. Installed various updates, made sure the system was fully updated through WU (except SP4 rollup due to multicore issues). Installed Extended Kernel and rebooted. This caused the boot time to take about 10 minutes (after the splash screen) and I could no longer log into the system with an error similar to "The system could not log you on because the domain [DOMANNAMEHERE] is not available". (I selected Workgroup, not domain during the install). The only major difference between the last time was that I did not install the SP5.1; I've never had problem with the Kernel before. 

[Third reinstall] Installed again, got sound working, updated most updates from WU (except SP4 rollup due to multicore issues). Installed Kernel and get the same issue as last time.

The reason the boot time was so slow becomes apparent when I saw that the HDD access light would only periodically blink about every 4 seconds. The reason the login didn't work seems to be that it just timed out as it would try logging in for about 30 seconds before giving the error.

So close, yet so far. Not even sure at this point which order things should be applied. With so many updates, both official and unofficial, it is difficult to track down what causes this odd behavior.

Link to comment
Share on other sites

Well, I used HFSLIP to create an updated W2KAS CD. Was able to install Extended Core and KernelEX. I couldn't get the GTX 750 TI to work even with the BWC's unofficial drivers. The chipset drivers that I had used for XP (from Optiplex 7010 which supported XP) failed to install with an unknown error, even after installing nonofficial .net framework 3.x and using FCWIN2K. 

So, basically XP will work fine on this unsupported system. Make sure you use drivers from the optiplex 7010 (or 9010 if using 9020) as they are similar in design and it supports XP. Ethernet works with Intel's networking drivers from XP embedded and Server 2003. XP 64-bit should also work, but I haven't tried it. Anything older than XP is just too difficult.

Link to comment
Share on other sites

  • 1 year later...
On 1/7/2019 at 2:20 PM, broken120x120 said:

Dell Optiplex 7020

i7-4790 (Haswell)

Intel Q87 chipset ~Limited XP embedded support

. I heard that W2K has issues with USB 2.0 on newer hardware because it has old drivers.  The device manager shows many unknown devices. The most important of these are USB 2.0, Networking, and graphics drivers.

I am happy to report that on Dell Latitude e6540 the USB predicament has been overcome



  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...