Jump to content

Unable to add any Role/Feature


Recommended Posts

I had problem with DNS server settings, so i tried to remove and reinstall, but i faced:


DNS Server: Installation failed
Error: Attempt to install DNS Server failed with error code 0x80070643. Fatal error during installation

so did a search, many solutions, tried almost all,

- windows update issues

- iis shared configuration disable

- windows process activation service removal


successfully removed, still no change.

- sfc /scannow


Found no problem

- installing using powershell


Add-WindowsFeature : Installation of [DNS Server] DNS Server failed.

Attempt to install DNS Server failed with error de 0x80070643.

Fatal error during installation At line:1 char:19 + Add-WindowsFeature <<<< dns + CategoryInfo : OperationStopped: ( [Add-WindowsFeature], Exception +

FullyQualifiedErrorId : FeatureMessageDetail,Microsoft.Windows.ServerManag er.Commands.AddWindowsFeatureCommand

- running server manager as admin

but all have failed to help me install "DNS Server" Role.
So any help will be appreciated and I am open to all suggestion as I'm thinking to reinstall windows might be the last solution

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...