Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Dave-H

Offline Files Sync Error

Recommended Posts

Does anyone here have experience with the Windows 8.1 Offline Files facility?

I've been using it for quite a while to synchronise some folders on my main machine's archive drive with my netbook, and it's always worked very well until a few weeks ago.

 

Now, although it still syncs OK, it's always showing an error after syncing.

The error being thrown is that good old favourite "The parameter is Incorrect"!

This is one of the most common and most annoying error messages there is IMO, as of course it gives you absolutely no clue as to what the "parameter" is that's incorrect, and in my experience there's almost always absolutely no way to find out!

 

I have of course researched this, and the few bits of information I've found nearly all say to reset the store on the client side and basically start again.

Well I did that, even going as far as you completely delete the CSC folder on the client machine, and re-did the whole sync partnership from scratch, which needless to say took hours!

 

It worked fine for about a day and a half, and then the same error came back, with no apparent cause!

As I said, it is actually syncing the files fine, and I have been monitoring the sync event log, and files are being transferred OK when they have changed or been added or removed on the server side or the client side.

However, it still keeps throwing this wretched error so it always looks as if the sync has failed.

 

The details view in the Event Log shows -

- UserData   - SyncFailureInfo    Path \\ASHFIELDCOURT\Archive     Operation Sync client copy to server     ResultCode 0x80070057     Result The parameter is incorrect.

"ASHFIELDCOURT" is the name of my main computer, the server, and "Archive" is the name of the shared drive on that machine.

 

Anyone any ideas, this is driving me nuts?!

Cheers, Dave.

:)

  • Upvote 1

Share this post


Link to post
Share on other sites

So has no-one any experience of this at all?

I should now mention that both the client and server machines have Windows XP installed on them as well as Windows 8.1, and offline files works perfectly on Windows XP on the client, and it doesn't matter whether the server is on Windows XP or Windows 8.1, in both cases Windows XP on the client works fine and Windows 8.1 throws the error.

I am therefore assuming that the problem is on the client machine and not on the server.

I've now tried de-synchronising all the synchronised folders on the client in Windows 8.1, leaving just one file synchronised on the client, which is in the root of the shared drive on the server.

I'm still getting the "parameter is incorrect" message when I synchronise.

:(

Share this post


Link to post
Share on other sites

What you report seems like an issue in the "engine" than in the "database", however you can try (I am presuming that this would work on 8.1 as well) to format/re-initialize the database:

https://support.microsoft.com/en-us/kb/230738

 

jaclaz

Share this post


Link to post
Share on other sites

Hi again jaclaz!

:hello:

I had already followed the instructions on that link, in fact most of the references on the web to this sort of problem point to it!

It didn't do any good unfortunately.

 

The one puzzling thing was that adding the registry entry appeared to do absolutely nothing.

It's supposed to re-initialise the cache, and then be deleted.

 

In fact nothing happened at all when I re-booted after adding it, the cache remained exactly the same, and the registry entry was still there too!

The article is for Windows XP of course, not Windows 8.1, although my research seemed to indicate that it should still work.

 

I did find one suggestion to clear things by adding the FormatDatabase entry elsewhere, in HKLM\System\CurrentControlSet\Services\CSC\Parameters, instead of  HKLM\Software\Microsoft\Windows\CurentVersion\NetCache.

This just resulted in a rather frightening BSOD on startup saying KERNEL_SECURITY_CHECK_FAILURE, so I swiftly backed out of that!

 

Just to give the exact setup, the server has a drive on it called "Archive" which I have shared, under that name, on Windows 8.1 and Windows XP.

I used Offline Files on the client netbook to synchronise some folders on that drive, both on 8.1 and XP on the netbook.

This worked fine for many months, until this error message started happening on synchronisation on the client, but only on 8.1, not on XP.

 

Anyway, I've now tried some more tests.

I have now removed sync for all folders and files except one single file on the archive drive, which is in the root of the drive.

The error message is still appearing.

 

I have now tried sharing another drive on the server, and again synchronising just one file in the root again as on the first drive.

That drive syncs with no error message.

 

So I now have two entries in the sync partnership, both syncing just one file, one of which works and the other doesn't!

 

This indicates to me that the problem is actually on the server, with something about the Archive drive or its contents causing the problem, but I can't for the life of me see what it could be. The sharing of the two drives is set up identically. They are both FAT32 formatted drives.

 

Any suggestions gratefully received!

:)

Share this post


Link to post
Share on other sites

Well I finally came around to the conclusion that it was the name "Archive" for the shared folder on the server that it didn't like.

Not because there's anything wrong with it as a name of course, but possibly because I had been syncing using the same share name (of course) on all three of my server's operating systems.

I think what may have happened is that something got corrupted on the Windows 8.1 client, possibly character cases or something, which resulted in the client no longer being happy with the share root name on Windows 8.1.

I had noticed that depending on which machine I looked on, and on which OS, it was sometimes "Archive", sometimes "ARCHIVE" and sometimes "archive"!

I completely deleted the whole sync partnership again, including deleting the CSC folder, and then re-synchronised my folders using only Windows XP on the server (which is the OS I still most use there) and I removed the shares on Windows 8.1 and Windows 98SE on the server.

So far so good, the problem hasn't returned.

:yes:

Edited by Dave-H

Share this post


Link to post
Share on other sites

Well I spoke too soon, because after weeks of working fine the problem suddenly came back again, exactly as before.

Needless to say I have no clue as to what might have changed at the point that the error message came back!

Once again, the sync appears to actually be working, but it always ends with a red error x on the Sync Center system tray icon, and a "the parameter is incorrect" message logged.

I have no intention of wiping the whole thing and starting again a second time, as it took literally hours to rebuild the cache and it obviously didn't permanently fix the problem, so I don't know where to go from here.

:no:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...