Jump to content

HELP!: Win98SE "Scanners and Cameras" fails (window empty)


Recommended Posts

My "Scanners and Cameras" window displays no imaging devices and all 3 buttons are greyed out. What can this be? I am running Win98SE with KernelEx on a historical PC with AMD K6-3+@550MHz and 768MB RAM on mainboard DFI K6BV3+/66.

Canon D1250U2F

My very bulky old scanner "Plustek OpticPro 6000P" was for parallel port (which is occupied by my matrix printer) and stopped working long ago by driver trouble.

So on a fleamarket I recently bought a scanner "Canon D1250U2F" (stylish 1990th iMac design in grey and transparent violet, including slide scanner, original CD and manual) for USB2. But I don't get it to work. The driver "ScanGear CS-U 6.3.1a" from the CD only shows a (German language) popup error like "not enough memory", which however seems to be a very generic error behaviour of this stupid driver (I saw many such reports in forums). So I downloaded an updated version 6.3.3, which instead displays "Can not communicate with scanner. Cable may be disconnected. Check Status. Scanner driver will be closed." The buttons on the scanner sometimes (only when cold?, or after 1st driver install?) work and start a program (running stimon.exe), but when I attempt to scan, I get the same error message again.

On the scanner also the "scan" button got stuck, so I dismantled and filed the plastic button parts to make them fit better (got a little dust inside, that I need to remove later). It may be that an electrolytic capacitor in the AC adapter is dying (found a repair webpage about this) but PSU is not dead. When powered on, the white CFL tube lights up (a little dim?) for about 10 minutes. When the belt driven scanner head was manually moved out of its zero position (top rim), after power-on (had no USB connected) the motor quite slowly moves it back to zero with a buzzing noise. But I see no LEDs light up (has it none or is something broken?).

"Scanners and Cameras" trouble

When in Windows control panel I start "Scanners and Cameras", it displays nothing and (this is bizarre) all 3 buttons are greyed out, so I can not manually add or edit imaging devices. On the internet I found various complaints about the phenomenon but no explaination. I collect digcams, thus there are 21 imaging device entries in my registry. I suspected that Windows can not handle so many devices or some may be faulty, thus I even tried to delete some or all registry entries under this branch (after saving it):


But this didn't help. "Scanners and Cameras" still displays nothing, no matter whether I plug in webcams etc. I reloaded most entries into that branch and also managed to install the scanner as the 1st entry "0000" (I read hints that this may be important).

This is my contents of the logfile "Windows\Applog\STIMON.LGE":

{o e9ba8510 1c000 "E:\WINDOWS\SYSTEM\STIMON.EXE"R e9ba8510 0 40R e9ba8510 80 f8R e9ba8510 80 198r e9ba8510 18000 1000R e9ba8510 16000 1000o e9ba94b0 f000 "E:\WINDOWS\SYSTEM\STI.DLL"R e9ba94b0 0 40R e9ba94b0 80 f8R e9ba94b0 80 1c0r e9ba94b0 d000 1000R e9ba94b0 c000 c00o e9b9bd60 65000 "E:\WINDOWS\SYSTEM\SETUPAPI.DLL"R e9b9bd60 3d000 1000R e9b9bd60 3e000 1000R e9b9bd60 3f000 1000o e9b8ef10 158510 "E:\WINDOWS\SYSTEM\SHELL32.DLL"R e9b8ef10 83000 1000o e9b81150 60a00 "E:\WINDOWS\SYSTEM\SHLWAPI.DLL"R e9b81150 53400 1000R e9b81150 54400 1000o e9b818e0 47035 "E:\WINDOWS\SYSTEM\MSVCRT.DLL"R e9b818e0 3a000 1000R e9b818e0 3a000 1000R e9b818e0 34000 1000R e9b818e0 34000 1000R e9b818e0 3b000 600o e9b81010 13c00 "E:\WINDOWS\KERNELEX\KEXBASEN.DLL"R e9b81010 10800 1000R e9b81010 11800 400R e9b81010 10800 1000R e9b81010 d800 1000R e9b81010 d800 1000R e9b81150 55400 1000R e9b81150 56400 1000R e9b81150 53400 1000R e9b81150 400 1000R e9b81150 400 1000R e9b818e0 36000 1000R e9b818e0 37000 1000R e9b818e0 39000 1000R e9b818e0 38000 1000R e9b8ef10 83000 1000R e9b8ef10 1000 1000R e9b8ef10 1000 1000R e9b8ef10 84000 1000R e9b8ef10 85000 1000o e9b992c0 2b000 "E:\WINDOWS\SYSTEM\COMDLG32.DLL"R e9b992c0 1b000 1000R e9b992c0 1c000 1000R e9b992c0 1d000 600R e9b992c0 1b000 1000R e9b992c0 1000 1000R e9b992c0 1000 1000o e9b9cb50 5a00 "E:\WINDOWS\SYSTEM\WINSPOOL.DRV"R e9b9cb50 4a00 600R e9b9cb50 4a00 600o e9b84420 b000 "E:\WINDOWS\SYSTEM\CFGMGR32.DLL"R e9b84420 8000 400R e9b84420 8000 1000o c1bca5a0 e000 "E:\WINDOWS\SYSTEM\MPR.DLL"R c1bca5a0 9000 800R c1bca5a0 9000 1000o e9b7ef80 50710 "E:\WINDOWS\SYSTEM\RPCRT4.DLL"R e9b7ef80 4c400 c00R e9b7ef80 4c400 c00R e9b9bd60 3d000 1000R e9b9bd60 1000 1000R e9b9bd60 1000 1000R e9b9bd60 3e000 1000R e9ba94b0 c000 1000r e9ba8510 17000 1000R e9ba8510 16000 1000o e9baa460 3358 "E:\WINDOWS\WIN.INI"R e9baa460 0 3358C e9baa460o c1bc8d10 31f3 "E:\WINDOWS\SYSBCKUP\VER.DLL"R c1bc8d10 2f5 100R c1bc8d10 2f5 100R e9b81010 11c00 200R e9b81010 f800 1000R e9b818e0 3c000 1000R e9b818e0 35000 1000R e9ba8510 0 400R e9b818e0 3e000 1000R e9b818e0 3f000 1000R e9b818e0 40000 1000R e9b818e0 3d000 1000R e9b81150 1d400 1000R e9b81150 59600 600R e9b81150 4f400 1000R e9b81150 22400 1000R e9b81150 9400 1000R e9b81150 48400 1000R e9b81150 50400 1000R e9b81150 1e400 1000R e9b81150 3a400 1000R e9b8ef10 5000 1000R e9b8ef10 1c000 1000R e9b8ef10 87000 a00R e9b8ef10 1d000 1000R e9b8ef10 a000 1000R e9b8ef10 2000 1000R e9b992c0 f000 1000R e9b992c0 1e000 1000R e9b9cb50 4200 800o c1813f20 866e0 "E:\WINDOWS\SYSTEM\USER.EXE"R c1813f20 1844 225eR c1bca5a0 a000 400R e9b7ef80 4b800 c00R e9b9bd60 33000 1000R e9b9bd60 46000 1000R e9b9bd60 35000 1000R e9b9bd60 36000 1000R e9b9bd60 43000 1000R e9b9bd60 44000 1000R e9b9bd60 45000 1000R e9b9bd60 34000 1000R e9b9bd60 37000 1000R e9b9bd60 38000 1000R e9b9bd60 5000 1000R e9b9bd60 18000 1000R e9b9bd60 15000 1000R e9b9bd60 17000 1000R e9b9bd60 6000 1000R e9b9bd60 2000 1000R e9b9bd60 7000 1000R e9b9bd60 1c000 1000R e9b9bd60 23000 1000R e9b9bd60 11000 1000R e9b9bd60 4000 1000r e9ba94b0 3000 1000R e9ba94b0 b000 a00r e9ba94b0 1000 1000r e9ba94b0 9000 1000r e9ba94b0 a000 1000o c1bc88d0 1b0fb "E:\WINDOWS\SYSTEM\MMSYSTEM.DLL"R c1bc88d0 731 b77R c1bc88d0 731 b77r e9ba8510 b000 1000R e9ba8510 10000 1000r e9ba8510 d000 1000R e9ba8510 11000 1000r e9ba8510 e000 1000R e9ba8510 13000 1000R e9ba8510 14000 1000R e9ba8510 15000 600R e9ba8510 12000 1000r e9ba8510 c000 1000r e9ba8510 1000 1000r e9ba8510 2000 1000r e9ba8510 9000 1000r e9ba8510 7000 1000r e9ba8510 8000 1000r e9ba8510 a000 1000r e9ba8510 5000 1000r e9ba8510 4000 1000r e9ba94b0 5000 1000r e9ba94b0 2000 1000r e9ba8510 6000 1000r e9ba8510 1a000 1000r e9ba8510 f000 1000R e9b7ef80 c600 1000R e9b7ef80 13600 1000R e9b7ef80 1f600 1000r e9ba94b0 4000 1000R e9b9bd60 1d000 1000R e9b9bd60 1e000 1000R e9b9bd60 1b000 1000R e9b9bd60 1f000 1000R e9b7ef80 11600 1000}

- Which files are needed to make STICPL.CPL work?

In Win98SE "Scanners and Cameras" is handled by STICPL.CPL, but Windows ME implements this differently. May it be that an update mixed up DLLs from WinME and so makes STICPL.CPL fail? Which files are correct?

Edited by CyberyogiCoWindler
Link to comment
Share on other sites

On Windows ME there is no sticpl.cpl.The scanners and cameras control panel item is created by wiashext.dll. See screenshot for all files related to image aquisition  I have on my ME system  (may not be entirely complete).



Link to comment
Share on other sites

Have you tried installing WIA 1.1 from here?


Anyway, I had never looked into Scanners and Cameras. Did it just now and it only lists 'General Video Camera Device' which I have no idea what it is. I do have a Lexmark X-1150 combo installed and running fine under my 98SE and in fact I have just scanned a few documents a couple days ago, using the official software.


However, I have FastStone Image Viewer 5.3 installed and looked into the File menu under 'Acquire Images From Scanner'. The new window it opens lists in the right-hand dropbox all the cameras and scanners ever installed on my system, with the Lexmark X1100 series as default (as it should be).


Therefore, before messing around with the system, you may wanna try FastStone Image Viewer (freeware) and see if you can get your scanner (and other capturing devices) to work with it.

Link to comment
Share on other sites

I have installed TWAIN 1.7 (TWAIN9X.EXE) without difference. I also tried out FastStone Image Viewer 5.3; it is much like IrfanView with slicker GUI but less features, thus I uninstalled it.

The same imaging device list was already displayed by PicturePublisher 8 and IrfanView anyway, and like these, also FastStone only ended with said scanner communication error.

Link to comment
Share on other sites

There's also the possibility that the device is defective - be it the power source, the data communication channel or whatever. I still have a friend's scanner, an old LPT-port Mustek that's been powered with reverse polarity voltage for a few seconds and now doesn't do much other than power on.


To rule out hardware issues you may have to install and test it on a newer (Win2000+) system using the corresponding drivers.

Link to comment
Share on other sites

Can you scan with Canon's own bundled software (Scangear Toolbox CS or similar as comes with my Canoscan N1220U presumably)?  It always works here.


I also get communication errors sometimes when trying to acquire from the N1220U into third party software. If I then run the Scangear Toolbox briefly I can scan normally after that into whatever software supporting TWAIN.


As for your scanner not appearing  in Scanners and Cameras, its drivers probably  don't support that interface just as with mine.

Edited by loblo
Link to comment
Share on other sites

My "Scanners and Cameras" window is empty and shows none of my (8 different?) imaging devices and all 3 buttons are grayed out.

I own no other PC or OS to test it with. I want to buy a Thinkpad T61 or X61t soon, but that may still take a while. May be the scanner's PSU is bad. The plug is special, but may be I need to tap the cable somehow to test how much ripple the 12V DC 1.25A output has.

Perhaps I should try the WIA driver or even the Win98SE Unofficial Service Pack 2, but I fear the latter may make everything worse.

Edited by CyberyogiCoWindler
Link to comment
Share on other sites

There's something we all missed: the three buttons being grayed out. I presume it's about 'Add...', 'Remove and 'Properties' under the Devices tab.

How about the second tab Logging settings, or is it not present there? There should be at least one choice in the dropdown list below 'Logging module', saying 'STICLI'.

If that's missing or the tab itself is nonexistent, that may be indicate a missing or unmatched dependency.


Direct dependencies for original STICPL.CPL (on my 98SE system) would be:

STI.DLL 4.10.1998 (which is an ActiveX object)

Kernel32.dll 4.10.2226

Advapi32.dll 4.90.3000

User32.dll 4.10.2233

Gdi32.dll 4.90.3003

Comctl32.dll 5.81

Shell32.dll 4.72.3612.1700

Ole32.dll 4.71.3328


STI.DLL has the following dependencies:




Setupapi.dll 5.00.1671.1

Cfgmgr32.dll 4.10.1998

RPCRT4.dll 4.71.3336


Again, those version numbers are present on my system, where the 'Scanners and Cameras' control panel has those three buttons active. Never ever used that applet though. Your versions may be different.

I'm thinking of a bad OLE installation. I remember there used to be a tool that checked the validity of all OLE elements installed, but forgot its name.

Link to comment
Share on other sites

Microsoft Systeminfo shows these DLL versions:

STI.DLL 4.10.1998          (same)Kernel32.dll 4.10.2226     (mine 4.10.2222)Advapi32.dll 4.90.3000     (mine 4.80.1675)User32.dll 4.10.2233       (mine 4.10.2231)Gdi32.dll 4.90.3003        (mine 4.10.1998)Comctl32.dll 5.81          (same)Shell32.dll 4.72.3612.1700 (mine 4.72.3812.634)Ole32.dll 4.71.3328        (same) STI.DLL dependencies:Kernel32.dllAdvapi32.dllUser32.dllSetupapi.dll 5.00.1671.1  (same)Cfgmgr32.dll 4.10.1998    (same)RPCRT4.dll 4.71.3336      (same)
The "Scanners and Cameras" window does have a 2nd tab where I can select a protocol mode STICLI or STIMON and 3 checkboxes. If I switch to "STIMON", it returns to "STICLI" when reopened.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...