Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Hella

Getting the ATI Mobility FireGL V5000 / Mobility Radeon X700 to work w

Recommended Posts

20 hours ago, JasonSlaye said:

I dont know if this post will be read again but man, i got a asus laptop with a mobility radeon X700. I try your solution but i may fail, i find catalyst 4.11 but not sure its a good one.

...

The color is still limited to 2 or 16 color. If you read my message can you help me or make me a package with your driver for this graphic card ?

This problem (Mobility X600 in my case) drove me nuts for a long time on a laptop I was trying to get up and running with 9x. Despite scattered reports of people getting Mobility X600/X700 chips working under 9x, no matter how many times I tried or how many different Catalyst versions I tried, nothing ever changed.

Forget Catalyst 4.11, use the last 9x compatible package. 2K/XP WDM (non-.VXD) Display drivers do not work under 9x, so they won't get you anywhere either.

If you're having the same problem I did, then this should cure it. Disable PCI Steering on the PCI Bus under Device Manager. The reinstall the ATI Catalyst package if necessary. Manually choose an X700 device from the list, or add your specific VEN&DEV to the INF if you wish.

Share this post


Link to post
Share on other sites

7 hours ago, LoneCrusader said:

This problem (Mobility X600 in my case) drove me nuts for a long time on a laptop I was trying to get up and running with 9x. Despite scattered reports of people getting Mobility X600/X700 chips working under 9x, no matter how many times I tried or how many different Catalyst versions I tried, nothing ever changed.

Forget Catalyst 4.11, use the last 9x compatible package. 2K/XP WDM (non-.VXD) Display drivers do not work under 9x, so they won't get you anywhere either.

If you're having the same problem I did, then this should cure it. Disable PCI Steering on the PCI Bus under Device Manager. The reinstall the ATI Catalyst package if necessary. Manually choose an X700 device from the list, or add your specific VEN&DEV to the INF if you wish.

Thanks a lot for your quick answer. So i listen to you advices,

I first go into device manager, i go to pci bus property then in irq sterring tabs i unchecked all options so it shouldn't use IRQ steering.

I download the catalyst 6.2 without wdm so for win9X : http://retro.software/downloads/download/235-win98-video-drivers/1397-ati-catalyst-6-2-drivers.html

I install it in WIn9X but after its get uncompressed in : c:\ATI\Support, its start the driver install saying it not find at all a drivers compatible.

So in the same folder i put my modified inf of the C8_30314.INf files with this line added :

"ATI MOBILITY RADEON X700 Series" = RV410_ENU, PCI\VEN_1002&DEV_5652&SUBSYS_19621043&REV_00
"ATI MOBILITY RADEON X700 Series Secondary  " = RV410_ENU, PCI\VEN_1002&DEV_5652&SUBSYS_19621043
"ATI MOBILITY RADEON X700 Series Third" = RV410_ENU, PCI\VEN_1002&DEV_5652&CC_030000
"ATI MOBILITY RADEON X700 Series Fourth" = RV410_ENU, PCI\VEN_1002&DEV_5652&CC_0300

So i lunch the setup.exe from the Support folder but still it dont detect my driver so i make a copy of the C9_*.ini that i rename C8 and the installer still not find my driver.

Then i modified the C9_30314.inf with the same line i put above but the installer is still not recognise. 

Finaly i go to the folder Cpanel for install the ati c panel, the installation work and i update manualy my driver with the modified inf, windows detect it take it then ask me to reboot, then when i reboot my screen become black with green shade appearing all over like if gpu get malfunction. So i need to reboot under windows xp go to C:/windows/system.ini of windows 98 and remove the lines :

386Grabber=vgafull.3gr

display.drv=pnpdrvr.drv

from the [boot] section for return finaly to my desktop with the graphic proposing 256 colors or 16 bit but when i choose it, i restart then i return to 16 colors.

Also i got catalyst starting saying he cant detect my hardware. I'm feel a bit stuck now.. Not knowing where to look at.

 

By the way in the graphic menu for change color and resolution i can see 2 screen appearing (before i deleted one of the graphic device cause was making conflit) and my version of Windows 98 is caming from Unattended Boot CD for 98 and sometime whennavigate in menu (mostly when i unplug my usb dongle) i got freeze and need force reboot.

C8_30314.INF C8_30314.INI C9_30314.INI C9_30314.inf

Edited by JasonSlaye

Share this post


Link to post
Share on other sites

What's the Manufacturer/Model and specs of the laptop you're using? This will help us figure out if there may be other issues contributing to the problem.

Most likely you will need to first install Windows 98SE with ACPI disabled (SETUP /P I) if you have not already done so. When I tried with ACPI enabled on my laptop I got an unrecoverable series of crashes.

It's been several months, and I don't have the machine readily accessible at the moment, :unsure: but from what I can remember you should only need to uncheck one option box to disable PCI steering. Other changes may produce different results and these may vary yet again according to the hardware in use.

Your changes to C8_30314.INF should have been sufficient; you don't really need to change anything else but you will have to point the Update Driver wizard to the 9X_INF folder manually rather than depending on Catalyst Setup. I would just use one line and truncate the entry to just ""ATI MOBILITY RADEON X700 Series" = RV410_ENU, PCI\VEN_1002&DEV_5652" eliminating the REV, SUBSYS, and CC codes, as these get really super device-specific for no reason as they all point to the same section.

Now, C9_30314.INF does NOT have all of the required sections to install a RV410_ENU device. This may be the reason for the crashes if you were using this INF at this point rather than your C8_30314.INF, which does have all of the required sections. Simply reverting to your C8_30314.INF may work; if not, or if you experience crashes/instability, start over using 98SE with ACPI disabled as above.

Share this post


Link to post
Share on other sites

Well the laptop is a Asus V6000 model V6X00VA , V6VA-X02P.

Its a laptop for Windows XP with a Pentium M 2GHZ, with 2GB ram with a ATI mobility Radeon X700 128mb.
Under Windows 98 with system.ini i limit the ram and the vcache to 512mb (1FFFF).

I put a dx diag from my XP session, I will reinstall windows 98 with the command you tell me i thought install with the Unattended Boot CD for 98 would fix most of my issue.

By the way i got glitch graphic even with the C8_*.inf file

Edit:

So i did a full reinstall of Windows 98 with the command "Install /P i" (cause french version replace setup by install), then i put back drivers i got available (sd, ms,xd cards, lan , sound) and also i unchek steering in the pc bus

then i run the driver installer its go decompress the file in the ATI/Support folder then in ATI/Support/6.2/Drivers i put my modified INF with only one line added the one you told me.

Then i make a restart and i got this screen :

fOcL7jc.jpg

I remove back the driver, install the cpanel, force windows install back the driver then still get this screen with windows working behind (keyboard, sound everything work in except the screen).

DxDiagXP.txt DxDiag98.txt

Edited by JasonSlaye

Share this post


Link to post
Share on other sites

IGP (X12xx, 21xx)
Main article: Radeon R400 series
All models include Direct3D 9.0b and OpenGL 2.0
Based on Radeon X700
Model    Launch    Code name    Fab (nm)    Bus interface    Core clock (MHz)    Memory clock (MHz)    Core config1    Fillrate    Memory
MOperations/s    MPixels/s    MTexels/s    MVertices/s    Size (MB)    Bandwidth (GB/s)    Bus type    Bus width (bit)
Radeon Xpress X1200    Feb. 28 2007    RS690C (zeus)    80    HT 2.0    350    400 - 800    4:2:4:4    1400    1400    1400    175    256 - 512    6.4 - 12.8    DDR2    128
Radeon Xpress X1250    Aug. 29, 2006 (Intel), Feb. 28, 2007 (AMD)    RS600, RS690 (zeus)    FSB, HT 2.0    400    1600    1600    1600    200
Radeon Xpress 2100    March 4, 2008    RS740 (titan)    55    HT 2.0    500    2000    2000    2000    250

I have got these drivers The top one which is not shown is ATI Mobility FireGL V5200. I know that ATI drivers for 9500 and 9700 either can be installed on the cards and x700 drivers run on my x850 agp so the V5200 driver could be good for the V5000? They do not have the same GPU chip number but neither has x700 compared to x850. PCI FireGL 9250 cards were wired different to that of normal 9250 ones and drivers were not made for win9x, so FireGL would need to be the criteria when choosing a driver. I have uploaded INF see if your card is found?

Mobile ATI Drivers.png

CL_40818.zip

Edited by Goodmaneuver

Share this post


Link to post
Share on other sites
On 11/22/2019 at 6:56 PM, Goodmaneuver said:

IGP (X12xx, 21xx)
Main article: Radeon R400 series
All models include Direct3D 9.0b and OpenGL 2.0
Based on Radeon X700
Model    Launch    Code name    Fab (nm)    Bus interface    Core clock (MHz)    Memory clock (MHz)    Core config1    Fillrate    Memory
MOperations/s    MPixels/s    MTexels/s    MVertices/s    Size (MB)    Bandwidth (GB/s)    Bus type    Bus width (bit)
Radeon Xpress X1200    Feb. 28 2007    RS690C (zeus)    80    HT 2.0    350    400 - 800    4:2:4:4    1400    1400    1400    175    256 - 512    6.4 - 12.8    DDR2    128
Radeon Xpress X1250    Aug. 29, 2006 (Intel), Feb. 28, 2007 (AMD)    RS600, RS690 (zeus)    FSB, HT 2.0    400    1600    1600    1600    200
Radeon Xpress 2100    March 4, 2008    RS740 (titan)    55    HT 2.0    500    2000    2000    2000    250

I have got these drivers The top one which is not shown is ATI Mobility FireGL V5200. I know that ATI drivers for 9500 and 9700 either can be installed on the cards and x700 drivers run on my x850 agp so the V5200 driver could be good for the V5000? They do not have the same GPU chip number but neither has x700 compared to x850. PCI FireGL 9250 cards were wired different to that of normal 9250 ones and drivers were not made for win9x, so FireGL would need to be the criteria when choosing a driver. I have uploaded INF see if your card is found?

Mobile ATI Drivers.png

CL_40818.zip 4.78 kB · 2 downloads

Hello, thanks for try help, actually my graphic card is not detect by your file. So i need find a way to include it into the windows for force the update and try the firegl V52000. While i was waiting answer i tried with Windows Millenium who get the same blur problems when i install video. I returned with a fresh install of Win98 cause millenium was very unstable.

edit:

I took a deep look into your inf file but its not working with catalyst 6.2 My driver use resources RV410 when your ask for non existant ati2mtag_M56GL. I would need the full folder with the dll and the cat.

Edited by JasonSlaye

Share this post


Link to post
Share on other sites

I have installed these drivers on a hard drive some where & I have copied over the inf. But because I had not used them I can not find files. I was trying to get my x1600 AGP working. Anyway I have found this driver & the x1700 CL_40818 driver will be here at this site too. http://www.driversguru.com/driverdetail/1925771-ATI+Mobility+P%2C+v.+1.0%2C+A01  This one looks better if it has the video drivers http://www.driversguru.com/driverdetail/2143251-ATI+FireGL+Unified+Graphics+Driver+(x86) 
 

Edited by Goodmaneuver

Share this post


Link to post
Share on other sites
41 minutes ago, Goodmaneuver said:

I have installed these drivers on a hard drive some where & I have copied over the inf. But because I had not used them I can not find files. I was trying to get my FireGL 9250 PCI working. Anyway I have found this driver & the x1700 CL_40818 driver will be here at this site too. http://www.driversguru.com/driverdetail/1925771-ATI+Mobility+P%2C+v.+1.0%2C+A01 
 

Unfortunaly its not get detect at all. I actually reinstall Windows 98 cause the previous install make my explorer make disapear all after i did install SP3

 

edit: i just saw your second link, i will try it soon as the install end

Edited by JasonSlaye

Share this post


Link to post
Share on other sites

Have you just lost your installation? I Hope you do not break your machine. What I think is best is to extract the CL_40818 drivers & then see if it has the files the inf says. I made a mistake posting that first URL as it is 2001 driver. https://dl.dell.com/video/R205351.exe contains the files but are not compiled compatible I will look further it has to be on driversguru. Mainly the Setupapi is not separated from Cfgmgr32.

Edited by Goodmaneuver

Share this post


Link to post
Share on other sites
1 hour ago, Goodmaneuver said:

Have you just lost your installation? I Hope you do not break your machine. What I think is best is to extract the CL_40818 drivers & then see if it has the files the inf says. I made a mistake posting that first URL as it is 2001 driver. https://dl.dell.com/video/R205351.exe contains the files but are not compiled compatible I will look further it has to be on driversguru. (Mainly the Setupapi is not separated from Cfgmgr. Good test for KEX24?)

 

Hi again, dont worry i didnt break the machine, i just break windows 98 install with using some unofficial service pack. Well now i got a fresh install so i redo my test with all link you give me and mm no not at all. Most of the driver i got is from xp and even if i put inf files into windows/inf/ folder its not propose at all.

Putting the file in the folder of the driver not make it detect too. Sorry its kind of annoying i know. I think the drivers you give me is made for xp only.

Share this post


Link to post
Share on other sites

I am working on it, do not try until I have all files we need. We need a driver that is based on 2006-7 I have most files compatible from R128573.EXE but I cannot find he original driver I must have had. There is still no guarantees even if the files comply but I will keep looking. We are only missing the direct draw and language files that are not in R128573.EXE. I will catch up again tomorrow.
 

Edited by Goodmaneuver

Share this post


Link to post
Share on other sites
1 hour ago, Goodmaneuver said:

I am working on it, do not try until I have all files we need. We need a driver that is based on 2006-7 I have most files compatible from R128573.EXE but I cannot find he original driver I must have had. There is still no guarantees even if the files comply but I will keep looking. We are only missing the direct draw and language files that are not in R128573.EXE. I will catch up again tomorrow.
 

Well i can guve you my orignal xp drivers if you wish. At least i know this one work perfect under this laptop in xp

Share this post


Link to post
Share on other sites

I do not know how to get XP INF's to load into registry. The CL means that is Vista driver only I think could mean Win7 as well. I just renamed %Windows NT% to %CHICAGO% & WinME liked it. *I forgot*. Now it is just a try, the files in https://dl.dell.com/video/R128573.EXE are Dependency Walker friendly to WinME. So extract them into usual place like Program Files\Ati Technologies\Support\Mobile really only need files in the XP_INF folder. The only other files missing are the Direct Draw installation which can be obtained from early Vista or LongHorn which too is friendly to Kernel32 & ativvaxx.dat which is found in R168684.exe. I have only checked LH_5048 - LH_5600, have no copy of original Vista any more. Found in Windows\System32\DriverStore\FileRepository\atiilhag.inf.......

(I know now how to install 2K & XP INFs but they rely on ati2mtag.sys which will not work I believe.)
 

Edited by Goodmaneuver

Share this post


Link to post
Share on other sites
On 11/21/2019 at 4:23 AM, JasonSlaye said:

Well the laptop is a Asus V6000 model V6X00VA , V6VA-X02P.

Its a laptop for Windows XP with a Pentium M 2GHZ, with 2GB ram with a ATI mobility Radeon X700 128mb.
Under Windows 98 with system.ini i limit the ram and the vcache to 512mb (1FFFF).

I put a dx diag from my XP session, I will reinstall windows 98 with the command you tell me i thought install with the Unattended Boot CD for 98 would fix most of my issue.

By the way i got glitch graphic even with the C8_*.inf file

Edit:

So i did a full reinstall of Windows 98 with the command "Install /P i" (cause french version replace setup by install), then i put back drivers i got available (sd, ms,xd cards, lan , sound) and also i unchek steering in the pc bus

then i run the driver installer its go decompress the file in the ATI/Support folder then in ATI/Support/6.2/Drivers i put my modified INF with only one line added the one you told me.

Then i make a restart and i got this screen :

...

I remove back the driver, install the cpanel, force windows install back the driver then still get this screen with windows working behind (keyboard, sound everything work in except the screen).

2GB of RAM may be a problem here; try using rloew's RAM Limitation Patch instead. The various ram limiting "tweaks" never worked for me.

I can't make out the picture very well; I assume it's just a black screen? IIRC this happens to my X600 laptop when I try to load the drivers under 95. Never found a solution for 95, but at least 98 worked in my case.

What resolution was attempted/did you try to set for your desktop? It's possible the Mobility X700 or your laptop's LCD panel may not properly support some resolutions. Custom resolutions can be added to the INF file as well (adapt for your card's INF file/section and desired resolution obviously); it may be best to add one for the default resolution chosen by the drivers working under XP and reported in the DXDIAG you posted.

Beyond this I'm not sure what to try next. SciTech Display Doctor might be of some use.. It worked on my X600 laptop under 95 but broke Plug & Play in the process.

4 hours ago, Goodmaneuver said:

I do not know how to get XP INF's to load into registry. The CL means that is Vista driver only I think could mean Win7 as well. I just renamed %Windows NT% to %CHICAGO% & WinME liked it. *I forgot*. Now it is just a try, the files in https://dl.dell.com/video/R128573.EXE are Dependency Walker friendly to WinME. So extract them into Program Files\Ati Technologies\Support\Mobile really only need files in the XP_INF folder. The only other files missing are the Direct Draw installation which can be obtained from early Vista or LongHorn which too is friendly to Kernel32. I have only checked LH_5048 - LH_5552, have no copy of original Vista any more.

Jason, please do not quote me on this & do not reply just yet as I want to update this post. I posted this for an update and for other readers. Will be several hours before I edit again. 
 

What do you possibly hope to achieve by loading an XP driver INF into the registry? :dubbio: First of all, as I've already pointed out, 2K/XP/Vista/etc display drivers DO NOT WORK under 9x. As far as I know, despite the fact that other devices can use WDM (.SYS) drivers, display drivers under 9x MUST be .VXD drivers. I can't remember the source of that, but I read it somewhere years ago, and I have yet to see any evidence to contradict it.

Dependency Walker is for user-mode programs, not drivers, which are an entirely different beast. The proper way to check a 2K/XP WDM driver for 9x compatibility is to use WDMCHECK by Walter Oney or DISPPE32 by rloew on the file while running under 9x.

Aside from all that; even IF it were possible to load a .SYS display driver under 9x, the NT-style INFs do not have the correct sections and registry entries to properly load such a device driver under 9x. :no:

Share this post


Link to post
Share on other sites

I did update my video card to the INF's request I cannot directly test so it is up to Jason. The only other alternative is Universal Vesa drivers. The GPU chip has got the FireGL suffix on it I do not think it is compatible with just rv400. In which case the updated files will need to be run. I know I edit too much but it is for correct reasons in the main. The file version of 6 can be used in the AIW TV drivers. The main thing is I made a mistake as I said.
 

Edited by Goodmaneuver

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...