Jump to content

need autounattended.xml help


franner
 Share

Recommended Posts

I have made a autounattended.xml for a multiboot windows 7 x86/x64 and server 2008 r2. I have tested this Image many times. The autounattended.xml file works fine except one specific region which I need handled.

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="windowsPE">
<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<UserData>
<ProductKey>
<Key></Key>
</ProductKey>
<Organization>Franner Inc.</Organization>
<FullName>Franner</FullName>
<AcceptEula>true</AcceptEula>
</UserData>
<ImageInstall>
<OSImage>
<InstallFrom>
<MetaData wcm:action="add">
<Key>/IMAGE/NAME</Key>
<Value></Value>
</MetaData>
</InstallFrom>
</OSImage>
</ImageInstall>
</component>
<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<UserData>
<ProductKey>
<Key></Key>
</ProductKey>
<Organization>Franner Inc.</Organization>
<FullName>Franner</FullName>
<AcceptEula>true</AcceptEula>
</UserData>
<ImageInstall>
<OSImage>
<InstallFrom>
<MetaData wcm:action="add">
<Key>/IMAGE/NAME</Key>
<Value></Value>
</MetaData>
</InstallFrom>
</OSImage>
</ImageInstall>
</component>
</settings>



<settings pass="specialize">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<ComputerName></ComputerName>
<ShowWindowsLive>false</ShowWindowsLive>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<ComputerName></ComputerName>
<ShowWindowsLive>false</ShowWindowsLive>
</component>
<component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<FilterLevel>High</FilterLevel>
<PlaySound>false</PlaySound>
<ShowInformationBar>false</ShowInformationBar>
<DisableAccelerators>true</DisableAccelerators>
<DisableDevTools>true</DisableDevTools>
<DisableFirstRunWizard>true</DisableFirstRunWizard>
<DisableOOBAccelerators>true</DisableOOBAccelerators>
<Home_Page>http://www.google.com</Home_Page>
<SearchScopes>
<Scope wcm:action="add">
<ScopeDefault>true</ScopeDefault>
<ScopeDisplayName>Google</ScopeDisplayName>
<ScopeKey>SearchProvider1</ScopeKey>
<ScopeUrl>http://www.google.com/search?q={searchTerms}</ScopeUrl>
</Scope>
</SearchScopes>
</component>
<component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<FilterLevel>High</FilterLevel>
<PlaySound>false</PlaySound>
<ShowInformationBar>false</ShowInformationBar>
<DisableAccelerators>true</DisableAccelerators>
<DisableDevTools>true</DisableDevTools>
<DisableFirstRunWizard>true</DisableFirstRunWizard>
<DisableOOBAccelerators>true</DisableOOBAccelerators>
<Home_Page>http://www.google.com</Home_Page>
<SearchScopes>
<Scope wcm:action="add">
<ScopeDefault>true</ScopeDefault>
<ScopeDisplayName>Google</ScopeDisplayName>
<ScopeKey>SearchProvider1</ScopeKey>
<ScopeUrl>http://www.google.com/search?q={searchTerms}</ScopeUrl>
</Scope>
</SearchScopes>
</component>
<component name="Microsoft-Windows-ErrorReportingCore" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<DisableWER>1</DisableWER>
</component>
<component name="Microsoft-Windows-ErrorReportingCore" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<DisableWER>1</DisableWER>
</component>
</settings>



<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<UserAccounts>
<AdministratorPassword>
<Value></Value>
<PlainText>true</PlainText>
</AdministratorPassword>
<LocalAccounts>
<LocalAccount wcm:action="add">
<Name>Computer</Name>
<Group>Administrators</Group>
<Password>
<PlainText>true</PlainText>
<Value></Value>
</Password>
</LocalAccount>
</LocalAccounts>
</UserAccounts>
<AutoLogon>
<Enabled>true</Enabled>
<Username>Computer</Username>
<Password>
<Value />
</Password>
<LogonCount>9999999</LogonCount>
</AutoLogon>
<TimeZone>Romance Standard Time</TimeZone>
<ComputerName>Computer x86</ComputerName>
<OOBE>
<HideEULAPage>true</HideEULAPage>
<NetworkLocation>Home</NetworkLocation>
<ProtectYourPC>3</ProtectYourPC>
<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
</OOBE>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<UserAccounts>
<AdministratorPassword>
<Value></Value>
<PlainText>true</PlainText>
</AdministratorPassword>
<LocalAccounts>
<LocalAccount wcm:action="add">
<Name>Computer</Name>
<Group>Administrators</Group>
<Password>
<PlainText>true</PlainText>
<Value></Value>
</Password>
</LocalAccount>
</LocalAccounts>
</UserAccounts>
<AutoLogon>
<Enabled>true</Enabled>
<Username>Computer</Username>
<Password>
<Value />
</Password>
<LogonCount>9999999</LogonCount>
</AutoLogon>
<TimeZone>Romance Standard Time</TimeZone>
<ComputerName>Computer x64</ComputerName>
<OOBE>
<HideEULAPage>true</HideEULAPage>
<NetworkLocation>Home</NetworkLocation>
<ProtectYourPC>3</ProtectYourPC>
<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
</OOBE>
</component>
</settings>
<servicing>
<package action="configure">
<assemblyIdentity name="Microsoft-Windows-Foundation-Package" version="6.1.7600.16385" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="" />
<selection name="WAS-WindowsActivationService" state="true"/>
<selection name="WAS-NetFxEnvironment" state="true"/>
<selection name="WAS-ConfigurationAPI" state="true"/>
<selection name="DesktopExperience" state="true"/>
<selection name="InkSupport" state="true"/>
<selection name="NetFx3" state="true"/>
<selection name="WAS-ProcessModel" state="true"/>
<selection name="WirelessNetworking" state="true"/>
</package>
</servicing>
</unattend>

servicing part:

<servicing>
<package action="configure">
<assemblyIdentity name="Microsoft-Windows-Foundation-Package" version="6.1.7600.16385" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="" />
<selection name="WAS-WindowsActivationService" state="true"/>
<selection name="WAS-NetFxEnvironment" state="true"/>
<selection name="WAS-ConfigurationAPI" state="true"/>
<selection name="DesktopExperience" state="true"/>
<selection name="InkSupport" state="true"/>
<selection name="NetFx3" state="true"/>
<selection name="WAS-ProcessModel" state="true"/>
<selection name="WirelessNetworking" state="true"/>
</package>
</servicing>

The problem is if I have the <servicing> part in autounattended.xml then windows 7 x86 and x64 will have error at the end of the install because they don't have the component (features) which gets enabled in <servicing>. This part is needed for server 2008 R2 which installs fine. When I take out the <servicing> part everything is fine when installing windows 7.

My question is, is there a way around to get windows 7 x86/x64 and server 2008 R2 unattended install with the services enabled. An solution I would think was good if its possible (I unfortunately dunno which code to write), would be to make the <servicing> part only run if windows server 2008 r2 was selected and otherwise ignored by windows 7.

The last 2 weeks I have been searching with google, msfn, and many other sites which write about unattended setups, unattended.xml, autounattended.xml, <servicing> etc. But I haven't found someone who did have a similiar situation.

I hope u can guide me to help me solve this problem.

In code I would do something like this (I know this cannot be used in the xml file but I think u get the idea where I want to head as a suggestion). Take this as an illustration.

if %winOS% == "server 2008 R2" Then

<servicing>

.

.

.

</servicing>

endif

Edited by franner
Link to comment
Share on other sites


Yes I am also using DISM, but mostly from command line. I am enabling some features like netframwork etc. (from the xml file)

Which features do you want me to disable?

Thank you for wanting to help me

Edited by franner
Link to comment
Share on other sites

My bad, you are enabling the features...why not use dism to enable them instead of the xml?

for %i in (WAS-WindowsActivationService WAS-NetFxEnvironment WAS-ConfigurationAPI DesktopExperience InkSupport NetFx3 WAS-ProcessModel WirelessNetworking) do dism /Image:<path_to_mount_folder> /Enable-Feature /FeatureName:%i

Link to comment
Share on other sites

  • 3 months later...

I have a similar problem.

I make a AiO Instalation with 7 versions of windows Seven. All works fine with my custom Autounattend.xml file except NetBook Edition version.

During install appears a error. this error occours because I disable System Restore in Autounnatended file and I have removed System Restore from Netbook Edition. The when windows setup tries to disable this feature appears a error.

Can I disable System Restore (and other itens) with DISM? I want simple disable, don't remove that feature because in some scenarios they can be usefull.

Other itens I want to disable with DISM (disable, don't remove):

WinDefend (Windows Defender)

WSCSVC (Action\Security Center)

SDRSVC (Windows Backup),

Is it can be done with DISM can anyone post a script or REG tweak to disable that things?

Other question, how can I enable automatic driver and icons download during instalations? This can be done with dism or I need to create a script or regtweak or maybe in Autounattend.xml file?

Thanks for help

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...