Jump to content

ModifyPE and Windows 7

Recommended Posts

Some time back (and I believe I got them from here), I downloaded some tools to add expanding and compressing Windows files to the "Send To" Context Menu. There was a batch file version, and a VBS version. These worked great, all the way up to Windows Vista x64 (including through SP2). However, now I've moved on to Windows 7 x64, and I'm having some trouble. I can expand the files just fine, since Windows 7 has it's own Expand.exe built in. But ModifyPE.exe is no longer functioning. I get an error saying:


Obviously, it does me no good to be able to expand a file, if I can't subsequently compress it again. I don't absolutely have to do this on my Win7 machine. I have two other machines, one with XP Pro and another with XP Pro x64, both of which would work fine to do the job, but it would be nice if I could do what I needed on all three of my systems.

I've already disabled UAC, so that's out of the picture. Has anyone found a workaround, or possibly a better method of expanding and compressing Windows system files in Windows 7? I'm always game to try new methods, if it's an improvement over the old method. I tried searching the forums for "modifype windows 7", but found no relevant results. Any suggestions or advice would be appreciated, even if it's just to tell me that I'm out of luck, so I don't waste my time further.

Link to comment
Share on other sites

ModifyPE is poorly coded and doesn't work with anything newer than XP. This has been discussed dozens of times on these forums. Just try a similar utility instead (a forum search should yield relevant results e.g. search just for modifype)

Link to comment
Share on other sites

I always lived by the rule that - when using a search engine - the more relevant information you type in, the more relevant information you get out. In this case, I guess I was just over-complicating things. Thanks for the heads up.

Link to comment
Share on other sites

As I said elsewhere, ModifyPE gives invariably the "Invalid parameter, type modifype for help" error and refuses to work when run under Vista (and, presumably, also Win 7)...

[...] It's known since 2007, and never resolved, up to now. See this post, over at siginetsoftware. You may try PEChecksum, from the CodeProject, or you may try the old freeware PEChksum v0.99.0, from Bitsum Technologies, findable inside the PESuite. I cannot guarantee either Bitsum PEChksum or PEChecksum from the CodeProject will run OK in Vista [or Win 7]. It's up to you to try them and report your findings.
You asked for ideas, here above are two of them. Good luck! ...and keep us posted on your results.

As you can see, there are more than one program called PECh[ec]ksum, and either of them may be viable alternatives.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...