Jump to content

RT Seven Lite - RC build 1.7.0 and Beta build 2.6.0


Recommended Posts


Helllo,

I built my newest Win7 DVD by using "RT Se7en Lite RC build 1.60" to integrate the Updates, LangPacks, Drivers, Tweaks and Remove all language components except japanees (red), then I integrated the Addons with Windows 7 Toolkit and finally added WPI+Softwares.

I tested it today, the updates wasn't integrated (:

Moreover, at about the end of win7 installation when user themes are installed, WPI is launched, 2 minutes later I get a message indicating windows goes to be restarted in less than a minute.

As expected after th restart, i got no more chance to install the softwares with WPI.

Anything wrong with my process?

BTW, As I'm using and will use only English and French languages, may i remove all all language components including Japanese?

Regards

Link to post
Share on other sites

But still if I have to mark stuff on right first in order to be able to remove it, why can I tick anything on left anyway? I still do not understand at all.

I don't know what's your great confusion here to use.....If you something wants to remove on the left side which is permanently removed if same app found found on the default windows features you have to uncheck that first. Both are linked. Saving last session is working good. Your output will be saved only after every operation completed successfully. It will not save it instantly after you giving the name and path. For drivers, it will take the inf if it's related files found otherwise it will exclude that. Nvidia and AT drivers integration is fixed in upcoming new build. If you select Multiple drivers button, rt 7 lite will search upto the last root folders. Suppose if you select just windows, it will search every inf under that folder. Also it will read the entire inf to locate its related files. I can say...its working good.

Edited by bensam56
Link to post
Share on other sites

Helllo,

I built my newest Win7 DVD by using "RT Se7en Lite RC build 1.60" to integrate the Updates, LangPacks, Drivers, Tweaks and Remove all language components except japanees (red), then I integrated the Addons with Windows 7 Toolkit and finally added WPI+Softwares.

I tested it today, the updates wasn't integrated (:

Moreover, at about the end of win7 installation when user themes are installed, WPI is launched, 2 minutes later I get a message indicating windows goes to be restarted in less than a minute.

As expected after th restart, i got no more chance to install the softwares with WPI.

Anything wrong with my process?

BTW, As I'm using and will use only English and French languages, may i remove all all language components including Japanese?

Regards

post your last session

Link to post
Share on other sites

Helllo,

I built my newest Win7 DVD by using "RT Se7en Lite RC build 1.60" to integrate the Updates, LangPacks, Drivers, Tweaks and Remove all language components except japanees (red), then I integrated the Addons with Windows 7 Toolkit and finally added WPI+Softwares.

I tested it today, the updates wasn't integrated (:

Moreover, at about the end of win7 installation when user themes are installed, WPI is launched, 2 minutes later I get a message indicating windows goes to be restarted in less than a minute.

As expected after th restart, i got no more chance to install the softwares with WPI.

Anything wrong with my process?

BTW, As I'm using and will use only English and French languages, may i remove all all language components including Japanese?

Regards

post your last session

I rebuild another Win7DVD by using "RT Se7en Lite RC build 1.60" to integrate 97 Updates, 2 LangPacks,480 Drivers, Tweaks and Remove all language components japanees included, then I added WPI+Softwares (NO addons NO Windows 7 Toolkit) .

Same problem as above, only 11 updates are installed (see image bellow) and more worrying after WPI launched I get a message indicating windows goes to be restarted in less than a minute, NO chance to install the softwares with WPI.

BTW, WPI is launched in Win7\sources\$OEM$\$$\Setup\scripts\setupcomplete.cmd as

for %%i in (C D E F G H I J K L M N O P Q R S T U V W X Y Z) do if exist %%i:\sources\install.wim set CDROM=%%i:

Start %cdrom%\Software\WPI\wpi.exe

del %0

TNX for yr help

Link to post
Share on other sites

Hello coucou !

About RT Se7en Lite, I think it's better to keep NetFx3

Inside your Lastsession.inf you can see:

[Features]

NetFx3=False

About WPI, Isee the batch file working good is:

You can download here: sources folder


for %%i in (C D E F G H I J K L M N O P Q R S T U V W X Y Z) do if exist %%i:\sources\install.wim set CDROM=%%i:

Start %cdrom%\WPI\wpi.exe

del %0

You need to change the path. WPI folder is set at the root of your DVD!

See inside the folder:

%systemdrive%\Programs\Rockers Team\RT 7 Lite x86\Preset\Lastsession1.inf

If you have many "Lastsession(x).inf

I hope that can help you!

Edited by myselfidem
Link to post
Share on other sites

Hello coucou !

About RT Se7en Lite, I think it's better to keep NetFx3

Inside your Lastsession.inf you can see:

[Features]

NetFx3=False

TNX myselfidem,

Do I have just to modify NetFx3=True inside the .iso and reinstall Win7 for test

or do ihave to modify NetFx3=True, restart the whole RT7Lite integration then reinstall Win7 for test

BTW, should i use the Autounattend.xml RTSe7enLite created or I can use a personal Autounattend.xml?

About WPI, Isee the batch file working good is:

You can downlaod here: sources folder


for %%i in (C D E F G H I J K L M N O P Q R S T U V W X Y Z) do if exist %%i:\sources\install.wim set CDROM=%%i:

Start %cdrom%\WPI\wpi.exe

del %0

You need to change the path. WPI folder is set at the root of your DVD!

I don't think so, since i gave the right path (%cdrom%\Software\WPI\wpi.exe). This was tested for a years with WinXP and few month with Win7 built by 7customizer or Windows 7Toolkit. Moreover, WPI is launched correctly.

The problem is the Win7 builtd RTSe7enLite force a restart at the wrong time. The restart should be launched after WPI finishing the software installation.

Regards

Link to post
Share on other sites

Yes you can use your customized "Autounattend.xml" with RT Se7en Lite!

With RT Se7en Lite, maybe this value force an restart inside "Lastsession.inf":

AppInstallationMode=True

If you use WPI you don't need the RT Lite Installer.

I'm not sure if it's only needed to change the value to: Netfx3=True without making a new time all the process!

Edited by myselfidem
Link to post
Share on other sites

TNX again myselfidem for yr help;)

BTW, the actual Win7 builtd RTSe7enLite is NOT fully silent. To finish the installation, it ask for User Name; Passworg; then Configure Windows for Updates...

As much I understood, "Lastsession.inf" is the result of RTSe7enLite integration and can be used to check how goes the integration, BUT it NOT used for Win7 installation.

Therfore if everything goes fine it can be throw. Isn't it???

Will wait bensam56 advices. Hope he will reply shortly.

Edited by coucou
Link to post
Share on other sites

TNX again myselfidem for yr help;)

BTW, the actual Win7 builtd RTSe7enLite is NOT fully silent. To finish the installation, it ask for User Name; Passworg; then Configure Windows for Updates...

As much I understood, "Lastsession.inf" is the result of RTSe7enLite integration and can be used to check how goes the integration, BUT it NOT used for Win7 installation.

Therfore if everything goes fine it can be throw. Isn't it???

Will wait bensam56 advices. Hope he will reply shortly.

rt 7 lite uses dism for updates integration....Updates are being installed in different ways. If you are starting the installation from BIOS then its installing all the updates but if you are trying to install the windows from your previous desktop it's missing to install some updates. To ensure that updates are integrated or not....mount your customized windows manually using dism and locate the following path

%temp%\rt_mount\windows\servicing\packages\

In that folder you can see all the integrated updates file in .mum and .cat. Check whether all your updates KB is present. If it's present then it results RT 7 Lite integrated the updates correctly otherwise it means rt 7 lite is not working. Regarding WPI, you will not get that restart mode in coming new build.

Link to post
Share on other sites

As much I understood, "Lastsession.inf" is the result of RTSe7enLite integration and can be used to check how goes the integration, BUT it NOT used for Win7 installation.

Therfore if everything goes fine it can be throw. Isn't it???

Yes, if you want you can delete the "Lastsession.inf" at the root of your DVD before to create your ISO file!

And as bensam56 said you can check if the updates are installed inside the Vitual Machine:

%systemdrive%\Windows\Servicing\Packages

Edited by myselfidem
Link to post
Share on other sites

I don't know what's your great confusion here to use.....If you something wants to remove on the left side which is permanently removed if same app found found on the default windows features you have to uncheck that first. Both are linked.

Well, I was (and partially still am) confused because it's not SO obvious. I know it's simple to you, but not to me :P

I mean, when you use the program the first time (or maybe when you simply don't know it too well yet), how are you supposed to know how exactly this works?

How about if you add a simple line of text above the panels saying something like "Right panel works in the same way as Enable/disable Windows features option from Control panel, and if you want to remove something permanently, it must not be ticked on the right panel"? That would clear things perfectly. I mean, even people here gave me various explanations (like having to tick stuff in the right panel first in order to being able to remove it in the left).

Saving last session is working good. Your output will be saved only after every operation completed successfully. It will not save it instantly after you giving the name and path. For drivers, it will take the inf if it's related files found otherwise it will exclude that. Nvidia and AT drivers integration is fixed in upcoming new build. If you select Multiple drivers button, rt 7 lite will search upto the last root folders. Suppose if you select just windows, it will search every inf under that folder. Also it will read the entire inf to locate its related files. I can say...its working good.

Automatic saving of lastsession.inf works and it did before indeed, but that is not what I meant at all.

Maybe I misunderstood, but when when I click on Settings in the main window, untick "Save current settings", which ungreys the "Save as" button, I believe I should be able to select a path where the settings will be saved instead of the default location somewhere inside RT7's folder. It simply does nothing and no matter what I do, the file doesn't appear in the location I specify (after the whole process of course, I don't expect the file to be created straight away /it wouldn't make any sense anyway/). So my conclusion is specifying custom location of the settings doesn't work, unless I am missing something.

As for the integration, let me try to make a few screenshots to show you what I mean.

Firstly, let's say I want to integrate chipset drivers which are located att e:\Install\ovladace\chipset\9.2.0.1015\WIN7\.

On the integration screen I go "Select multiple drivers" and navigate to the folder where they are located.

drivers1.th.png

The problem is that when I press ok, I get blank screen, just like this:

drivers2.th.png

Now the way to go around this is to select the whole 9.2.1015 folder, and finally there is something in the little window!:

drivers3.th.png

Voila! It worked!

drivers4.th.png

This really looks like a bug to me (not quite important, but slightly annoying in my opinion).

By the way, what exactly does "boot WIM image only" mean? Like drivers that will only be used during setup? Or something else?

Anyway, really looking forward to version 1.7.0.

Edited by TheWalrus
Link to post
Share on other sites

rt 7 lite uses dism for updates integration....Updates are being installed in different ways. If you are starting the installation from BIOS then its installing all the updates but if you are trying to install the windows from your previous desktop it's missing to install some updates. To ensure that updates are integrated or not....mount your customized windows manually using dism and locate the following path

%temp%\rt_mount\windows\servicing\packages\

In that folder you can see all the integrated updates file in .mum and .cat. Check whether all your updates KB is present. If it's present then it results RT 7 Lite integrated the updates correctly otherwise it means rt 7 lite is not working. Regarding WPI, you will not get that restart mode in coming new build.

As far as I know, I allways start the installation from BIOS. In other words, I boot from my RTSe7en prepared Win7_DVD and start the installation.

As i wrote here above I've added 97 updates (see here above Lastsession.inf).

I've only 44 integrated updates in %systemdrive%\Windows\Servicing\Packages

WHY?

By mounting the RTSe7en prepared Win7_DVD i got the same amount of integrated updates but much more packages

WHY?

Regarding WPI, I've seen HERE that the Rt Seven Lite - Rc V1.7.0 will ba avilable soon. Can't wait... I can be yr beta tester.

@myselfidem : TNX for the %systemdrive%\Windows\Servicing\Packages info

You have a PM

Regards

Link to post
Share on other sites

Hi, I have a problem. I have made my image but I am trying to do an unattended install from a 250 GB USB HDD. I formatted a 10 GB partition, set as active and done the bootsect thing. It boots up fine, but none of the unattended options work! It still asks for license agreement, version select, username creation etc... Why is this happening? When testing the image in vmware the unattended install works fine, I just select partition and it installs everything by itself.

The "USB Bootable" option in RT7lite doesn't work (doesn't detect my hard drive, I guess it is only for USB FLASH drives not HDD, wtf) so I can't use that either. Can someone tell me what the USB Bootable option does so I can do that for my USB-HDD and make the unattended options work? Thanks

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...