Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Sign in to follow this  

winxp & win2k networking problems

Recommended Posts

I currently have 3 computers, a Sony laptop w/ win2k sp4, a Dell desktop running winxp sp2, & a thinkpad x41 running winxp tab ed sp3 connected wirelessly to a 2wire modem/router supplied by AT&T w/ 2 printers connected via ethernet cables to the router. All 3 were previously networked together for file sharing using a linksys router. I also had the tablet & desktop configured to access the desktop using remote desktop on the tablet, but remote desktop crashed repeatedly. When I changed routers I only had the tablet & desktop working so it was an all winxp lan. I disabled remote desktop configuration when I changied routers

At first I was using simple file sharing because I was using windows briefcase to synchronize to my ext hd backup and it required simple file sharing. I had no problem accessing the web or printers from either computer, and I could go from the tablet pc to the desktop w/out any problem, but I couldn't access the tablet from the desktop. I spent months trying this and that and rerunning the network wizard and someone suggested turning simple file sharing off, so I did and ran the wizard again and - connection both ways. And I have no idea why.

Recently I had to replace the hd on the tablet, and while it was having its hd erased and waiting to get the new hd installed, I had time to troubleshoot the Sony, which I last used in april 2007 when it suddenly would only boot in safe mood and life was double hockey sticks so I didn't have time/energy to troubleshoot. Altho the desktop has the nice, large monitor and good speakers, I can't sit up at it for long so I end up doing the majority of my computer work on the portable currently working and using the desktop as more of a file storage server. I'd much rather work on the Sony than the tablet w/ its small screen and no-hear speakers cleverly placed on the bottom of the computer.

Resting in its satchel while being moved from place to place cured the Sony and it booted right into win2k. After changing Sony's workgroup name to the new one, adding an account w/ a username/pw identical to one on the desktop and configuring the linksys adapter w/ the new SID & security key I got a connection to the workgroup and web. But altho I could open files from the desktop, I couldn't save any files or create files/folders on the desktop. Both sharing & local security permissions on the desktop's shared folders give full permission to the common account.

I then spent several days updating the Sony [80+ security updates] & reinstalling the OS in the tablet and updating it from there [60+ security updates]. I used a different pw on OS installation for The Administrator account on the tablet, but I created administrator & power user accounts w/ the same usernames/pws as the desktop. So all three computers have a power user account w/ the same username & PW and the desktop & tablet have an administrator & a power user account w/ the same username & PW.

I then ran the network wizard on the desktop, created a "disc" and ran that on the tablet and the tablet connected right away to both the desktop & Sony. Only now I'm getting an "access denied" message if I try to access the desktop from the Sony - I lost my list files and read permissions.

I can access the tablet and save to/create folders from the sony and both the desktop & tablet can save to/create folders on the Sony and each other. When I access the Sony from the desktop or tablet or the desktop from the tablet I simply click on the folder under network places and it opens. When I click on a folder on the tablet under network places from either the sony or desktop I get a dialog box to type in a user name & pw, which I do, and then I get access. That difference in connecting happened when I had two win2k computers networked and I never figured out why.

My understanding is that for file sharing to work, it is only necessary to have a user account w/ the same username & password on each computer. I was googling for win2k + winxp file sharing problems and one article mentioned having the same administrator username/pw, but I had connectivity earlier w/ the same power user accounts.

I also understood that classic file sharing on winxp does not require the guest account and I disabled them on both the desktop & tablet back when I switched from simple file sharing. The network wizard apparently re-enabled the guest account again on the desktop, but I disabled it on the tablet when I was going thru my security checklist and there's no connectivity problem between the tablet & desktop. The guest account is disabled on the sony and was disabled when I had read permission on the desktop.

Any ideas on some setting the network wizard would have made on the desktop that blocks the sony - either because it's win2k or because the wizard made "disk" can't be run on win2k?

Share this post

Link to post
Share on other sites

Has anyone networking three computers to share files had it work by using one account w/ the same username & password on all 3 computers?

Today when I clicked on the desktop share from network places on the sony, instead of "access denied", I got the dialog box asking for UN & PW. I put in the UN&PW common to all 3 computers and then I got the message "The credentials supplied conflict w/ an existing set of credentials".

I thought maybe 3 computers couldn't share the same username/pw combination - something like a joint account token established between two connecting computers using one shared account so another shared account is necessary for a 2nd computer to connect. So I created another set of accounts on the sony & desktop sharing the same un&pw, added the user to the shared permissions on both computers, and rebooted. I first tried accessing the desktop from the sony, I got the logon box, put in the new un&pw and got access w/ write privileges to the shared desktop folders. Ha! I thought. But when I went to see if I could go from the desktop to the sony, I got the logon box, but the new common un&pw didn't work. So just for the heck, I put in a un&pw for an account on the sony not shared by the two computers - both have accounts using that pw but w/ different user names. That one worked & I got write access to the shares on the sony. Then I went to the thinkpad and got write access to both the sony and desktop just by clicking on the shares in network places - no logon box so I don't know what account(s)it's using. Then I tried going from the sony to the tablet, got the dialog box, and the un&pw common to the tablet & sony failed. So again I put in a username & pw for an account on the tablet not matched on the sony and got write access.

And once again I'm thoroughly confused. If my theory was correct, I would need 3 shared accounts, every computer would have 2 shared accounts, and no two computers would have the same pair. In order to fix my setup, I'd have to delete one shared acct from the desktop.

Being unable to go both ways using the shared account doesn't fit w/ my theory, however, Being able to log onto the tablet from the sony using an account combination not on the sony and to do the same from the desktop to the sony, however, doesn't fit w/ what I've read about win2k/winxp networking. Not that I've ever found an adequate explanation anywhere about how nt computers connect to share files.

Share this post

Link to post
Share on other sites

How it works for me (simplistic setup); other methods fail -

3 PC's, below defined on all 3,

each having "Folder Shares Security=Usr1+Usr2+Usr3",

and whatever Accesses are allowed on the Given PcN-

Usr1/Pwd1 -> On Pc1, can connect to Pc2/P3

Usr2/Pwd2 -> On Pc2, can connect to Pc1/P3

Usr3/Pwd3 -> On Pc2, can connect to Pc1/P2

(p.s. you might want to remove "Everyone")

Note: Accesses via "Share Security" can be done via UserGroups and assigning the predefined UsrN's to them.

A Server will(?) allow for more complicated structures( :unsure: ).

Edited by submix8c

Share this post

Link to post
Share on other sites

Thanks submix8c,

Currently I can get from any computer to any computer and I can copy/move files between all three, but I've found that I can't copy a folder from computer 1 to computer 2 and then from 2 to 3 or I'll get the credentials conflict message. But I can create a folder on the 3rd computer and copy all the files over from 2 that I copied from 1 w/out problem. If it stops working I'll create new accounts or rename an account so that I have 3 accounts w/ the same UN & PW on all three computers and added to Share Permissions.

I don't know why it's working since two of the accounts I use to go between computers aren't shared by those computers, the username is different on the accounts that have the same pw. It's like I'm logging in locally. And I don't get why the logon box shows up on some connections and not others.

I have everyone off any shares on the win2k computer - been doing that since 2002 since win2k's everyone includes unauthenticated users. I don't really use groups since my users are all me and only me. My intended setup was to have an extra administrator account as advised [and make that the recovery agent for using encryption] and a power user account to use for daily work as advised on all computers and to have all document folders accessible by me [and only by me] from whatever account I logged into on whatever computer. So on my win2k shared folders I added all my user accounts to share and security permissions and gave them all full control, left system and creator owner and removed everyone and any other groups.

WinXP is a bit different and I read some conflicting stuff that made me hesitate to remove the everyone group.

As I understand it, on both win2k & winxp deny takes precedence over permit, so you don't deny everyone - especially from c:\. But removing the everyone group from folders isn't a deny - at least not on win2k - it's just a lack of privileges. Since user privileges = highest of user + group privileges, I can just have the users themselves on the folders - plus system.

The Shared Folders function/applet/whatever in Administrative Tools is nice & convenient when I remember it's there - esp when I can remember its run command [fsmgmt.msc]

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.