Jump to content

How to get the cause of high CPU usage caused by apps?

Recommended Posts

  • 5 weeks later...


For the past month my CPU has been going from 0%-40% sometimes even to 100%. I checked the resource monitor and saw that NT Kernel and System is responsible but I don't know what program or application is causing the problem. I performed a trace and I have the result up on mediafire. I'm using Windows 7 x64. Can you help?


Link to comment
Share on other sites


as you can see in the picture the iastor.sys causes 16% of the CPU usage.


This driver belongs to the Intel storage driver. You use version Is this the latest version? If not, update the driver. If this is the latest driver, use the version before this driver. If the issue still occurs, check your Hitachi HDD for errors (run chkdsk C: /r /f) and run a diagnostic tool from Hitachi.


Link to comment
Share on other sites

Ok I'm not too good with computers but I went to Device Manager and went under Disk Drives and found Hitachi HT followed by some letters and numbers. Is this the one I have to uninstall? I checked for updates but it said everything was good.

Link to comment
Share on other sites

Ok it's happening again. How Do I delete the driver? I tried looking for the previous driver on the HP website but I can't find it. Do I have to keep searching or is there somewhere else I can find it?

EDIT: Nevermind I found out how to uninstall and I found the previous version. Once again thanks for your help André.

Edited by Dragonmaninferno
Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...

Hi -

I've been searching for a while trying to solve the same issue and your forum seems to be the most proficient and your response prompt.


- Laptop CPU 100% typically when viewing videos or flash, but I cannot always confirm this is the cause. Typically though while in a browser.

- Dell Laptop (detail below) recently upgraded to Win 7 64

- Same issue happened on Vista and I thought the upgrade would take care of it

- Disabled Windows Media Player Network Sharing Service and didn't seem to work

- Unplugged monitor (Hannspree HDMI) because I thought it was a driver issue, didn't have a long-term effect.


Dell Studio

Intel Core 2 Duo CPU T6500 @ 2.1 Ghz


Windows 7 Home Premium SP 1

I have downloaded the SDK and installed but the xperf command shows as invalid. I have read the post in Nov. 2010 with this " PATH environment variable and check if the path to the WPT was added". How do you check this variable/path?

I have changed the registry key as you instructed for 64 bit Win 7.

If I can run your commands I will post the issue here for your evaluation if I cannot figure it out.

Thank you in advance.

- t

Link to comment
Share on other sites

That worked. Thx.

Here's my test:

- Open Chrome Browser

- Go to CNN.com and play a video and waited about 1 minute for CPU to hit 100%

- Captured a .etl file for two instances.

Instance 1 = Playing video in browser then pausing

Instance 2 = Closing Chrome tab for video

.etl files are large so I have only attached screen shots of these. Once I finish this post I will zip and post the smaller file (55 MB) if you wish to see it. I stopped my video test approx. 25 mins ago and the CPU is still at 100% or very close to it, so it is very slow zipping and FTPing a file.

Attached are four files:

Capture_1a = Summary table from Instance #1

Capture_1b = Summary table with Chrome.exe expanded

Capture_2a = Summary table from instance #2

Capture_2b = Expanded

You'll notice Task manager is open as well and I did this to monitor CPU but Task Manager also locked up and required reboot twice while getting the .etl files.

I'll post a zip location of the smaller etl if you want to view this.

Thank you.





Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...