Jump to content

Final ESU Updates for Windows 7 SP1 (Retired!)


Recommended Posts

Hello, steven4554!

I went over security bulletins and put together my own update tree for Windows 7 64 bit SP1.
I noticed some things when comparing with your list.

Consider the following patch replacement chains:

2476490 < 2564958
You have included both. Suggest removing 2476490.

2503658 < 2544893
You have included both. Suggest removing 2503658.

2479628 < 2506223 < 2525694 < 2555917 < 2567053 < 2617657 < 2639417 < 2660465 < 2641653 < 2676562.
You have included 2525694 and 2676562. Suggest removing 2525694.

2620712 < 2813170 < 2859537 < 2872339
You have included 2620712 and 2872339. Suggest removing 2620712.

2644615 < 2859537 < 2872339
You have included 2644615 and 2872339. Suggest removing 2644615.

2507938 < 2567680 < 2790113 < 2859537 < 2872339
You have included 2790113 and 2872339. Suggest removing 2790113.

2508272 < 2618451
You seem to not include this patch (ActiveX Kill Bits)?
Suggest including 2618451.

2475792 < 2510531 < 2706045
You seem to not include this patch (Vulnerability in JScript and VBScript engines)?
Suggest including 2706045.

2489256 < 2716513
You seem to not include this patch (security update for FTP Service 7.5 and FTP Service 7.0 for Internet Information Services 7.0)?
Suggest including 2716513 and 2719033.

2721691 < 2758694
You seem to not include these patches (security update for XML Core Services 4.0)?
Suggest including 954430 and 2758694.

2601626 < 2621146 < 2772930
You seem to not include these patches (security update for Active Directory)?
Suggest including 2772930 and 2853587.

You included this patch (security update for Windows Media Format Runtime 9 and 9.5 (wmvdmod.dll), and for Windows Media Player 11 and 12) under the "WMP12 updates" area, but it is a security patch that also fixes Format Runtime. This can be used by applications other than Windows Media Player. I for one only realized it is an important security patch after encountering it in the bulletin. In the Windows Updates Downloader, the category looked unimportant (some users don't use WMP, but still play WMV videos). Suggest moving 2803821 to security updates area.

Some of the missing updates do look like they might not be a part of Windows 7, but instead require additional download and installation?
My appologies in that case. Could you point those out?

If you don't mind me asking, where do you get information on non-security patches? I can't seem to find a listing or bulletins for those.

Thanks :blushing:

Link to comment
Share on other sites

can i have some light on update KB2574819 (Update for Windows 7 for x64-based Systems)

this update first got Synced from SCCM (SUP) but doesnt deploy to systems.

manual download from MS site and its installation works though... is it because MS re-released it with V2

(V2 is the one which is available for download now Windows6.1-KB2574819-v2-x64.msu)


Edited by jithuraj
Link to comment
Share on other sites

Hello Steven,

A very minor problem; update KB2834140 under Non-Security Updates (for both the X64 list and the x86 list) is not downloading. I checked the .UL file and the filename is missing '-v2' in the URL thus:



(above for X64 obviously!)

Nothing mission critical!

Edited by JonnyT1978
Link to comment
Share on other sites

  • 2 weeks later...

Hello Steven,

Sorry for the lack of reply, been away with work. Yes you are correct, I re-downloaded your September list and -v2 of the update downloaded correctly this time.

KB2791765 is being offered post-install using your latest UL - the KB is here: http://support.microsoft.com/kb/2791765

Edited by JonnyT1978
Link to comment
Share on other sites

So i'm having a bit of an issue here and hopefully somebody else has had it and/or has info about how to fix it. I'm using RT 7 Lite to create images with these updates slipstreamed in. I'm doing all of the .NET, Security, Non-Security and Optional updates, but after I install with the image and try to sync the time, I get "Unable to start the Windows Time service"

The trick is I've had this problem in the past and fixed it. The issue lay within updates that were conflicting with each other somehow. Removing the offending updates (There were 3 or 4 iirc) resolved the issue completely. However the issue now being that I can't remember exactly what updates I had removed to rectify this.
As I see it, there are 2 options

-Rediscover what updates were the problem causers and remove them
-Use a program other than RT7 Lite (Nobody else is complaining about this issue so I assume it's something specifically caused by these updates + that program)

Any suggetions? Thanks!

Edited by Internetlad
Link to comment
Share on other sites

Please, for the love of god or whatever you might believe in, do not use RT7Lite! That program is outdated by several years, and even when the "company" behind it still existed, it was buggy as hell up to the point of messing things left and right.

You can get something that's light years ahead of that junk: Win Toolkit. Give it a shot, and maybe you will find out numerous problems went away!

Link to comment
Share on other sites

The main problem with RT7L was that it deleted components forcefully where as WTK uses built in component removal that is a lot safer.

I used RT7L up to beginning of this year. Now using WTK.

Link to comment
Share on other sites

Thanks i'll try it out.
EDIT: Tried this out today. Loaded all the updates into the AIO integrator and did a couple minor tweaks (Change IE homepage, folder views, etc.) And I got a message near the end of the install

The pop up box, verbatim says "Windows could not configure one or more system components, To install Windows, restart the computer, then restart the installation."

Is this a common issue? I'll try again today without the tweaks (Just the updates) and see what happens until I hear back.

EDIT 2: Banged out another image today and this one seems to work! I left out the tweaks and I guess something in there was causing the issue. . . Weird right? I also left out the IE10 update. . . Maybe that was it?

Don't know. If anybody else is familiar with the issue hang me a line.

Edited by Internetlad
Link to comment
Share on other sites

UPDATE: Seems to have something to do with removing the config file to unlock all the versions of windows on the same disk. I guess you can't do that with th(e win toolkit) despite the option?

Edited by Internetlad
Link to comment
Share on other sites

  • steven4554 changed the title to Final ESU Updates for Windows 7 SP1 (Retired!)
  • dencorso locked and unlocked this topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...